Why the long delay before an incoming landline call rings the OBI110 phone port?

Started by chetstone, December 01, 2011, 01:07:54 PM

Previous topic - Next topic

chetstone

I have one phone hooked up directly to my landline. It starts ringing immediately when a call comes in. After 2-3 rings the phone attached to my OBI starts ringing. I've verified that it's not a problem with the phone attached to the OBI by hooking both phones up directly to the landline. They both ring at the same time.

chetstone

OK, I found the RingDelay parameter which was set to 4000. Setting it to 0 solved the problem.

Stewart

The delay is there, so the OBi can learn the caller ID and propagate it to the connected phone.  Setting RingDelay to 0 will lose that feature.  Of course, if your landline doesn't have caller ID service, or if you don't care to see the number on the phone attached to the OBi, a value of 0 should be fine.

chetstone

Quote from: Stewart on December 01, 2011, 07:11:46 PM
The delay is there, so the OBi can learn the caller ID and propagate it to the connected phone.  Setting RingDelay to 0 will lose that feature.  Of course, if your landline doesn't have caller ID service, or if you don't care to see the number on the phone attached to the OBi, a value of 0 should be fine.

The phone attached to the phone port seems to display the caller id number fine with a setting of 0.

Can the OBI look up the incoming number in its speed dial list and display the associated text?

infin8loop


For what it's worth, I have AT&T POTS service connected to the OBi110 LINE port. Sometime ago, when I changed the RingDelay from the default 4000 to 2000 it seemed like it worked. That is, until I noticed the OBi call log was missing callerid information on some calls coming in on the LINE port. I increased the RingDelay to 2500 and the OBi call log issues went away.  Yup, I still hear the wired phone connected to the AT&T line ring before the cordless connected through the OBi but the delay isn't as annoying at 2500 as it was at 4000.  And the call routing on the OBi seems to be working.  When it comes to the OBi the word seems seems to come up a lot.
"This has not only been fun, it's been a major expense." - Gallagher

RonR

RingDelay is time the OBi waits before processing InboundCallRoute rules.  If RingDelay is set too short and CallerID is not decoded by the time it expires, InboundCallRoute rules based on CallerID will not be effective:

Delay in milliseconds after initial ring detected on the LINE port before the device acts on the call (to route it according to InboundCallRoute). This value could be 0 so that the call is handled immediately. However, you should consider setting it to a large enough value to allow OBi to completely decode the PSTN Caller-ID signal if the service is available on the PSTN line. This is required if the InboundCallRoute relies on Caller-ID information to route the incoming call.

Novice

So it looks there are some conflicting reports. To clarify, if i don't have any InboundCallRoute handling, can I set it to 0 and still have the caller ID show up after a ring or 2 (same as if the phone is directly connected to the telco), or will the OBI not be able to display the caller ID at all.

Thanks

hwittenb

Quote from: Novice on December 25, 2012, 08:30:49 PM
To clarify, if i don't have any InboundCallRoute handling, can I set it to 0 and still have the caller ID show up after a ring or 2 (same as if the phone is directly connected to the telco), or will the OBI not be able to display the caller ID at all.
No you will not have the caller id to display on your phone if you set the ring delay to zero.

On a Line Port call, the OBi listens for the caller id during the ring delay period.  When that period expires it quits listening.


hwittenb

Quote from: claude on December 26, 2012, 02:00:35 AM
where you fix the delay?
There is nothing to fix if you use the default settings.  The default setting is 4 seconds (4000ms).

The setting is under Physical Interfaces-->LINE Port-->RingDelay

claude

claude

azrobert

Said by hwittenb:
QuoteNo you will not have the caller id to display on your phone if you set the ring delay to zero.

Obihai fixed this problem and the caller id will be displayed if ring delay is set to zero.
I remember reading it somewhere, but I can't find it now.  To verify my memory, I just tried it and it does work.

You still can't test for caller id in the inbound call route if delay is set to zero or set too low.

hwittenb

I tested it before I posted last time and it didn't work.  I tested it again just now and it works, so I guess it is fixed.

Diana

Did you do a Firmware update to your OBi110 in the last day or two?  That is the only way I know of for them to have fixed the problem.  Care to explain?

Quote from: hwittenb on December 27, 2012, 10:46:14 AM
I tested it before I posted last time and it didn't work.  I tested it again just now and it works, so I guess it is fixed.

azrobert

The OBi will start to display the caller id as soon as it's processed.
Maybe the caller id wasn't processed in time for the first ring and hwittenb hung up before it was displayed on the second ring.

That's what the ring delay is for.  It delays other processes like inbound call route until it has the callerid.

hwittenb

I tried it some more times this evening with the RingDelay set to 0 and the caller id seems to always display as long as you have no other activity in the Line Port incoming routing except routing to the phone (ph).  I guess with my first test where it didn't work there must have been something wrong with the test.

If I also have some other activity in the incoming routing like forking the call to another phone the caller id doesn't display on the phone.  Actually it did display when I was using CallCentric to send the call to my PSTN line, but it would not when I tried calling three other ways and it always displayed on an external display on the phone line so AT&T was sending it each time.

Novice


ipse

Quote from: Novice on January 01, 2013, 07:18:30 PM
I've set RingDelay to 0 and it has been working well for me.
Only with VoIP calls...for PSTN (at least in NA) the CallerID info is sent between the first and second ring:

http://what-when-how.com/voip/fsk-caller-id-on-pstn-voip/

You cannot set the delay to zero for PSTN is US or Canada. I tested this in Canada - even my phone connected directly to POTS does not get the CallerID info before the second ring.
VoIP is a different story.
Of all the things I lost, I miss my mind the most. - Mark Twain

Novice

To clarify, with RingDelay set to 0, the phone started ringing immediately with no caller ID, but caller ID showed up after the second or third ring. Basically, my phone was behaving the same as if it wasn't connected to an Obihai at all, which is what I was trying to achieve.

However, it recently stopped working - the caller ID never shows up anymore for calls coming in on the PSTN line.
Any suggestions on how to fix this (for those who were actually able to get it to work).

The frustrating thing with my Obi is that even though I don't change any settings, things always seem to stop working properly.

ipse

All I can tell you is that for true PSTN LINE, I have to set it to min 2800ms to register CallerID.
In my case, RingDelay=0 really means the system NEVER gets the CallerID info - verified with logs and with "Call Status" while it's ringing.
Based on what I wrote before about CallerID info being sent after the first ring, it makes sense.
Of all the things I lost, I miss my mind the most. - Mark Twain