On Tuesday September 6th the forum will be down for maintenance from 9:30 PM to 11:59 PM PDT

Main Menu

New OBi100 and ViaTalk setup help needed

Started by ck42, January 04, 2012, 02:23:04 PM

Previous topic - Next topic


So just got the OBi100 and am attempting to swap it out for the Linksys adapter.
I found what little I could find on setting up OBi for ViaTalk, but it's not registering.

At one point, I thought maybe the password it was looking for was different than the one that I use to login to my ViaTalk account, so I found on the VT website some setup info for some other non-OBi device and it gives examples for me that seem to reflect my account info...including some other password.
I tried plugging in this other password as a test and rebooted.
Refreshing the Status page on the OBi caught the message:

Register Failed: 401 Unauthorized (server=; retry in 5s)

The IP address translates to the server I have configured in it is at least making the attempt.

So, I went back in and put the original password and tried again.  Same "Unauthorized" message.

Now this has me wondering if maybe VT has to authorize adapters....maybe I need to have 'allow' by OBi to register??

Am running with the latest 1.3.0 firmware.


Assuming you have Google Voice on the SP1 Service and want to put ViaTalk on the SP2 Service, set:

Service Providers -> ITSP Profile B -> General -> Name : ViaTalk
Service Providers -> ITSP Profile B -> SIP -> ProxyServer : (ViaTalk provided proxy)
Service Providers -> ITSP Profile B -> SIP -> OutboundProxy : (ViaTalk provided proxy)
Voice Services -> SP2 Service -> X_ServProvProfile : B
Voice Services -> SP2 Service -> AuthUserName : (ViaTalk phone number including the 1 and the area code)
Voice Services -> SP2 Service -> AuthPassword : (ViaTalk provided password)
Voice Services -> SP2 Service -> CallerIDName : (callerid name)

Everything else on SP2/ITSP B should be at Default.


#2 it turns out, I DID need to be using that other password shown on the VT website (opened ticket and got response showing that same *other* password).
I think what may have happened when I originally tried to use it is that I didn't reboot the OBi after entering the p/w.

So now...I'm registering. Yay!  First hurdle over with.

But now, on attempting outbound calls, I get a 407 message indicating "End Call (407 Proxy Authentication Required)"

I'm certainly not anywhere near being a VoIP expert, but this seems contradictory to me.  I'm showing as registered, but it's telling me that auth is required???

Regarding the use of the Outbound Proxy (Using the VT provided proxy)....I thought this setting was for cases where the OBi needed to reach through a proxy server on my network, which I'm not doing - but I can if I want.


You can try blanking out the OutboundProxy field and see what happens.  ViaTalk's examples used it, so I included it.

You haven't set any fields other than what I suggested, have you, like URI?  Make sure all SP2 and ITSP B settings are at Default except for the ones specified.


Everything is defaulted, other than what you specified with the exception of the RTP port range....only because I have certain rules setup on my firewall to use a different port range.  This really shouldn't affect it since it was working with the PAP2T.

But now......I'm back to square 1.  Not registering.  Defaulting something broke it again.  :-\

[EDIT] Took out the Outbound Proxy and it's registering again.

In any case, still getting the 407 message.

Realized that I forgot to change the IP address for the OBi on my Static NAT port setup on the firewall.  Also went ahead and defaulted the RTP ports and made the necessary range change on the firewall too.


Inbound calls will cause the OBi line to ring, but when answered, nothing.  On the caller's end, it never sees the 'pickup' and just keeps ringing.