GV missed calls - when answered by home machine?

Started by offroad, January 13, 2012, 11:59:51 AM

Previous topic - Next topic

Stewart

On a free or paid CC account, you can make free toll-free calls by sending e.g. **275*18005551212.  This routes the call via SIPBroker and does not require two-stage dialing.  From an OBi not specially configured, you would have to dial e.g. **2**275*18005551212.

However, you can configure the OBi digit map to do this automatically, i.e. you would dial 18005551212 and the OBi would automatically select SP2 and send **275*18005551212.  The result would be that all toll-free calls would go via Callcentric and SIPBroker, which is IMO a good thing, because you'll know the CC service is working, should you ever need it for 911.

The 911 service is configured for your physical address and does not directly depend on your phone number.  If you call 911, in addition to your address, a special temporary number is displayed to the dispatcher, which they can use to call you back, in case you get disconnected or hang up inappropriately.

Having nothing to do with 911, you can set up your home number (whether or not ported to GV) as an outbound caller ID for Callcentric, so any calls you make with their service will show that number to the callee.

RonR

FWIW, ...

1. You don't need a Callcentric or any other account to use Sip Broker.

2. Calling the number you PM'd me using SIP Broker does not get an answer.

Stewart

Quote from: RonR on January 15, 2012, 09:27:09 AM
Calling the number you PM'd me using SIP Broker does not get an answer.
RonR,

For me, calling 1-800-426-7378 (IBM service) fails with GV (including via Gmail), works with Callcentric and Anveo, works (though with slow setup time) when dialed via SIPBroker access number 1-646-810-9280, and works with **275*18004267378 sent to Callcentric.

RonR

Using a Sip Broker PSTN number, the call goes through.  Using Sip Broker directly, it does not.

Stewart

Quote from: RonR on January 15, 2012, 09:56:26 AM
Using a Sip Broker PSTN number, the call goes through.  Using Sip Broker directly, it does not.
Works for me, sort of.  The call appears to go through correctly, and starts playing the prompt, but SIPBroker decides something is wrong and retries, presumably on another carrier.

Note that the format for SIPBroker (directly) is *18004267378.

I don't recommend SIPBroker for general toll-free termination, because there seems to be noone minding the store.  They still don't know about area code 855!


offroad

#25
Registered for a free CallCentric account and tried to set it up with the OBitalk wizard but OBitalk shows:  

Configure Voice Services
Service Provider 1   Google Voiceâ„¢ Account      Connected      
Service Provider 2   CallCentric Account   Register Failed: 500 Server Internal Error (server=204.11.192.35:5060; retrying)

CallCentric's website says my phone is not registered
Followed the guide they have for an OBi100 and filled in all info, but couldn't figure out where to put this:
Digit Map:   (*xx.|**275*x.|[3469]11|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

Any ideas what I've done wrong?

RonR

Quote from: offroad on January 15, 2012, 12:49:07 PM
Followed the guide they have for an OBi100 and filled in all info, but couldn't figure out where to put this:
Digit Map:   (*xx.|**275*x.|[3469]11|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

Use this:

Service Providers -> ITSP Profile B -> General -> DigitMap:

([2-9]11|**275*[x*][x*].|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1aaa>[2-9]xxxxxx|011xx.|(Mipd)|[^*#]@@.'@'@@.)

where aaa is your local area code.

RonR

Quote from: offroad on January 15, 2012, 12:49:07 PM
Service Provider 2   CallCentric Account   Register Failed: 500 Server Internal Error (server=204.11.192.35:5060; retrying)

CallCentric's website says my phone is not registered

It shouldn't take very much configuring:

http://www.obitalk.com/forum/index.php?topic=1039.0

Stewart

Quote from: offroad on January 15, 2012, 12:49:07 PMService Provider 2   CallCentric Account   Register Failed: 500 Server Internal Error (server=204.11.192.35:5060; retrying)
Try enabling ITSP Profile B -> SIP -> X_DnsSrvAutoPrefix .

offroad

Quote from: RonR on January 15, 2012, 01:13:14 PM
Quote from: offroad on January 15, 2012, 12:49:07 PM
Followed the guide they have for an OBi100 and filled in all info, but couldn't figure out where to put this:
Digit Map:   (*xx.|**275*x.|[3469]11|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

Use this:

Service Providers -> ITSP Profile B -> General -> DigitMap:

([2-9]11|**275*[x*][x*].|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<1aaa>[2-9]xxxxxx|011xx.|(Mipd)|[^*#]@@.'@'@@.)

where aaa is your local area code.

I checked about an hour later and OBiTalk now shows:
Service Provider 2   CallCentric Account   Registered (server=204.11.192.39:5060; expire in 29s)

CallCentric now shows:  Your Phone is Registered

Apparently I was just a bit impatient.

I did go ahead and put in the string listed above into digit map field for ITSP Profile B (except for changing the aaa to my area code), don't have time to test it tonight but will tomorrow. 

What exactly does this string define?  I see its different than the one on CallCentric's website.

RonR

Quote from: offroad on January 15, 2012, 07:24:09 PM
What exactly does this string define?  I see its different than the one on CallCentric's website.

It's the dialplan for the Callcentric trunk:

[2-9]11  ->  211/311/411/511/611/711/811/911

**275*[x*][x*].  -> Sip Broker code + number

1xxxxxxxxxx  ->  11-digit numbers starting with '1'

<1>[2-9]xxxxxxxxx  ->  10-digit numbers starting with '2' to '9' ('1' is added)

<1aaa>[2-9]xxxxxx  -> 7-digit numbers starting with '2' to '9' ('1' plus area code added)

011xx.  -> 011 + country code + number (international dialing)

(Mipd)  ->  18005551212*76*10*223*207 (IP dialing : 18005551212@sip.tollfreegateway.com)

[^*#]@@.'@'@@.)  ->  18005551212@sip.tollfreegateway.com (SIP URI dialing)

offroad

It seems that perhaps Call Centric / OBi don't like my Verizon 4G LTE USB aircard.
While I've been experimenting with the OBi110 in an effort to get rid of our POTS, I have also been experimenting with replacing our current WISP internet provider with Verizon 4G LTE service.

The WISP service is only 512k and the latency is too high for smooth calls with the OBi and GV.
With my company Verizon 4G USB modem only showing two bars, I get 4-8mbps and excellent call quality on GV.
I'm using a Cradlepoint MBR95 router that supports Ethernet and 4G USB modems so switching from one to the other is only one click.

The problem is that while both the OBi and Call Centric show registered under the WISP (Ethernet) internet service, I don't get registered with Call Centric when on Verizon 4G.  I can switch to Verizon 4G then re-power or reboot the OBi but still don't get registered on Call Centric which is SP2 on the OBi.  Google Voice seems happy on either connection.

Since GV won't work with some of the 800 numbers I need to dial, I'm going to need to get Call Centric or another secondary SIP provider to work with Verizon 4G.  Unfortunately my location limits the options I have for internet service.  Any ideas on how to make Verizon 4G play well with Call Centric?


Stewart

Try ITSP Profile B -> SIP -> X_DnsSrvAutoPrefix (checked).

If no luck, post what System Status shows for SP2.

offroad

This was already checked  -  ITSP Profile B -> SIP -> X_DnsSrvAutoPrefix (checked).  

I had deleted the SP2 Call Centric account while troubleshooting and recreated using OBiTalk so I believe everything should be at defaults.

From OBiTalk Device Configuration

Under WISP (Ethernet):
Callcentric account   Registered (server=204.11.192.22:5060; expire in 29s)


Under Verizon 4G Modem:
Callcentric account   Register Failed: 500 Server Internal Error (server=204.11.192.36:5060; retrying)

I can re-power Router/4G Modem then OBi110 and still get Register Failed showing on OBiTalk,
Call Centric dashboard goes from "Your Phone is Registered" to Your Phone is Not Registered"

Stewart

Wow!  The DNS SRV record points to port 5080, so VZ must somehow be thwarting the DNS SRV lookup.  Try setting in Network Settings DNSServer1 to 8.8.8.8 and DNSServer2 to 4.2.2.2

If no luck, try (from a PC on the 4G conection) going to a command prompt, type nslookup -type=SRV _sip._udp.callcentric.comand press enter.  Post the output.

offroad

#35
Changed Network Settings DNSServer1 to 8.8.8.8 and DNSServer2 to 4.2.2.2

OBiTalk shows:  Callcentric account   Register Failed: 500 Server Internal Error (server=204.11.192.23:5060; retrying)

Google Voice is unaffected and shows Connected

c:\>nslookup -type=SRV _sip._udp.callcentric.com
Server:  cp.local.tld
Address:  172.11.20.57

*** No Service location (SRV) records available for _sip._udp.callcentric.com


The IP address returned is the routers ip on the network the OBi is on and is also the same network the PC is on as well.

Stewart

Quote from: offroad on January 18, 2012, 10:16:18 AMc:\>nslookup -type=SRV _sip._udp.callcentric.com
Server:  cp.local.tld
Address:  172.11.20.57

*** No Service location (SRV) records available for _sip._udp.callcentric.com
Unbelievable!

Try changing (in ITSP Pofile B -> SIP) ProxyServerPort and RegistrarServerPort from 5060 to 5080.

offroad

#37
Try changing (in ITSP Pofile B -> SIP) ProxyServerPort and RegistrarServerPort from 5060 to 5080.

Changed both, saved and rebooted
ObiTalk showed that SP2 (Call Centric) Wasn't Registered

Re-Powered the OBi and now both ProxyServerPort and RegistrarServerPort show 5060 instead of the 5080 I previously put in.

OBiTalk now shows: Callcentric account   Registered (server=204.11.192.37:5080; expire in 0s)
And Call Centric shows My Phone is Registered.

c:\>nslookup -type=SRV _sip._upd.callcentric.com
Server:  cp.local.tld
Address:  172.11.20.57

*** No Service location (SRV) records available for _sip._upd.callcentric.com

The PC command return looks the same so, Why did ProxyServerPort and RegistrarServerPort revert to 5060 and since they did why is SP2 now working?

Well....I spoke too soon I guess as I'm back to:
Callcentric account   Register Failed: 500 Server Internal Error (server=204.11.192.22:5060; retrying)


Changing ProxyServerPort and RegistrarServerPort back to 5080, save and reboot and OBiTalks shows:
Callcentric account   Register Failed: 407 Proxy Authentication Required (server=204.11.192.34:5080; retrying)

A few minutes later and OBiTalk shows: Callcentric account   Registered (server=204.11.192.23:5080; expire in 0s)
Call Centric shows phone is also registered.

I'm afraid to reboot the OBi again or re-power, shouldn't these settings stick once saved?

Didn't touch a thing and now Call Centric says my phone is not registered.
Refreshing OBitalk and now I see: Callcentric account   Register Failed: 500 Server Internal Error (server=204.11.192.22:5060; retrying)

Refresh ProxyServerPort and RegistrarServerPort on OBi and now they show 5060, so something is changing the port back to 5060.  OutboundProxyPort was always 5060, could this be affecting something?

Without changing anything its now over a 5-8 minute or so time frame cycling between:
Callcentric account   Register Failed: 500 Server Internal Error (server=204.11.192.xx:5060; retrying)
Register Failed: 407 Proxy Authentication Required (server=204.11.192.xx:5080; retrying)
Callcentric account   Registered (server=204.11.192.xx:5080; expire in 29s)

Then it starts over again
xx=random ip

RonR

Quote from: offroad on January 18, 2012, 05:07:51 PM
I'm afraid to reboot the OBi again or re-power, shouldn't these settings stick once saved?

If you're making changes directly to the OBi, you must set:

System Management -> Auto Provisioning -> ITSP Provisioning -> Method : Disabled
System Management -> Auto Provisioning -> OBiTALK Provisioning -> Method : Disabled

or the OBiTALK Web Portal will keep reconfiguring the OBi back to its settings shortly after you reboot.

Stewart

Assuming that you have disabled provisioning per RonR's post and the changes are now "sticking":

On a "typical" Callcentric setup, you would put callcentric.com in ProxyServer and would leave RegistrarServer and OutboundProxy blank.  I believe that the port number corresponding to a blank field should not matter, as it would never get used.

I had suggested changing RegistrarServerPort, just in case you had filled in RegistrarServer.  I didn't even think about OutboundProxyServer.  If you set that too, either to work around a previous problem or because you thought it was a more "conservative" setup, then yes, you would have to also change ProxyServerPort to 5080 (given that VZ is blocking DNS SRV lookups).