Speed Dial Settings Speed Dial Settings

Started by Tatus, February 13, 2012, 05:08:42 PM

Previous topic - Next topic

Tatus

In Speed Dial Settings the Soft Phone has ID#1, and I can not change it.
I want to use #1 for my most often called number, but my soft phone's number is barely used.   It is very inconvenient. Is it possibly to change it?

If I  change it manually in my local device, OBiTALK Portal overwright it anywhere. 

jimates

#1
no way to change it. I think even if you don't put the device in an account number 1 is not selectable.

RonR

Quote from: Tatus on February 13, 2012, 05:08:42 PM
If I  change it manually in my local device, OBiTALK Portal overwright it anywhere. 

If you disable Auto Provisioning in the OBi, any changes you make to the OBi manually will not be overwitten by the OBiTALK Web Portal:

System Management -> Auto Provisioning -> ITSP Provisioning -> Method : Disabled
System Management -> Auto Provisioning -> OBiTALK Provisioning -> Method : Disabled

RonR

Quote from: jimates on February 13, 2012, 06:12:01 PM
no way to change it. I think even if you don't put the device in an account number 1 is not selectable.

Speed Dial 1 is usable like any other as long as you don't use the OBiTALK Web Portal.

jimates

I thought I read a post where 1 and 99 were not usable. Guess I was mistaken.

RonR

Quote from: jimates on February 13, 2012, 07:19:50 PM
I thought I read a post where 1 and 99 were not usable. Guess I was mistaken.

They're not from the OBiTALK Web Portal (1 is hard-wired and 99 is missing).

They work perfectly from the OBi itself.

Felix

Note that speed dials on the device are not overwritten even if you don't disable provisioning...

RonR

Quote from: Felix on March 03, 2012, 06:57:43 PM
Note that speed dials on the device are not overwritten even if you don't disable provisioning...

Unless something has changed in the past few days, that's contrary to everyone else's experience and what's documented in the OBi Device Administration Guide:

Page 17:

Speed Dialing of 99 OBi Endpoints or Numbers

The OBi device supports Speed Dialing of 99 numbers. These numbers can be associated with phones reachable via an Internet or landline service or the OBiTALK network. Be careful with the Speed Dial Set-Up as this will conflict with the Speed Dials set-up on the OBiTALK portal. The Speed Dials that are set-up on the OBiTALK portal will always overwrite anything set-up via the phone connected to the OBi.


Page 19:

∞ Note: Be careful with the Speed Dial Set-Up as this will conflict with the Speed Dials set-up on the OBiTALK portal. The Speed Dials that are set-up on the OBiTALK portal will always overwrite anything set-up via the phone connected to the OBi.

g10voip

how do i set this as a speed dial
my obitalk1st device connects to my second obitalk device at a remote site. ( i would like 1 stage dialing )
then calls out of the pstn port of my 2nd obitalk device to the outside world.
if i just call PP(ob200605xxx) it asks be a question of wheather i want to continue 1 or dial new number 2.
i don't want any questions to be asked!

PP(ob200605xxx)**818888868xxx
this fails,
i even tried with no tk format **9200605xxx**818888868xxx
but fails

"x = is just to hide my number"

thanks

james

ianobi

This depends on your present set up. It sounds as though the remote OBi is in your "Circle of Trust", which is ok. If the remote OBi is an OBi110 with default Primary Line, which is PSTN, then this speed dial should work:

pp(ob200605xxx*818888868xxx)


This assumes that the remote OBi has this setting:

Voice Services > OBiTALK Service > InboundCallRoute:
{200605xxx>(xx.):li},{200605xxx:aa},{ph}


Lots more info on this subject here:

http://www.obitalk.com/forum/index.php?topic=6947.0

g10voip

#10
primary is default to pstn, but InboundCallRoute said sp1 instead of li, and i put parenthesis in the middle instead of at the end of my speed dial.

thanks that solved it.

if i press speed dial 9, i want to connect to my remote obi talk pstn outside line,
without it asking press 2 to enter #, just want to be ready to dial.

i saw this note on prev link:
Voice Services->SPx Service->X_InboundCallRoute
{(Mcot):aa($1)},{ph}
but don't know if i need it on local obi or remote obi, and what it means mcot ? aa ? $1 ?

my remote inbound call route
{(290620350|200850700)>(xx.):li},{(290620350|200850700):aa},{ph}
just solved my own problem, changed aa (auto attendent) to li (outside line)
{(290620350|200850700)>(xx.):li},{(290620350|200850700):li},{ph}

new problem:
how can i make a hotline for say (where if i pickup my phone) it automatically connects to remote pstn line?
skipping the speed dial step, or it automatically linking to remote pstn.

thanks

James

ianobi

There are several ways of doing a "hotline" setup. Is this really what you want? Your local OBi then becomes just a dumb phone - all you can do is pick it up and dial PSTN numbers via the remote OBi.

My preferred method is this one:

http://www.obitalk.com/forum/index.php?topic=5076.msg32750#msg32750

It's a "master/slave" setup. Your local OBi would be the slave and the remote OBi would be the master. You pick up the local phone and get local OBi dial tone. You dial a PSTN number and it automagically gets sent out of the remote(master) OBi's PSTN Line Port. The setup in the linked post would need changing to make PSTN the Primary Line in the master OBi.

The advantage is you can also use sp1 and sp2 on the master obi and its Auto Attendant. Also call between the two OBi's and have incoming PSTN calls at the master OBi ring one or both of the OBi devices. Some thought needs to be given regarding emergency calls - the slave and master OBi's can be in different countries.

It's very adaptable. You might keep **1 and **2 available to the slave OBi, but the Primary Line - numbers with no ** codes - can be dialled by the slave and be sent out of the master's PSTN Line Port.

That's the problem with OBi's - so many different ways to configure them   :)


azrobert

#12
ianobi,

I apologize for jumping in, but I don't think you answered James' question.

James,

Add to beginning Phone port DigitMap after the beginning "("
<S3:ob200605xxx*9>|

Add to the beginning of the Phone Port OutboundCallRoute:
{(ob200605xxx*9):pp},

Add to the beginning of the remote OBitalk InboundCallRoute:
{(290620350|200850700)>(<9:>):li},

Take phone off hook. If nothing is dialed after 3 seconds you will get dial tone of the remote Line Port.

There other ways to do this. This is how I did it.

Setup a User Defined DigitMap call rmt
(91xxxxxxxxxx|9xxxxxxxxxx|9xxxxxxx)

Add to beginning Phone port DigitMap after the beginning "("
(Mrmt)|

Add to the beginning of the Phone Port OutboundCallRoute:
{(<ob200605xxx*>(Mrmt)):pp},

Add to the beginning of the remote OBitalk InboundCallRoute:
{(290620350|200850700)>(<9:>1xxxxxxxxxx|<9:>xxxxxxxxxx|<9:>xxxxxxx):li},

Dial 914801234567 and 14801234567 will be routed out the remote Line Port.
Dial 94801234567 and 4801234567 will be routed out the remote Line Port.
Dial 91234567 and 1234567 will be routed out the remote Line Port.

Edit:
I forgot to include a "*" in the OutboundCallRoute for the 2nd solution.
It has been corrected.

ianobi

azrobert,

You are always welcome to jump in - that's how the forum should work  :)

Yes, your "warm line" solution is a neat way of keeping the local obi's original services. I'm often guilty of answering questions that were not asked! This time I was trying to make sure James was asking the right question to suit his needs.

I'm filing "warm lines" for mixing in with other future configs.