Weird incoming Google Voice problem

Started by dhobi, March 01, 2012, 05:16:14 PM

Previous topic - Next topic

NameerObi

I am using the web based expert mode to make these changes.  How do I access it via the ip address.  Do I telnet to it? I can not access via a web browser.

RonR

Quote from: Stewart on March 14, 2012, 09:08:47 PM
If you still have trouble, report whether you are prompted to press 1, or if you hear silence, but pressing 1 connects the call anyway.

It's always necessary to send a DTMF '1' to answer an incoming Google Voice call when the XMPP interface is used (as the OBi does) regardless of whether Call Screening is on or off in the Google Voice settings, but no prompt is given by Google Voice.  Enabling X_SkipCallScreening should automatically send the DTMF '1' for you.  If X_SkipCallScreening is disabled, you must press '1' in the blind to answer an incoming call.

None of this is pertinent to outgoing calls.

NameerObi

I just did it.  I just figured out how to log into the Obi devise via the web browser using my ip address.

I am working on doing the changes manually.

Thanks Stewart,  I really appreciate your help.

Stewart

Quote from: RonR on March 14, 2012, 09:40:27 PMEnabling X_SkipCallScreening should automatically send the DTMF '1' for you.  If X_SkipCallScreening is disabled, you must press '1' in the blind to answer an incoming call.
I'm wondering if (at least some of) this problem is caused by the DTMF not being reliable.  For example, a user may have set DTMFMethod to InBand to work around issues with DTMF on outgoing calls.  But that would also presumably cause the '1' to be sent as voice; if the RTP path was flaky during the first 100 ms, the digit might not be 'heard' by the GV server.   Possibly, even with RFC2833, a few lost packets could cause trouble.  Is there any feedback available in the protocol, so the OBi could retry if needed?

RonR

Quote from: Stewart on March 14, 2012, 10:21:28 PM
I'm wondering if (at least some of) this problem is caused by the DTMF not being reliable.

That's entirely possible.

Quote from: Stewart on March 14, 2012, 10:21:28 PM
Is there any feedback available in the protocol, so the OBi could retry if needed?

I don't know, but I seriously doubt it.  It appears Google did a very quick-and-dirty XMPP interface to Google Voice, making as few changes as possible to the underlying Google Voice, not worrying about the ugly rough edges that resulted.  They probably assumed they would be the only ones interfacing with it and they could just band-aid around them.

dhobi

I believe DTFM not being reliable is the reason why this is happening and it must have to do with packet loss or ports not being opened fast enough or the router getting confused for a brief amount of time. It still does it for me sometimes, but I know what to do now, just press '1' after a couple of "hello hello".

It is very strange that GV requires '1' to be pressed anyway even if call screening is disabled, but I do understand the quick and dirty XMPP hack. Hopefully they will not change it in a way that prevents devices such as OBI to use GV at all.

MichiganTelephone

Quote from: dhobi on March 01, 2012, 05:16:14 PM
I have a strange incoming calls via Google Voice problem: the phone rings, I pick up the phone but somehow the OBI device/GV do not realize I picked up and the caller keeps hearing the rings and is eventually sent to the GV voicemail.

Outgoing calls work fine, so it's not a broken phone. This started happening today and I am not sure what setting I may have broken to cause it to do this.

Any ideas what to check?

It's possible that your problems have nothing to do with your Obihai device, and that the issue is actually with Google voice.  As I wrote to someone else today who was having a similar issue:

I have found that once in a great while Google Voice seems to get confused and lose its configuration. So try this: Log into Google Voice and look to see what destination you have set (should be Google Chat). UNCHECK Google Chat, and if you have another destination set, check that. Optionally, place a test call to see if the call goes through to the other destination. Now change it back to the way to was — uncheck the other destination and re-check Google Chat. Then try another test call.

Weird I know, but I've seen this work on at least two occasions now. I can't explain why it works and can't guarantee that it will work in all such situations, but it's worth a try.


It sounds like perhaps you may be having a different issue, but maybe it wouldn't hurt to give this a try anyway.
Inactive, no longer posting or responding to messages.  Goodbye and good luck.  Some of my old Obihai-related blog posts have been moved to http://tech.iprock.com - note this in NOT my blog; I have simply given the owner permission to repost some of my old stuff.

dhobi

Quote from: MichiganTelephone on March 14, 2012, 11:36:54 PM
Quote from: dhobi on March 01, 2012, 05:16:14 PM
I have a strange incoming calls via Google Voice problem: the phone rings, I pick up the phone but somehow the OBI device/GV do not realize I picked up and the caller keeps hearing the rings and is eventually sent to the GV voicemail.

Outgoing calls work fine, so it's not a broken phone. This started happening today and I am not sure what setting I may have broken to cause it to do this.

Any ideas what to check?

It's possible that your problems have nothing to do with your Obihai device, and that the issue is actually with Google voice.  As I wrote to someone else today who was having a similar issue:

I have found that once in a great while Google Voice seems to get confused and lose its configuration. So try this: Log into Google Voice and look to see what destination you have set (should be Google Chat). UNCHECK Google Chat, and if you have another destination set, check that. Optionally, place a test call to see if the call goes through to the other destination. Now change it back to the way to was — uncheck the other destination and re-check Google Chat. Then try another test call.

Weird I know, but I've seen this work on at least two occasions now. I can't explain why it works and can't guarantee that it will work in all such situations, but it's worth a try.


It sounds like perhaps you may be having a different issue, but maybe it wouldn't hurt to give this a try anyway.



It is clearly not what you are suggesting because the phone rings but GV doesn't detect the call was picked up unless I press '1' on the phone. So the call is routed correctly. I believe it's the initial DTMF '1' that the OBI device sends automatically that occasionally gets lost.

NameerObi

I think that the Obi devise is sending the DTMF '1' too soon.  I was wondering if there is any way we can prolong the initiation of this task, where it would be sent 2-3 seconds after the call is received instead of its current setting.

dhobi

Quote from: NameerObi on March 15, 2012, 08:34:01 AM
I think that the Obi devise is sending the DTMF '1' too soon.  I was wondering if there is any way we can prolong the initiation of this task, where it would be sent 2-3 seconds after the call is received instead of its current setting.

Don't know if it's too soon or because the initial UDP packets get lost, the router/firewall takes a bit to open the holes for the UDP packets, etc. You can try the OBI connected straight to the ISP, no routers/firewalls in between.

dhobi

Looks like a new firmware update was just released that mentions a GV fix: (Mar 15, 2012) - 1.3.0 (2690)

http://www.obitalk.com/forum/index.php?topic=9.msg18471#msg18471

lottamoxie

I too was having this problem and did the firmware update.  It appears to be fixed now.  I was able to receive a call and not have dead air.  Woot!

pjones

I have the same problem, but pressing 1 after answering the call doesn't fix it.  I've running the 3/15/2012 firmware, which didn't fix my issue. 

Anyone else?  Any other suggestions?

Thanks

dhobi

Quote from: pjones on March 18, 2012, 04:53:45 PM
I have the same problem, but pressing 1 after answering the call doesn't fix it.  I've running the 3/15/2012 firmware, which didn't fix my issue. 

Anyone else?  Any other suggestions?

Thanks

Try connecting the OBI straight to your ISP without any home routers/firewalls to rule those out.

kenobi

To all,

I had the same problem stated in this thread. I know for sure that I did not have this problem 5 days ago, however, I don't know when this problem started as I just noticed today, which is when I started looking at the forum for a resolution.  I tried a few of the suggestions on here (e.g. upgrade the f/w, reset the OBi, disconnect then reconnect GV from forwarding to Google Chat), but nothing worked.

Here is what solved the problem for me. Hopefully this resolves it for others also.

Assuming Google Voice is your Profile A,

Make sure Service Providers -> ITSP Profile A -> RTP -> X_UseSSL is unchecked.

I was checked in my configuration, and I believe it was always that way when it worked fine, but now only when it is unchecked can I successfully make inbound/outbound calls.

synchron

I had the problem where I had to enter '1' for incoming calls (other than GV numbers).  Then I upgraded to 1.3.2690 and it works fine again.

Thanks

synchron  8)