Viatalk no incoming calls getting through

Started by manddarran, March 08, 2011, 06:51:05 PM

Previous topic - Next topic

manddarran

most of the time my calls to my viatalk number end up going to voicemail or the person gets a disconnected message.  i have checked every setting i can find on the obi and viatalk and no luck.  the phone at the house never rings.

any ideas?

RonR

Are you trying to use your ViaTalk SIP credentials in the OBi110 to replace an ATA you have been using with ViaTalk, or are you connecting the OBi110's LINE port to the ViaTalk ATA's PHONE port?  If it's the latter, it should be straightforward.

If you have your ViaTalk SIP credentials and are trying to replace the ViaTalk ATA, try the following configuration (this assumes you have Google Voice on SP1 and ViaTalk on SP2):


System Management -> Device Update -> Reset Configuration

System Management -> Network Settings -> LocalTimeZone : [your local time zone]

System Management -> Auto Provisioning -> Method : Disabled

Service Providers -> ITSP Profile A -> General -> SignalingProtocol : Google Voice

Voice Services -> SP1 Service -> AuthUserName : [your Google Voice username]

Voice Services -> SP1 Service -> AuthPassword : [your Google Voice password]

Service Providers -> ITSP Profile B -> SIP -> ProxyServer : [the ViaTalk proxy server name or IP address]

Voice Services -> SP2 Service -> X_ServProvProfile : B

Voice Services -> SP2 Service -> AuthUserName : [your ViaTalk username]

Voice Services -> SP2 Service -> AuthPassword : [your ViaTalk password]

Physical Interfaces -> Phone Port -> PrimaryLine : [your choice]

OBi-Guru

Maybe registration period needs to be made shorter?  Default is 60 secs, try to reduce it to 5 secs.

Service-Providers->ITSP Profile->SIP-> RegistrationPeriod = ...

RonR

For many VoIP providers, 60 seconds is way too short.  The normal registration period is 3600 seconds (60 minutes) and I've been meaning to suggest the default in the OBi110 should be changed to 3600 (as it is in most ATA's).  Re-registering once per minute is total over-kill.

biomesh

Here are my settings that work great:

ITSP profile(General)

Name: megatron.vtnoc.net  (this is just my server I connect to)
Stun Server: stun.vtnoc.net

ITSP (SIP):
Proxy Server: megatron.vtnoc.net
Registrar Server: megatron.vtnoc.net
UserAgent Domain: megatron.vtnoc.net
Register Expires: 600
X_ProxyServerRedundancy: Checked
X_CheckPrimaryFallbackInterval: 600
X_CheckSecondaryFallbackInterval: 600

Voice Service:
X_KeepAliveServer: megatron.vtnoc.net
AuthUserName & AuthPassword: your personal credentials
CallerID Name: Your name
MWIEnable: Checked
X_VMWIEnable: Checked
X_UserAgentPort: 5062

If you have multiple devices connecting to viatalk, you might just need to change the X_UserAgentPort to something different to make it easier for your router to handle the NAT connectivity.