December 12, 2017, 10:10:27 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: One-way audio - Disable SIP Firewall on router  (Read 9452 times)
refrosted
Newbie
*
Posts: 14


« on: April 01, 2012, 03:43:50 am »

FYI, FWIW -- As a newbie, I set up voip.ms first on SP2 on the Obi110 and then a few days later, GV on SP1, both using the Wizards.  After doing that, I discovered that the voip.ms calls on **2+number  (SP2) worked for about 1-2 seconds and then went silent (one-way audio).

After some searching, I checked Disable SPI Firewall (SPI=stateful packet inspection) on my Netgear WPN824 router  (in the WAN section). After doing that all Obi calls  worked.

After a few days of running, the only consequence I've noticed is my wife's Adobe GoLive FTP transfer program stopped connecting, giving an error message. Since Filezilla wasn't similarly affected, I found that switching on  "Passive Transfer" in the Advanced setting of the GoLive ftp server connection settings let the connection/file transfer go through. We continue onward.

I haven't discovered yet if there is a different/better way to fix this issue in the Obi configuration so that the SPI (whatever its benefit may be) can be re-enabled. If anyone knows one, please advise.  I have not set any port forwarding in my router nor was I advised to by Obi Tech support.

Onward.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #1 on: April 01, 2012, 05:21:15 am »

Possibly, one on the following may enable SIP to work with SPI enabled:

1. Update router firmware, if not running the latest version.

2. In ITSP Profile B -> SIP, try changing ProxyServerPort from 5060 to 5080.  If you have a value set in OutboundProxy and/or RegistrarServer, also change the corresponding port numbers from 5060 to 5080.
Logged
refrosted
Newbie
*
Posts: 14


« Reply #2 on: April 01, 2012, 02:24:43 pm »

Quote
Possibly, one on the following may enable SIP to work with SPI enabled:

1. Update router firmware, if not running the latest version.

2. In ITSP Profile B -> SIP, try changing ProxyServerPort from 5060 to 5080.  If you have a value set in OutboundProxy and/or RegistrarServer, also change the corresponding port numbers from 5060 to 5080.

Thanks.

(1) There's no warning triangle on my Obi Dashboard indicating firmware update, so I think it's all right.

(2) I tested the switch to port 5080 in the 3 variables in the ITSP B Sip and still I have to Disable SIP Firewall on my router to have the call work.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #3 on: April 01, 2012, 07:16:52 pm »

Update router firmware, if not running the latest version.

Conceivably, it's modem related.  Make / model?

Otherwise, you will probably have to leave SPI off, as this particular router does not have the detailed control offered by other Netgear units.

If you still want to pursue this, can you set up a way to capture traffic on the WAN side of the router?
Logged
refrosted
Newbie
*
Posts: 14


« Reply #4 on: April 03, 2012, 09:35:07 pm »

Quote
Update router firmware, if not running the latest version.

Conceivably, it's modem related.  Make / model?

Otherwise, you will probably have to leave SPI off, as this particular router does not have the detailed control offered by other Netgear units.

If you still want to pursue this, can you set up a way to capture traffic on the WAN side of the router?

Oh, Router!   Thanks, I updated the Netgear WPN824v2 to 2.0.26 but the SPI still needed to be disabled.

My cable modem is Scientific Atlanta DPC2100R2 recently purchased on ebay to end the $7/mo rental fee (Comcast).    It only will shows the status page at 192.168.100.1

I'm not familiar -- would need step-by-steps on how to capture/display traffic on the WAN.  For now, probably I'll leave well-enough alone.

I'm curious, now,  what routers are known to be  "trouble-free" for Obi/Voip, or is it alla bit challenging?

--
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC