Sending a fax through Obi202?

Started by UserAsdf, July 02, 2012, 01:08:44 AM

Previous topic - Next topic

DChappell

I'm having this exact same issue with my 202, where the fax "handshake" is being cut off or "silenced" by the 202 a couple of seconds after it is initiated.

After reading through this thread I am trying to locate where I can uncheck the "T38Enable" setting but for the life of me cannot find it anywhere in my 202 expert setup.  Could somebody point me in the right direction please?

Thanks!

ianobi

DChappell,

Welcome to the forum.

Find your way to the Codec pages, best do Codec Profile A and Codec Profile B. T38 is right at the bottom of the page.

DChappell

#42
Quote from: ianobi on September 13, 2012, 07:41:22 AM
DChappell,

Welcome to the forum.

Find your way to the Codec pages, best do Codec Profile A and Codec Profile B. T38 is right at the bottom of the page.

Thanks!!  One problem... I do not have anything about T38 in ANY of my Codec Profile pages. :(   Only codec's I've got are G711U / G711A / G729 / G726R32 / iLBC.  Currently the only codec's I have enabled are the G711U & A.

Maybe I've got an older firmware?  (jusst checked and I'm running the latest 3.0.0 build so that's not it)

ianobi

That's odd! I have a OBi110 not a OBi202, so I can't check. I was looking at Codecs on page 147 of the OBiDeviceAdminGuide.pdf and there it is right at the bottom - T38Enable.

DChappell

Interesting...  Just looking at the admin guide and it has a LOT more codec's listed that what I have access to via my ObiTalk Expert Settings...  Time to fire off a ticket to Obi.

Thanks!

ianobi

#45
Just checked - that's also true of my OBi110!

There are some cases of settings only being available by logging directly into the OBi via its IP address. Dial ***1 to get the ip address.

Uncheck the default box and then make your change, submit and reboot.

DChappell

Of COURSE there are settings I can only get to by logging directly into the device... because that makes SOOO much sense right? LOL

Glad to report that disabling the T38 option has corrected the inbound fax issue, and thanks for pointing me in the right direction!

Forum support rocks!

Doug

dial.tone

Quote from: DChappell on September 13, 2012, 09:03:05 AM
Of COURSE there are settings I can only get to by logging directly into the device... because that makes SOOO much sense right? LOL

Glad to report that disabling the T38 option has corrected the inbound fax issue, and thanks for pointing me in the right direction!

Forum support rocks!

Doug

Ditto!  Found the T38 option and disabled it in Profile A and B.  Just tested inbound and outbound faxes and they worked perfectly.  I love this thing!

Ostracus

The only thing about disabling it is it makes you ask, "so why did I buy the Obi202, again"?

Billt928

I have been fighting T.38 fax issues with callcentric for over a month.

The setting on Callcentrics site did improve outbound faxing with T.38 bit I'm still having issues with inbound faxes disconnecting. Obi techs told me the calls were disconnecting because Callcentric was issuing a BYE command. Callcentric has not told me the issue, but they are doing an internal port to a diffrent carrier.

http://www.callcentric.com/support/device/obihai/obi202

fathom

THANK YOU THANK YOU!!!!
SIP ALG was my problem too (after 4hrs of trying various settings).
Brilliant to bring the topic up and solving the problem.

I have mine as g711u and t38 , not sure which one was used
Will play around with other voip provider too (so far success with call centric, wanted to use the T38 feature...how do I know when T38 is being used?)

QBZappy

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

fathom

Thanks for the link.
I had to do some changes (trial and error because I would get a dial tone but it would not connect).
So now it's working: faxed from home (brother MFC-495W set at lower rate to obi202 via callcentric free outgoing per use service) to work (xmedius T.38 over ip fax company) and all 5 pages, including a PDF. Looks like it went through using the T.38

Duration   totall was 225 (this is a snapshot midway)
Direction   Outbound   Outbound

RTP Transport      UDP
Audio Codec      tx=; rx=G711U
RTP Packetization (ms)      tx=0; rx=20
RTP Packet Count      tx=192; rx=252
RTP Byte Count      tx=33024; rx=33384
Peer Clock Differential Rate      0 PPM
Packets In Jitter Buffer      0
Packets Out-Of-Order      0
Packets (10ms) Interpolated      5
Packets Late (Dropped)      2
Packets Lost      0
Packet Loss Rate      0 %
Packet Drop Rate      1 %
Jitter Buffer Length      110 ms
Received Interarrival Jitter      80 ms
DTMF Digits Received      0
Jitter Buffer Underruns      2
Jitter Buffer Overruns      0
Sequence number discontinuities      0
skew compensation      0 ms
send silence      0

jjtricket


fathom

From billt928 post:

You can tell your using T38 under call status (it does not show T38) but this line will change

Call Status
Audio Codec = tx=G711U; rx=G711U

Will change to when sending
Audio Codec = tx=; rx=G711U

or
Audio Codec = tx=G711U; rx=

when receiving a fax

Billt928

#55
spent many hours / days working with obi and callcentric on this.

The T38 reinvite uses a G711u tunnel  

That is why you loose the reference to G711u tx. T38 is negotiated in the G711u connection. if faxing a number that does not support t38 like google voice the Audio Codec will show tx=G711U; rx=G711U.
you should also notice some other differences in the call status info.

also changing ReInviteExpires from 10 to 15 seems to have helped a lot for me when faxing to another obi202. seems that devices negotiating T38 on both ends of the call cause more of a delay

fathom

Callcentric faxing so far working consistently.

VoIP.ms, not consistent at all (kids back from school so the router is working overtime with Netflix and other chatting)
This is from VoIP.ms who do not use T.38:
RTP Transport      UDP
Audio Codec      tx=G711U; rx=G711U