Call forwarding is not working.

Started by murzik, March 16, 2011, 08:01:42 AM

Previous topic - Next topic

murzik

I am trying to forward calls received from SP2 to phone number through SP1.For example in SP2 settings I would select Unconditional call forwarding and for number sp1(1xxxxxxxxx).  For some reason this is not working, call just gets disconnected as soon as Call forwarding rule kicks in.
Any idea how to get it to work?
Or this is not supposed to work at all?

QBZappy

murzik,

Hi


I was thinking if you select Trunk Group 1 as your primary line, you do not need to use "sp1" in front. The phone number alone should work in your config. Trunk Group 1 goes to first available line. Since call coming on SP2, SP1 is next available line.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

murzik

QBZappy ,
Thanks!

But the thing is, that I have SP2 as primary phone line, but also I have rule to send all outgoing calls to the US through SP1. Just outbound rule {(1xxxxxxxxxx):sp1} and Obi is working this way.I have no problem with incoming or outgoing calls.
I have tried to put just phone number 1xxx xxx xxxx in forwarding phone number field and that did not work either.
I also tried conditional call forwarding, but same story the moment condition kicks in, incoming call gets disconnected.

QBZappy

murzik,

I assume you are not using the phone attached to the OBi to make this test. You should be using a cell or some other line.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

murzik

Of course not. ;D
I am calling from my cell phone and entering my wife's cell phone or my office phone as forwarding  destination.

jimates

@ QBZappy

Most users do not want to use "the next available line", they want to use a specific line due to caller id. We have dealt with google voice's work around long enough to make sure the correct phone number is displayed when we call. We don't want to go backwards.

With 2 sessions per line the call can come in and go out on the same line to keep the correct caller id in place.

obi-support2

murzik,

I assume you are using SIP protocol (not GV) on SP1 and SP2, correct?

Please try this setting:
Assume your SP1 is using ITSP Profile A, and SP2 is using ITSP Profile B,
set X_Use302ToCallForward to no (unchecked) under that ITSP Profile.
The default value is yes (checked).

--------

What this option does is to let your OBi send back a SIP 302 response to the caller (on SP2 in this case) which might not be processed by your ITSP B. OBi at this time is not smart enough to automatically turn off option 302 when you tried to forward btw SP1 and SP2 if they are on different ITSP Profile. Option 302 would be appropriate if SP1 and SP2 are indeed with the same ITSP (and if that works, would be more efficient).

OBIHAI Support Staff

murzik

Thanks!
It is working.

There is still one drawback.  I understand that there is maybe no way around, but instead of showing CID of phone originated the call, number of GV account I am using as forwarding account will appear.
So if some on will call my home phone and I have call forwarding enabled,  on my destination phone I will see my own home number instead  of number of person who's calling me.
::)

jimates

Calls that go out on a GV line don't originate on the Obi. They originate at google as if you are placing the call from google chat. So the GV number will always show up when calls are forwarded through that spx line.