I cannot receive phone calls

Started by edusobi, March 16, 2011, 08:10:03 AM

Previous topic - Next topic

edusobi

Hello,
I searched and found this question many times, but I had no luck after trying all suggestions, so I posted it again.

I have obi110 installed and configured with Google Voice. I followed instructions given at voxilla http://voxilla.com/2011/01/24/how-to-use-google-voice-and-obi-for-all-your-calls-free-2512, including firmware update.

I believe that when I configured the device I was able to receive a phone call from my own cell phone (just to try the configuration). However, since then, every time I receive a phone call, I always here a female voice asking to press "1" to accept the call, or "2" to send it to the voice mail.  No matter how many times I press "1", or keep it pressed, the calls are sent to the voicemail.
I have already check:

1) X_SkipCallScreening is set to "value", in the "Voice Services * SP1 Service" of the OBi Device Management Web Page.

2) Google Voice settings "Forwards calls to:", "Google Chat" is checked.

3) Following a suggestion in Google forums I also "Signed out of chat" at the left side of my Google Mail account.

4) Of course, I tried to logout from my gmail account, and even turn off the computer.

In all cases, when I receive the incoming calls I hear the prompt to choose between "1" and "2" (which is supposed to be disabled as of (1) above!), and those calls are invariably sent to the voice mail, no matter what.

I also noticed that many times I am not able to follow options when I place a call (please press "1" for this, or press "2", for that). I am not sure if these are related problems.
And "yes", I am in the US.

Any help would be very much appreciated!



   

OBi-Guru

Are you calling from a phone that was used to authenticate your GV account?  If yes, this is the expected behavior.   Calling from other phones will not be intercepted by GV menu.

If you need to dial from that particular phone, try to prepend *67 before the number, to block your callerID.  See if it goes through.

edusobi

Thank you Obi-Guru!

Yes, I authenticated the account using this phone (I mean, a phone connected to my obi110 device). Should I have to auntheticate it using the Google soft phone keypad first? Am I still on time to authenticate it on line?

I did try *67 to place an outgoing call followed by numeric options, but I was unable to do so (the receiving system did not interpret my selections).

Thanks!


jimates

#3
What you are hearing is call screening. Is it the call screening for google chat or the call screening for google voice. Each is a separate thing.

call screening for google chat is disabled in the Obi. You said you checked that.

call screening for google voice is disableed from within your google voice page.
click on the settings wheel on the right -
voice settings > calls > call screening - set to off.

edusobi

Hi jimates,

I double checked and "Call Screening" is set to "Off" on Google voice, so it seems that there is something else going on.
Thank you for your suggestion!

Eduardo


OBi-Guru

When you set up GV account, Google will authenticate a phone number, for instance your cellphone?
Now, if you dial from your cellphone to that GV number, it will get to the Google voice menu.  Is this what you heard?   If so, it is the expected behavior.

Now from your cellphone, dial *67 and then GV number (this will block the callerID of your cellphone), then GV will ring your OBi phone.

You can also use someone's else cellphone that is not associated to the GV number, and call that GV number normally, and see if it rings the OBi phone.

edusobi

Obi_Guru,
the problem is with all external phones, for example, third parties trying to reach me.
My Obi phone rings fine, but every time I try to answer a phone call with the phone attached to the Obi device, it asks for "1" to answer or "2" to send to "voicemail".

I am testing myself with Yahoo "phone out" service, which is completely unrelated with my GV account.

Thanks!




RonR

#7
Quote from: edusobi on March 16, 2011, 03:33:38 PMMy Obi phone rings fine, but every time I try to answer a phone call with the phone attached to the Obi device, it asks for "1" to answer or "2" to send to "voicemail".
If you'd rather not have to press '1' to answer, uncheck the default box and check the selection box at (it's the last one on the page):

Voice Services -> SPx Service -> X_SkipCallScreening

Then you won't hear the prompt and the OBi will press '1' for you (you won't hear it).

OBi-Guru

Are you using OBiTALK portal to configure your GV service on the OBi110?  If so, by default, the configurator will set X_SkipCallScreening = yes.   If you are using OBiTALK portal, make sure not to disable your provisioning (in case you see that in the OBi device webpage).

And yet, you are still getting the GV female voice asking you to press 1 to accept, 2 to vmail.   And pressing 1 does not let you pass that to GV.

How about this, can you try calling from your OBI phone to United Airlines reservation system and see if you can successfully navigate using your touch key phone?   You can enter a flight number and find out arrival/departure, etc?

Lastly, try to factory reset your OBi, re-add your device to OBiTALK portal, and configure your GV credential once again.   Basically start over with the set up to make sure there is no mistake made in the steps.

edusobi

Yes OBi-Guru, I used OBiTALK portal to configure GV service.

The "X_SkipCallScreening" variable is (and originally was) set to "Value", which I assume means "Yes".

Anyway, I connected to the airline reservation system, and it did NOT allow me to navigate their options. It kept repeating the same first options over and over, which means it did not receive my touchpad commands.


RonR

Quote from: edusobi on March 16, 2011, 04:26:44 PMThe "X_SkipCallScreening" variable is (and originally was) set to "Value", which I assume means "Yes".
Are you looking at a file produced by?:

System Management -> Device Update -> Backup Configuration

You should be using the OBi's Web Server-Based Local Configuration and connecting to it from your web browser using the IP address returned by ***1.  You should be seeing something similar to the attached Capture.jpg.


Quote from: edusobi on March 16, 2011, 04:26:44 PMAnyway, I connected to the airline reservation system, and it did NOT allow me to navigate their options. It kept repeating the same first options over and over, which means it did not receive my touchpad commands.
DTMF problems with Google Voice may require enabling the following:

ITSPx -> General -> X_UseFixedDurationRFC2833DTMF

edusobi

RonR,
it seems all settings are as you suggest.
Please see the attached form.
Thanks!


OBi-Guru

From the same gmail account, can you try making a call to that UA reservation line from the "CALL PHONE" icon on your PC?  And see if you can navigate the menu with the PC keypad?

Additionally, unplug your OBi from the router, and make a call to the GV number, and answer it from the PC window, are you able to answer the incoming call?

edusobi

Hi OBi-Guru,

I can make calls from the GV softphone in my computer. I had no problems navigating the menu of arrivals and departures following numeric options.

Interestingly, I plug the Obi directly into the moden (bypassing the router), and I was able (for the first time since I am using my Obi110!), to navigate the menus of flight arrivals, etc. However, when I plugged it again in the router, it returned to the previous behavior: able to make calls, but unable to navigate prompted options.

   

OBi-Guru

Please send email to support@obihai.com with your OBi number (200 xxx xxx) and details on your internet connection (dsl, cable), provider and your router model.

edusobi

#15
Problem solved!

I want to say thanks to the support team as they helped me a lot. They were able to fix the problem with recognition of numeric options (or extensions). However, although things improved a lot, I was still unable to receive calls (a female voice asks for "1" or "2", but nothing happened after selection).

After playing around with the settings, I found the final solution was to change the router! I was using a very old router, which did not allow me to dial numeric options, even on the soft phone installed on my computer. This is why we thought at first that the problem was with the GV account.

So, for all people out there not being able to receive phone calls, it would be worth to try a router firmware update, or check with other router (if possible), to see if your hardware is compatible with GV.
My router was from 2004, and although it was working fine, it was not able to manage all features of GV. For the record, it had the same problem with Yahoo phone out.

Have a great day!