Calling from Google Voice using OBi (solved)

Started by jeff@jeffmusto.com, August 15, 2012, 01:53:13 PM

Previous topic - Next topic

jimates

open your gmail page and call your google voice number. It should ring on your computer.

jeff@jeffmusto.com

<<open your gmail page and call your google voice number. It should ring on your computer.>

Yes receiving a call in gmail works fine. Any other ideas?
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

jimates

Quote from: jeff@jeffmusto.com on August 21, 2012, 06:05:45 PM
<<open your gmail page and call your google voice number. It should ring on your computer.>

Yes receiving a call in gmail works fine. Any other ideas?
Did you get the call screening when answering in gmail? I guess resetting the Obi is the next step.

jeff@jeffmusto.com

Yes I did get the call screening on the line that I was using to call my GV number.
Can you tell me the proper way to do a hard reset on the OBi 110?
I am assuming I go to my dashboard, delete the device, do a physical reset of the OBi and then go back in to my dashboard and add it again. Is this correct?
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

jimates

Did you get the call screening announcement on your computer when you answered (press 1 to accept ...........).

Without reading back through the thread, if you didn't already try just deleting the google voice service you are having trouble with, do that.
From the dashboard click on the device, then click the trash can to the right of the google voice account and delete the service. Then set it up again. If you still have problems you can then do a hard reset.

Hard reset:
You don't have to delete the device from the account.
There is a hole on the bottom of the device. Beneath the hole is a button. Using a paper clip, press and hold the button until the unit restarts. Make sure you hold it long enough, 20 seconds.

jeff@jeffmusto.com

I did not get a call screening on my computer when I received an incoming call in my gmail account, I just answered and the call was there.

First I deleted the Google voice service and added it back in, no luck. Then I did the hard reset, no luck. I have ordered another OBi 110, maybe I should try and configure that to this GV number.
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

jeff@jeffmusto.com

I had an idea that maybe my GV number was blocked for spam or got blocked by mistake. I did not see it blocked for spam or blocked by me. I am out of ideas, I hope you have some as I use click to call a lot.
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

GregoryZ

Post your SP1 > X_InboundCallRoute

Maybe there is something there that shouldn't be.  Unless you've made modifications the defult should be {ph}

Also make sure that > X_SkipCallScreening is checked.

The problem my lay with GV, but lets rule out the OBi too.

-G
OBi100, OBi110, OBi200, OBi202

jeff@jeffmusto.com

<Post your SP1 > X_InboundCallRoute>
I am not sure how to do this but I can follow instructions very good if you could be so kind to let me know how to do it. I do not know if you have been following this thread but I just did a hard reset on the OBi so I am almost sure that nothing is there that should not be there.

I have 2 other numbers for GV to ring and I can do a click to call with those numbers with out a problem. This is why I do not think it is GV.

Also make sure that > X_SkipCallScreening is checked.
Tell me where this is also and I will check it.

Just to bring you up to speed when I do a click to call, the call goes through but never rings my OBi. I can see network activity on the OBi (light blinking) when I do the click to call but the phone never rings. All my inbound and out bound calls from my Obi connected phone works great.
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

QBZappy

Quote from: jeff@jeffmusto.com on August 22, 2012, 09:06:37 PM
<Post your SP1 > X_InboundCallRoute> <-Near the top

Also make sure that > X_SkipCallScreening is checked. <-Near the bottom
Tell me where this is also and I will check it.

Both settings can be found by clicking on this link: (Insert your OBi ip)
http://your_obi_ip/VS_1_VP_1_L_1_.xml
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

GregoryZ

Jeff,

I've been reading this post some over the past couple of days.  I guess I wasn't paying too much attention.  It didn't sink in when I read you had just done a reset.  :)

Blew my thoughts out of the water.   :-\

I just tested my click to call.  It works fine.  I don't get the call screening option (Jimates question earlier) either. 


Quote from: jimates on August 20, 2012, 09:40:48 PM
If I try and have it ring my OBi phone it does not ring but the call still goes through but I am not connected to it, the people at the number I am calling hear nothing.

The call you place using "click to call" should not even ring the other person's phone until you have answered your forwarding phone. You say your Obi doesn't ring, but somehow the call is being answered or the call would not be delivered to the other party.

I agree with Jimates here too.  The call should not be made to the other party until you have first picked up your phone connected to the OBi.

I'm stumpped too.  If it wasn't for the fact that you have just reset your OBi, I'd have you look up that information.  ( I see QBZappy jumped in before I finished typing this.  His link will get you the info I was asking for)

I've seen several posts where GV has been giving folks Busy Signals when the numbers they were calling are not busy, and misc. other issues that seem isolated and random.  Maybe this is just the case for your situation. 

If you had another OBi to setup with the same GV account, and test it there that would give us a better idea if it was in fact the OBi or not.

-G


OBi100, OBi110, OBi200, OBi202

jeff@jeffmusto.com

<<Both settings can be found by clicking on this link: (Insert your OBi ip)
http://your_obi_ip/VS_1_VP_1_L_1_.xml>>

And how would I find my OBi IP address?
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

jeff@jeffmusto.com

<<I've seen several posts where GV has been giving folks Busy Signals when the numbers they were calling are not busy, and misc. other issues that seem isolated and random.  Maybe this is just the case for your situation.>>

The call is going through. I can call my home (and other numbers) and the number I dial picks up the phone but of course I am not there.
I can also see the network light blink with activity when I do a click to call. I thought maybe my phone was not ringing but when I answer my phone (when it has not rang but I see the network light blinking) I just have a dial tone.

I have a new OBi coming by next Monday so I can try the new one then.
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

jeff@jeffmusto.com

#33
I figured out my IP address

Post your SP1 > X_InboundCallRoute
{(x.6124245445|x.xxxxxxxxxx):aa},{ph}

Also make sure that > X_SkipCallScreening is checked.
This is checked
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

GregoryZ

#34
Good Morning Jeff,

1st, you may want to edit your last post.  put "XXXX or ###" or so, in the post to hide a few digits of your phone number.  It's just a suggestion for YOUR security.  :)

2nd, OK.  So you've just done a reset of your device, yet you have a digit map in your call route already.  I'm no "Digit Map/Dial Plan" expert at all.  In fact, I rely on the others here for that.  
But, what comes to my mind is; if you have done a Hard Re-set, and have a non Defult setting here... where else may there be a non-default setting.

EDIT: I just got back from walking the dog, but I was thinking....  The inbound call route might be your numbers that you put in as "Circle of Trust" numbers on OBiTalk.  I don't know.  But, are either of those numbers your GV number?  Maybe that is throwing things off.

Does anyone else agree?  Should we not be looking closer at what Jeff's OBi Settings are at this point?

-G
OBi100, OBi110, OBi200, OBi202

GregoryZ

#35
Jeff,

Just figured this out, I think.

I just copied your SP1 > X_InboundCallRoute into my OBi100.  I substituted my GV number for yours.  I went to GV, and clicked to call.  Sure enough, my cell phone rang, but my phone on the OBi100 didn't.

So, try this.  Go to OBiTALK Portal, and remove your GV phone number from the Circle of Trust.  Let the OBi update and reboot.

Then try a test.

Let us know.

-G
OBi100, OBi110, OBi200, OBi202

jimates

{(x.612xxxxxxx|x.xxxxxxxxxx):aa},{ph}

yes, if either one of those numbers is your gv number, then when you click to call the AA is answering which completes your end. The settings does not ring the phone for those incoming numbers.
Then the call is delivered to the recipient. I assume that by the time they answer, the AA announcement is complete.

I don't use the circle of trust or the AA so I always forget about that being a possible problem.

jeff@jeffmusto.com

Sorry for not getting back sooner, I have been out of town. This fixed it. All I can say is WOW. Thank you jimates, GregoryZ and QBZappy for all the time spent on this. This might be something to put in the FAQs or make a sticky as it is not really well known.
Right after I added my 3rd OBi to my control panel I added all 3 numbers to the circle of trust on all OBis. That is when my problem started but I had no idea it was related.
Thank you all again, I hope I can give back some day.  ;D
the pvkid "Helping other people live the dream"
Puerto Vallarta Condo Rental

GregoryZ

OBi100, OBi110, OBi200, OBi202