X-lite app does not ring for incoming calls

Started by n-bee-r, March 17, 2011, 03:52:25 PM

Previous topic - Next topic

n-bee-r

The X-Lite (v4.0) app on my PC does not ring for incoming calls. However I can place outbound calls from X-lite through OBI device. What other configuration is missing in X-Lite to ring for incoming calls? ???

obi-support2

Have you installed OBiAPP on your PC and followed the setup instructions from OBIHAI.com to make your X-Lite work with the OBiAPP?

OBiAPP is a middleware (Windows only at the moment) that bridges the SIP signal coming from your Xlite to the OBiTALK network; that's how you normally place and receive calls on your Xlite over the OBiTALK network. I assume this is the way you want to use X-Lite with OBi.
OBIHAI Support Staff

n-bee-r

Yes, I followed the (screenshots) instruction for X-lite after installing the ObiApp middleware. As I said earlier, I can make outbound calls from Xlite through Obi. The issue I'm having right now is X-lite is not ringing for any incoming calls, only the phone attached to OBi device rings.

obi-support2

If the phone attached to the OBi device rings, that means your "incoming" call is calling a 200xxxxxx number, correct? The OBiAPP however is a softclient, but with a different OBi Number starting with 290xxxxxx.
You can check your OBiAPP softclient number by right clicking the OBiAPP icon (Windows system tray), select Properties, and take a look under the MyOBi Tab.

You MUST also configure the X-Lite SIP Accout User-ID to use the same softclient OBi number (290xxxxxx).
But since you can call out, you probably have done that correctly already...

Just note that we cannot ring both your OBi device and the soft client simultaneously, by calling just the OBi device's obi number.
OBIHAI Support Staff

jimates

@ n-bee-r

the softphone is an endpoint just like the Obi, except it only works on the Obitalk network, it doesn't configure with google like the Obi does.  If you want calls to ring it you will have to set the Obi to forward calls to it.

n-bee-r

OK I got it.

Is there a way to do CallForward from remote, say from ObiTalk.com. Everyday before leaving to office I need to do call forward on phone connected to Obi device, so that I can receive/answer the calls from X-lite running on my office desktop. Then do the reverse as soon as I'm at home. Can this call forwarding be done from ObiTalk.com or from ObiApp?

QBZappy

#6
n-bee-r,

Your OBi unit is web based. You should be able to access it over the internet just as easily as the OBi portal. In an upcoming firmware version you will have Expert OBi configuration which will give you another way of setting up call forwarding.

I find that there are too many steps to do CF using the Expert way. That really is intended to give general access to the unit for configs.


If you do not have a fixed IP you might need to set up DNS service like this one:
http://www.dyndns.com/ or http://no-ip.com/
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

victorr

I too can call out from x-lite (3.0) just fine but not receive.

I am trying to fork the call to both the fxs port and the soft phone. 

I cannot get x-lite to ring an incoming call at all regardless of what I do to the inboundcallroute.So far I can only route the call to the softphone by using the * code *72 **9 290****** .  callforwardunconditionalenable is enabled and I can receive calls in x-lite.

When I enter inboundcallroute={ph,pp(ob290******)} OR pp(ob290******) OR PP1(ob290******) for sp1 (bound to a google voice account) then the default setting for the obitalk service is automatically set to inboundcallroute={(290******)>(xx.):SP1},{(290******):aa},{ph} and nothing rings at all. Change both fields back to the default of ph and once again I can make calls from x-lite and make/receive calls on ph.

What to try next? Any suggestions?

jimates

Voice Service > SP1 Service > X_InboundCallRoute = {ph,pp(290xxxxxx)}

this will send all calls coming in on sp1 to the phone port and to the soft phone number.

At least it works for me.

victorr

#9
Jimates ... Thank you for responding to my previous question.  It helped a lot to find out my syntax was correct.

I finally realized I was calling from another google when dialing from my cell because it is a g1 with gv enabled.  
1)I reset the obi to factory.
2) added it to my obitalk profile.
3) Provisioned sp1 with gv account.
4) Went to obi device>voice services>sp1 service>X_InboundCallRoute={ph,pp(290123456)
5) Disabled GV on my cell phone and called in to gv# on sp1.

  The call forked properly.  Both the phone on ph port and x-lite 3.0 rang properly.

Then I called again from a gv account.  Only the ph port rings

Then I called again from my cell phone with gv disabled.  Only the ph port rings.

repeat steps 1-5 using instead the obitalk expert config web page.

Called out on softphone to cell #   ... success
Disabled gv on my cell phone and called into gv# on sp1 ... success .. call forked to ph port and pp softphone.

Disabled gv on wifes cell phone and called into gv# on sp1 ... success .. call forked to ph port and pp softphone.

enabled gv on my wifes cell phone and called into gv# on sp1 .. success (unexpected) .. call forked to ph port and pp softphone.

Enabled gv on my cell phone and called into gv# on sp1 ... success (unexpected).. call forked to ph port and pp softphone.

Conclusion: Use obitalk expert setup instead of configuring device directly and call forking feature will work.

Caveat: softphone on obitalk portal shows status of "offline" but works just fine anyway.

Questions:
1) What different settings does the expert config make?
2) What features are available using sip service provider that are not available with GV configuration?  (I saw a post regarding this but I cannot find it again.)