[SOLVED] home answering machine picks up before google voic

Started by ckck, April 10, 2013, 05:55:21 AM

Previous topic - Next topic

ckck

Some background: I have an Obi 100 at home, SP1 is attached to a voip.ms number, SP2 is attached to a google voice number. SP2 is set as the primary number to call out from. I don't use obi's auto attendant. That is, AFAIK auto attendant is not turned on. I have a home answering machine, to answer calls to SP1/voip.ms (which was ported from our former landline).

My problem: Some google voice calls go to google voice voicemail, while others are answered by my home answering machine. I can't find a pattern.

My google voice number points to my obi (via google chat), my cell phone, and my office phone. Though they do ring, neither my cell phone nor my office phone will answer. Only my home answering machine or google voice will answer.

I've set my home answering machine to pick up after the maximum number of rings, which is 7. At 6 seconds per ring this should be enough time to allow google voice to pick up.

In my google voice settings, I've turned on call screening for every caller.

I'm stuck at this point. I found a few threads that alluded to similar problems/solutions, but nothing spot on. This one was the closest ...

http://www.obitalk.com/forum/index.php?topic=3307.msg23530#msg23530

... but note exactly like the problem I'm having. Also, I don't use AA, or have any number in 'trusted callers'.

Any insights or ideas would be appreciated. Thanks!

ckck

Just did some testing, calling with my wife's cell phone to both my SP1 (voip.ms) and SP2 (google voice).

Calls to SP1 ring 7 times then my home answering machine picks up.

Calls to SP2 ring 4 times, with a 'long distance' ring, then my home answering machine picks up.

I don't know how to describe the SP2 ring other than that it reminds me of how out-of-area-code calls used to ring at my home when I was a kid, i.e. not a 'normal' ring.

I'm now wondering if the different ring is making my home answering machine want to answer after only 4 rings.

Is there a way in the obi set up to change the way that SP2 rings, to make it a 'normal' ring.

Or, maybe this is a problem with my home answering machine? It's an older panasonic phone/ansering machine combo. I'm reading the manual now and can't find a reason why it would answer after 4 rings. I'll keep looking ...

RFord

Actually, the norm is 5 seconds per ring and google Voice Mail kicks in a little short of 25 seconds (about 5 rings).  Your Answering Machine should be set to 4 rings if you want the Answering Machine to consistently pick up the call before it goes to GV Voice Mail.  If your Answering Machine has a setting for 5 rings, you could try that setting (my Answering Machine has settings for 2, 4 and 6 rings, so I select 4-rings), but I doubt you will get consistent results before calls goes to GV Voice Mail.

ckck

@RFord ... sorry, I think my explanation was convoluted and unclear.

I want google voice to answer when someone calls my google voice number (SP2).

I want my home answering machine to answer when someone calls my voip.ms number (SP1).

My answering machine is set to pick up after 7 rings, so, even at 5 seconds a ring that should be enough time to let google voice voicemail pick up before my home answering machine. According to the answering machine's user manual, the 7-ring pickup will happen regardless of the number of messages, or whether they're new or have been listened to.

I think the key here is that my google voice (SP2) ring is different from my voip.ms (SP1) ring, and that is tricking my answering machine in some (undocumented) way. But, I'm open to any ideas.

Shale

I would  go to the Expert Mode of OBiTalk for your device, compare the

Voice Service
SP1 Service
  X_DefaultRing

with
Voice Service
SP2 Service
  X_DefaultRing


If those are not the same, you could make them the same. If those match, I don't know where to go next.

ckck

@Shale ...

I think we're on the same trail. I just checked and X_DefaultRing is set to 1 for both SP1 and SP2. However, under Ring Settings ...

  Ring Profile A
RingName: Bellcore-dr1
RingPattern: 60;(2+4)

  Ring Profile B
RingName: Bellcore-dr1
RingPattern: 60;(.4+.2,.4+2)



This could be it! I'm at work now, but will change RingPattern and test when I get home. Strange that both RingName's are the same, but the RingPattern is different.

ckck

Well, after changing the RingPattern I tested by calling my google voice number from two different numbers.

Not really surprising, but now calls from both SP1 and SP2 ring the same way on my home phone. Specifically, here's what I set RingPattern to in Obi's expert configuration:

  Ring Profile A
RingPattern: 60;(2+4)

  Ring Profile B
RingPattern: 60;(2+4)