Problems with DTMF tones

Started by ChrisThompson, April 04, 2011, 12:59:16 PM

Previous topic - Next topic

ChrisThompson

I'm having a problem with the OBI110 handling DTMF tones from my handset.  I noticed this today when I was calling into a conference call line and the line kept telling me the code was invalid.

At first I thought the problem was that I was calling through the Google Voice line, so I called back using **8 to dial through the POTS line (connected to MagicJack).  I watched the MagicJack screen as I dialed the number.  When I dialed, the OBI did send the correct number to the MagicJack to be dialed.  However, once the connection was made, when I pressed a key on the phone, the number didn't always show up in MagicJack.  If I use my phone to key in "123456789", the MagicJack shows it only recognized the keys "124679".

I know this isn't a problem with MagicJack, because I've been using it for years and have never had an issue with it not recognizing the DTMF tones from my handset when it's directly connected to the MagicJack.

jimates

try it again only instead of pressing **8, press #. This should connect the handset directly to the line port (MJ) without the Obi in play.

Confirm it works ok like that then troubleshoot the Obi.

ChrisThompson

Okay. I tested by hitting #, waiting for the dial-tone and dialing the number.  During the dialing sequence, I can watch the numbers come up in the MJ interface just fine.  However, again, once the call is connected, only about 40% of the time does the dialed number show up in the MJ interface.

For example, I was dialing a room code (say 123456), I would have to push each number 1-6 times before it would show up in the MJ interface.  Once each number showed up, the conference call number recognized the correct room number.  In other words, I had to dial "11112233344566#" for the conference call number to recognize "123456#".

Further testing shows the same problem happens with dialing out over Google Voice on SP1, though I can't watch exactly what numbers are actually recognized.  Using the OBI test number (222-222-222), I can hear each DTMF tone as I press each number, but if I don't give sufficient time between each press, the tones won't play or they are cut off (a very short tone) or distorted.

With this new information in mind, I called back via MJ and found that if I left a 1.5-2 second delay between each number press, that the tone would get properly registered.

So it appears that the problem is that you cannot dial a numbers on a connected call without providing a full 2 second delay between each number.  This is a fairly serious issue for anyone that uses their phone to call services that request information dialed via tones.  A lot of support numbers request you enter your account number, last 4 SS#, telephone number, or other info on the phone.  With this issue, I can never be 100% certain that anything I've dialed has actually been recognized as a valid entry by the recipient.

jimates

well, pressing # is supposed to be the equivalent of the phone plugged directly into the Line device (MJ).

I would send an email to support@obihai.com

link to this thread, include your obi number

victorr


ChrisThompson

I sent an email to support and sent more detailed information.  I haven't heard back yet.

LeftRight

One more test that you can do is to directly connect your phone to MJ. Are the digits easily recognized by MJ after call is connected?

ChrisThompson

I have been using the same phone with the same MagicJack for more than a year, and previous to that I had a different phone connected to the same MagicJack for at least 2 years.  DTMF tones work just fine when the phone is connected directly.

Note that the DTMF problem occurs when calling over Google Voice as well as using **8 or # to dial out over the Line port, so even taking MJ out of the equation the problem exists.  MJ softphone allows me to monitor how the port is recognizing the tones whereas with Google Voice I have no way of knowing what the other end is recognizing, so it's a good diagnostic tool.

RonR

Just for clarification...

**8 and # do not give a hard-wired/physical connection between the OBi PHONE Port and LINE Port.  It's a bridged or logical connection, and I imagine audio, DTMF, etc. are still going through all the normal OBi components as usual.  I don't know, but it's possible DTMF is being decoded on the PHONE Port and regenerated on the LINE Port in this scenario.

You can get a hard-wired/physical connection between the OBi PHONE Port and LINE Port by removing power from the OBi.  There's a relay that drops out, forcing this connection for fail-safe purposes.

LeftRight

As RonR said, power off OBi unit will give a physical connection between phone port and line through relay, so double check if you can get same DTMF performance as directly connecting your phone.

Dial # will bypass OBi unit, i.e., NO DTMF detection on the PHONE port and NO regeneration on the LINE port, though there is a A/D, D/A path, and you may tune channel RX/TX gain to see if that make a difference. Ideally, you should see same DTMF performance as you remove power from the OBi ...

RonR

Quote from: LeftRight on April 07, 2011, 06:58:58 PMDial # will bypass OBi unit, i.e., NO DTMF detection on the PHONE port and NO regeneration on the LINE port ...

There is DTMF detection (but insufficient evidence to go out on a limb about DTMF regeneration) after dialing '#'.  SYSLOGing clearly shows the DTMF detection going on.

ajayhere24

I am having a similar issue too. If anyone figures out a solution to it, please do let me know.

thank you,
Ajay

ChrisThompson

I'm still having the problem.  I haven't yet tested it with the OBi unplugged.

ChrisThompson

With the OBI110 unplugged, dialing DTMF tones through the Line works just fine.  I really hope this is a software issue and not a hardware issue because I use my phone for conference calls almost every day and really need to be able to dial tones to enter the conference ID number.

infounlim


Kaizer

i have obi with gv as sp1. i'm experiencing the same issue with using a calling card for international calls. obi via gv connects to the local call center. the other end has a hard time validating the pin that i must enter. a certain pause between each digit is required but i've only had 1 successful try.

RonR

Kaizer,

It's been suggested that enabling the following setting may help:

Service Providers -> ITSP Profile x -> General -> X_UseFixedDurationRFC2833DTMF : (checked)

ChrisThompson

That setting is enabled on both my SIP accounts.

RonR

The suggestion was originally made in the context of Google Voice DTMF problems, but I suspect it can't hurt to have it enabled in any case.

I haven't experienced any DTMF problems with either Google Voice or SIP providers and haven't found this setting to make a difference either way, but let's hope it helps Kaiser.

earthtoobi

i used to have similar issues in the past especially when entering conference PIN number.
Making it to in-band DTMF solved my problems.

(Even after the above setting i have issues once in a  while when i type in PIN numbers real fast,but i don't consider it a problem.)