May 05, 2021, 10:03:31 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2] 3
  Print  
Author Topic: Problems with DTMF tones  (Read 132576 times)
obi-master
Newbie
*
Posts: 15


« Reply #20 on: May 06, 2011, 10:15:24 am »

Having the same issue. Can Obi support comment on this
Logged
Kaizer
Jr. Member
**
Posts: 33


« Reply #21 on: May 06, 2011, 02:15:16 pm »

Having the same issue. Can Obi support comment on this

I incorporated RonR's suggestion and :

Service Providers -> ITSP Profile x -> General -> DTMFMethod -> InBand

If you are on auto provisioning, uncheck obitalk settings, uncheck default then change to InBand

Working so far.
Logged
ChrisThompson
Jr. Member
**
Posts: 21


« Reply #22 on: May 06, 2011, 02:17:30 pm »

Unfortunately, this doesn't address the issue of DTMF tone issues when dialing out of the LINE port using **8 or #.
Logged
OBiSupport
Administrator
****
Posts: 267


« Reply #23 on: May 06, 2011, 02:58:23 pm »

There are a couple of places where a DTMF tone can get lost or go undetected.  Here are a couple things to try if you are having issues getting DTMF tones to a far-end peer (VoIP and/or PSTN).

1.  Change the DTMF transmit method to in-band.
Service Providers > ITSP Profile X > General > DTMFMethod = InBand

2.  Increase the audio gain setting for audio (DTMF) generated by the phone attached to the OBi PHONE port.
Physical Interfaces > PHONE Port > Port Settings > ChannelRxGain = 5
The "5" recommendation is arbitrary. Find a setting that works for your environment. Setting this too high could result in the OBi caller hearing their echo and/or the far end experiencing audio cut-out or the OBi caller being just too plain loud.
Note:  Only applicable to DTMF tones when "InBand" signalling is invoked.

3. Increase the LINE port audio gain setting.
Physical Interfaces > LINE Port > Port Settings > ChannelTxGain = 5
Again, the "5" recommendation is arbitrary.

4. Increase the DTMF playback level on the LINE port.
This is for those cases where a call is being bridged from VoIP to the LINE port or the LINE port is the Primary Line to Call Out (or **8 is used to make a call from the OBi PHONE port or AA).
Physical Interfaces > LINE Port > Port Settings > DTMFPlaybackLevel = 0
The "0" recommendation is arbitrary.

Logged
Kaizer
Jr. Member
**
Posts: 33


« Reply #24 on: May 07, 2011, 12:54:33 am »

well i got ahead of myself. changing to inband resulted in cell phone calls to obi for 2 stage calling to break. AA does not recognize the DTMF (from sprint or verizon). so this:

Service Providers -> ITSP Profile x -> General -> X_UseFixedDurationRFC2833DTMF : (checked)

didn't help either.

I guess I'm left with only this option to play with?

2.  Increase the audio gain setting for audio (DTMF) generated by the phone attached to the OBi PHONE port.
Physical Interfaces > PHONE Port > Port Settings > ChannelRxGain = 5
The "5" recommendation is arbitrary. Find a setting that works for your environment. Setting this too high could result in the OBi caller hearing their echo and/or the far end experiencing audio cut-out or the OBi caller being just too plain loud.
Note:  Only applicable to DTMF tones when "InBand" signalling is invoked.
Logged
ChrisThompson
Jr. Member
**
Posts: 21


« Reply #25 on: May 10, 2011, 11:36:52 am »

Here's what's going on from syslog when dialing via "#" direct to the line port. These tones are not always recognized by recipient:

Code:
May 10 12:24:26  [DSP]: ---- H/W DTMF ON (level:3) : 6 @ 209421 ms----
May 10 12:24:26  [DSP]: ---- H/W DTMF OFF @ 209551 ms ----
May 10 12:24:26  [DSP]: ---- H/W DTMF ON (level:3) : 6 @ 210071 ms----
May 10 12:24:26  [DSP]: ---- H/W DTMF OFF @ 210201 ms ----
May 10 12:24:28  [DSP]: ---- H/W DTMF ON (level:3) : 0 @ 211321 ms----
May 10 12:24:28  [DSP]: ---- H/W DTMF OFF @ 211451 ms ----
May 10 12:24:29  [DSP]: ---- H/W DTMF ON (level:3) : 5 @ 212821 ms----
May 10 12:24:29  [DSP]: ---- H/W DTMF OFF @ 212951 ms ----
May 10 12:24:29  [DSP]: ---- H/W DTMF ON (level:3) : 8 @ 213191 ms----
May 10 12:24:30  [DSP]: ---- H/W DTMF OFF @ 213321 ms ----
May 10 12:24:30  [DSP]: ---- H/W DTMF ON (level:3) : 1 @ 213591 ms----
May 10 12:24:30  [DSP]: ---- H/W DTMF OFF @ 213721 ms ----
May 10 12:24:30  [DSP]: ---- H/W DTMF ON (level:3) : 2 @ 213961 ms----
May 10 12:24:30  [DSP]: ---- H/W DTMF OFF @ 214091 ms ----

Here's what happens when dialing via Google Voice (SP1) with the "InBand" setting enabled.  These tones do appear to be recognized by the recipient:

Code:
May 10 12:25:57  RTP: Start->480ed57e:19295(80);0;0;0:0:0;1(42)
May 10 12:25:57  RTP: Skt Connected
May 10 12:25:58  RTP: PeerRflxAddr=480ed57e:19295
May 10 12:26:02  [DSP]: ---- H/W DTMF ON (level:3) : 6 @ 305990 ms----
May 10 12:26:02  [RTP] DTMF RFC -- dgt: 6, c_dgt:
May 10 12:26:02  [DSP]: ---- H/W DTMF OFF @ 306110 ms ----
May 10 12:26:04  [DSP]: ---- H/W DTMF ON (level:3) : 6 @ 307700 ms----
May 10 12:26:04  [RTP] DTMF RFC -- dgt: 6, c_dgt:
May 10 12:26:04  [DSP]: ---- H/W DTMF OFF @ 307830 ms ----
May 10 12:26:05  [DSP]: ---- H/W DTMF ON (level:3) : 0 @ 308870 ms----
May 10 12:26:05  [RTP] DTMF RFC -- dgt: 0, c_dgt:
May 10 12:26:05  [DSP]: ---- H/W DTMF OFF @ 309000 ms ----
May 10 12:26:07  [DSP]: ---- H/W DTMF ON (level:3) : 5 @ 310700 ms----
May 10 12:26:07  [RTP] DTMF RFC -- dgt: 5, c_dgt:
May 10 12:26:07  [DSP]: ---- H/W DTMF OFF @ 310830 ms ----
May 10 12:26:08  [DSP]: ---- H/W DTMF ON (level:3) : 8 @ 311420 ms----
May 10 12:26:08  [RTP] DTMF RFC -- dgt: 8, c_dgt:
May 10 12:26:08  [DSP]: ---- H/W DTMF OFF @ 311550 ms ----
May 10 12:26:08  [DSP]: ---- H/W DTMF ON (level:3) : 1 @ 312050 ms----
May 10 12:26:08  [RTP] DTMF RFC -- dgt: 1, c_dgt:
May 10 12:26:08  [DSP]: ---- H/W DTMF OFF @ 312180 ms ----
May 10 12:26:09  [DSP]: ---- H/W DTMF ON (level:3) : 2 @ 312730 ms----
Logged
ChrisThompson
Jr. Member
**
Posts: 21


« Reply #26 on: May 10, 2011, 11:50:55 am »

I applied the suggested settings by OBisupport and it does appear that DTMF tones are better recognized now.  I still get the occasional dropped number, especially when dialing quickly, but it works significantly better.
Logged
AndyJ
Jr. Member
**
Posts: 46


« Reply #27 on: May 11, 2011, 09:31:06 am »

It looks like something changed in the 1.2.1(2283) firmware. DTMF was actually working fine for me with the default settings before the upgrade, but is now very inconsistent after the upgrade. Sometimes it works, sometimes it doesn't (more often not).
Logged
GC_convertee
Jr. Member
**
Posts: 20


« Reply #28 on: May 13, 2011, 07:30:32 pm »

Hi I have the same problem (but have had it sporadically with using SIP / Sipgate / GV before I had the obitalk too)
ie dialing into conference calls, etc

Once I hooked up the obitalk110, I tried to dial into the secondary google voice account configured, to muck around with the voicemail features-in GV's ivr menu, but Google Voice wouldn't recognize my PIN.

I have decent Panasonic cordless phones kx-tga939t
When I press and hold the buttons on the handset, the dtmf tone stays on as long as I press the button.
But when I listen on the other end (via a cellphone or something), it's only a short dtmf tone, no matter how long I hold down the panasonic buttons

So it seems that my cordless phone does really have press-and-hold-dtmf tones
1. Does anyone know of a dect cordless sys that has press and hold
2. Is there gain or other settings to increase the dtmf tones on the receiving end?

Note I've only configed the obitalk thru the web portal and not directly via web admin, I read they can conflict

Also I do not have a landline to test and the phone is hooked up correctly

Thanks
G
« Last Edit: May 15, 2011, 03:41:49 pm by GC_convertee » Logged

GrandCentral in 2004, had Gizmo5 acct
Analog Fax working IB & OB...
efax acct revoked
faxzero.com (<=2 free/$2 for 3+pgs)
Linksys SPA-2102 ATA 2 Sipgate lines/free accts, $20 balance for OB faxes dialing
Obi110 2 GV accts No POTS/FXO
Panasonic kx-tga939t Dect Cordless -  Ans machine OFF
haiml
Newbie
*
Posts: 6


« Reply #29 on: May 18, 2011, 05:20:25 pm »

try this  to test DTMF:
http://www.testcall.com/222-1111.html
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #30 on: May 18, 2011, 05:41:44 pm »


If you have iNum calling configured, they also have a number that repeats your DTMF digits back :  883510000000092
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #31 on: May 21, 2011, 12:56:22 pm »

My DTMF problem was on SP1/GV and started after installing Build 2283.  DTMF tones work perfectly on SP2/SipSorcery with the default settings.

Changing "ITSP Profile A/General/DTMFMethod=InBand" seemed to fix the problem until today when I called my cell phone number to listen to a voice message.  My cell phone provider failed to recognize any DTMF tones.

Changing "Phone Port/DTMRxMode=Software" fixed the problem with my cell phone.

It seems OBiHai's quality control is lacking.  They should do no harm when providing a firmware upgrade.
Logged
slk23
Newbie
*
Posts: 1


« Reply #32 on: June 02, 2011, 11:23:33 am »


"Phone Port/DTMRxMode=Software" fixed the problem for me too.  I'm using a regular phone and not a cell phone.  It was working fine before the firmware update.

My DTMF problem was on SP1/GV and started after installing Build 2283.  DTMF tones work perfectly on SP2/SipSorcery with the default settings.

Changing "ITSP Profile A/General/DTMFMethod=InBand" seemed to fix the problem until today when I called my cell phone number to listen to a voice message.  My cell phone provider failed to recognize any DTMF tones.

Changing "Phone Port/DTMRxMode=Software" fixed the problem with my cell phone.

It seems OBiHai's quality control is lacking.  They should do no harm when providing a firmware upgrade.

Logged
zoomin
Newbie
*
Posts: 15


« Reply #33 on: June 04, 2011, 04:36:23 pm »

There are a couple of places where a DTMF tone can get lost or go undetected.  Here are a couple things to try if you are having issues getting DTMF tones to a far-end peer (VoIP and/or PSTN).

1.  Change the DTMF transmit method to in-band.
Service Providers > ITSP Profile X > General > DTMFMethod = InBand

2.  Increase the audio gain setting for audio (DTMF) generated by the phone attached to the OBi PHONE port.
Physical Interfaces > PHONE Port > Port Settings > ChannelRxGain = 5
The "5" recommendation is arbitrary. Find a setting that works for your environment. Setting this too high could result in the OBi caller hearing their echo and/or the far end experiencing audio cut-out or the OBi caller being just too plain loud.
Note:  Only applicable to DTMF tones when "InBand" signalling is invoked.

3. Increase the LINE port audio gain setting.
Physical Interfaces > LINE Port > Port Settings > ChannelTxGain = 5
Again, the "5" recommendation is arbitrary.

4. Increase the DTMF playback level on the LINE port.
This is for those cases where a call is being bridged from VoIP to the LINE port or the LINE port is the Primary Line to Call Out (or **8 is used to make a call from the OBi PHONE port or AA).
Physical Interfaces > LINE Port > Port Settings > DTMFPlaybackLevel = 0
The "0" recommendation is arbitrary.




I'm having troubles dialing out on my land line (AT&T).

Only rarely a call goes through. Most of the times, I get a message from AT&T "Your call cannot be completed at this time."

I have the latest firmware and a unit reset to factory defaults. I did try to tinker with the settings suggested above, but still cannot get it to work consistently.

Is there anything that I can do to fine tune it? Any way to make DTMF tones longer? They seem to be too short compared to what my phone is putting out.

Thanks!
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #34 on: June 04, 2011, 04:39:33 pm »

Any way to make DTMF tones longer? They seem to be too short compared to what my phone is putting out.

Physical Interfaces -> Line Port -> DialDigitOnTime
Logged
zoomin
Newbie
*
Posts: 15


« Reply #35 on: June 04, 2011, 05:41:14 pm »

Any way to make DTMF tones longer? They seem to be too short compared to what my phone is putting out.

Physical Interfaces -> Line Port -> DialDigitOnTime


Great! And you know what? It actually did the trick!

I set DialDigitOnTime to 300 (was 200), and DialDigitOffTime to 50 (was 200).

Did 5 calls and all 5 went through fine!

So, if anyone else is having similar issue, I strongly recommend playing with these values. Smiley

Thanks, RonR!
Logged
Dale
Full Member
***
Posts: 87


« Reply #36 on: October 12, 2011, 12:58:04 pm »

same problem here using GV.
I found that if i held down the numbers for longer it would work. I looked in vain for DialDigitOffTime in the Phone settings for an Obi100 but could not find that parameter.

Changed

Physical Interfaces -> PHONE -> PortDTMFRxMode to Software
an intitial test seemed better but the Rx suggests this is to do with receiving...
Now trying Service Providers > ITSP Profile X > General > DTMFMethod = InBand
« Last Edit: October 27, 2011, 10:04:58 am by Dale » Logged
Dale
Full Member
***
Posts: 87


« Reply #37 on: October 13, 2011, 08:56:43 am »

it helped, but again today I had to hold down the keys longer to get them to work...

is there a DialDigitOnTime  setting for the PHONE port?  (i cant see it)
Logged
ShermanObi
Administrator
****
Posts: 176


« Reply #38 on: October 13, 2011, 11:20:58 am »

@Dale
A software update may be the remedy.
Please dial ***6 from the phone attached to your OBi.
If there is a software update, press 1 and hand-up.
Your OBi will automatically download the latest firmware and restart.
This usually takes no more than 2 minutes.
Logged
Dale
Full Member
***
Posts: 87


« Reply #39 on: October 18, 2011, 12:12:35 pm »

all my obi boxes are fully up to date.
Logged
Pages: 1 [2] 3
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement