August 04, 2021, 06:07:19 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Obihai logging into Google Hourly  (Read 6420 times)
dvbhardware
Newbie
*
Posts: 18


« on: June 25, 2013, 01:10:29 pm »

Obihai 100 keeps logging into Google account  every hour on the same minute
Just wondering if it is the obi testing the connection to the Google voice account? It was bugging me because I have Firefox v22 not v9 which I rarely use.

Google>Accounts>Security>Recent Activity
Signed in from Firefox (Windows)

IP Address
68.xxx.xxx.xxx
ipxx-xx-xx-xx.xx.xx.cox.net.
Browser
Firefox 9.0
Platform
Windows

Jimmy
Logged
RichardJB
Newbie
*
Posts: 2


« Reply #1 on: June 27, 2013, 04:14:27 pm »

Interesting -- I just checked my account, and I see it too.  It appears to have started for me (Obi100) at 9:31PM (Pacific) on 6/26/13.  Coincidentally, this appears to be around the time that the recent GV Maintenance (which prevented people porting their numbers in for a few days) ended.

I think the "Firefox 9.0/Windows" stuff must be being spoofed by the Obi.  Perhaps this hourly login has been happening all along, but was previously being supressed in the "Recent Activity" listings by the GV security software.  And maybe the recent maintenance broke that code.  Just a guess...
Logged
foreman
Newbie
*
Posts: 2


« Reply #2 on: July 06, 2013, 09:15:43 am »

I'm having the same problem with my OBi 100.  Exactly once every hour - to the minute - the obi device signs into the google account I configured for it.

What makes matters worse is that this automated signin activity is preventing me from using that google account for other legitimate activities. For example, when I attempt to authenticate another application (via oauth) to access certain pieces of my account data, Google prevents me from doing so with the error message:

Our systems have detected unusual traffic from your computer network. Please try your request again later. Why did this happen?
IP address: xxxx
Time: xxxx
URL: http://accounts.google.com/OAuthAuthorizeToken


So I've had to unplug my obi until I find a remedy. I know it's the obi that's doing this because when I unplug it, the hourly google signins stop. Even stranger, the obi appears to be spoofing a "Firefox 9.0" browser header - to see this just login to "accounts.google.com", go to Security / Recent Activity, click a particular signin event, and look at the event details.

Google Voice and my ObiTalk OBi 100 are completely useless because my obi keeps signing in exactly every hour, which Google Accounts sees as "unusual traffic" from my computer network, which results in Google blocking certain account activities - such as OAuth authorizations for other legitimate applications!  Sad

Is OBi Tech Support reading this forum? Please help with this problem.
Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #3 on: July 06, 2013, 10:07:35 am »

It has been posted that it is best to have a separate Google account for your OBi GV use.

See http://www.obitalk.com/forum/index.php?topic=62.60 for some reasons and methods.
Logged
foreman
Newbie
*
Posts: 2


« Reply #4 on: July 06, 2013, 10:30:23 am »


Thanks for the link, but the account I speak of IS separate from my primary google account that I use for email, docs, ...

It is an account used only for shared services such as Google Voice and Google Cloud Print. For example, I've configured Google Cloud Print in this account that I then share with others. The printer can then scan directly to this account's google drive - but before the printer can do that it needs authorization via OAuth.  Family members can also login to this account to check GV messages and missed calls.  I did not want to create a different google account for each shared service as it becomes unmanageable.

The problem is that the OBi keeps signing in to this account exactly every hour. If that wasn't happening then this configuration would work. Why does the OBi keep signing into this account ever hour?
Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #5 on: July 06, 2013, 10:58:45 am »

I don't know why,  but I would guess that it is to maintain reliable operation or to detect a failed connection or to adjust for a GV protocol change. Why is that a problem?
Logged
Clive
Jr. Member
**
Posts: 68


« Reply #6 on: July 07, 2013, 01:31:21 am »

You will probably find that this is NAT keep alives being sent. This maintains the connection from the obi through your router as well as telling Google where your obi is to receive the calls.

Without the keep alive signal, the ports would automatically be closed and google wouldn't be able to see the obi.
Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #7 on: July 07, 2013, 01:40:45 am »

These guys are not seeing a keep-alive packet. They are seeing an automated login recorded by Google.
Logged
RFord
Full Member
***
Posts: 218


« Reply #8 on: July 07, 2013, 06:27:07 am »

Technically, how do you expect to make calls through your GV account without some form of authentication?  That is why you need your gmail account information, including your password when setting up GV on the OBi ATA.

When you sign up for a paid VOIP provider, you need the SIP info (username and password) to enter into your ATA for registration or to make outgoing calls in cases where registration is not required.  This also applies to GV.

When you see the word "Connected" on your OBi ATA, what do you think it means?  The regular "login" you are seeing is akin to a re-registration every hour or whatever the period is.
Logged
nlurker
Jr. Member
**
Posts: 28


« Reply #9 on: July 09, 2013, 02:32:19 pm »

http://www.obitalk.com/forum/index.php?topic=6147.0
Logged
martin595
Newbie
*
Posts: 5



« Reply #10 on: July 09, 2013, 10:12:09 pm »

The problem of obi occurs in Firefox. But it can be overcome by using the chrome browser.
As the chrome extension make its use easy.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement