Obi100 with alarm system problems

Started by Shannon, April 09, 2011, 01:16:20 PM

Previous topic - Next topic

Shannon

I am having trouble getting my alarm system working with the Obi100.  I ran a test and call the alarm company and they said they never received a signal.  I checked the Obi100 call history and it DID record 2 phone calls from the alarm box.  My guess is that some of the tones and signals are getting distorted in the analog/digital conversions from either the Obi100 or google voice.  Note, I did notify the alarm company of the updated google voice phone number.

I have already tried "Changing the Phone port DTMFRxMode from "Hardware" to "Software" , but that didn't work. 

Does anyone else have any suggestions to make this work with the alarm?  Thanks!

QBZappy

Shannon,

Hi

There is another thread discussing the OBi and alarm systems. You may like to read it to get some ideas. Perhaps you can try a test with another VoIP service provider. There are some like Voip.ms which charge only for usage plus a small monthly fee for a DID number ($0.99/mo). You may get better results.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

heartsurgeon

i have an obi110, same problem, no signal to the alarm company, inspite of the suggested change to "software"

SteveInWA

#3
As discussed in another thread, alarm systems communicate over phone lines using a rather primitive protocol, consisting of a few audio tones to handshake and say "goodbye" (the alarm protocol calls the latter "kiss-off").  In-between the handshakes, the actual alarm event is transmitted using touch-tone digits (DTMF).  This technique has been around for over 25 years, and it wasn't designed with error-correction (beyond retrying a few times before giving up).  So, it requires a high-bandwidth codec and relatively clean, clear tones.  Unless you've changed it, I believe OBi with Google Talk is configured to use the G.711 codec, which is what you want, and you should also try changing DTMFMethod from the default (Auto) to "InBand", just to ensure that the tones are being played over the voice channel (I don't know how it behaves in "Auto" mode).  This is the same way the tones would be sent over a classic POTS/PSTN line.  This is not the same DTMF setting as discussed earlier.  See my screen shot for details.

Let us know if this helps.  If not, as discussed before, I'd suggest trying a quality VoIP provider like Callcentric, configured as your other ISTP, instead of using Google.  Again, use the same recommended settings (G.711 with in-band DTMF).

*Disclaimers:  1) I do not work for an alarm company, nor for Callcentric.  2) I have not tried this on my own alarm system -- I keep a PSTN line for this purpose.  3) YMMV, and per OBi's own documented warnings, GV on the OBi device isn't intended for emergency communications (which alarm messages could be considered).