December 11, 2017, 08:46:05 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: *72 Call Forward All with Anveo always forward to my voicemail !? (SOLVED)  (Read 13132 times)
spintronics
Newbie
*
Posts: 8


« on: October 12, 2013, 06:39:55 pm »

Hello,

I am trying to get unconditional call forwarding to work with a specific number. Instead, the forward goes to my voice mail box !? When I look at the OBi parameters, things looks ok. Any clue would help me ? Is this issue related to Anveo ? Maybe this requires more that one channel ?

CallForwardUnconditionalEnable: checked
CallForwardOnNoAnswerNumber: SP2(15143802967)

The number is a real number I am using for testing.

Thanks !
« Last Edit: October 19, 2013, 06:16:05 am by spintronics » Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #1 on: October 12, 2013, 10:06:50 pm »

Your Anveo voicemail box? If so, review your call flow. See what conditions would result in the call going to your voicemail.

Was the SIP offline? Look at the status to see if it is online.
Logged
spintronics
Newbie
*
Posts: 8


« Reply #2 on: October 13, 2013, 05:56:59 am »

Hi Shale, the call flow I am using is Anveo's default call flow.
Things works fine when the unconditional call forward is OFF.

For incoming calls, the phone rings and:

1- if I answer then I can have a conversation and
2- if I don't answer, then it goes into the voice mail box.

SIP status is online

Cheers !
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3190


« Reply #3 on: October 13, 2013, 07:31:32 am »


CallForwardUnconditionalEnable: checked
CallForwardOnNoAnswerNumber: SP2(15143802967)


Did you make a typo when you posted?

CallForwardOnNoAnswerEnable: checked
CallForwardOnNoAnswerNumber: SP2(15143802967)
Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #4 on: October 13, 2013, 08:14:17 am »

Good catch,azrobert .

Spintronics, in the admin guide, I see *72  Call Forward All (Enter Number + #)

So enter the forwarding number as a suffix to the *72.

For your forwarding test, I think it is your plan that the call come into GV on SP1, the OBi forwards it to 15143802967 via SP2, and where are you picturing the call going from there? Or did I get that wrong?
Logged
spintronics
Newbie
*
Posts: 8


« Reply #5 on: October 13, 2013, 08:35:41 am »

Azrobert, crap, this was a copy & paste typo in my post. Sorry about that.
The setting were all right because I set them on phone with *72<number># (unconditional call fwd) and validated the corresponding parameters inside the OBi web management interface.

Shale, for clarification, the behaviour I want is to call my number (home in this case from SP2) and get transferred unconditionally and immediately to 15143802967 (with SP2 again).

My primary SP is SP2, which is Anveo. SP1, the secondary SP, is google voice (outgoing calls only because I am in Canada).

So when I receive calls or make outgoing calls without the **1 escape sequence, Avneo is used (SP2).

Sorry again for the stupid typo, it went through despites my double-check, maybe it was a little late last night for this post.

Cheers !
Logged
Shale
Hero Member
*****
Posts: 1061


« Reply #6 on: October 13, 2013, 09:34:08 am »

I don't know how it works using SP2 as incoming and outgoing both. Maybe somebody will have some info on that. Maybe you could enter *72**115143802967 -- at least as a test.

I have not understood how to do more than one call at once on an SP.

I could tell you how to accomplish that and more with a call flow on Anveo. I think you could have both your home and away numbers ring, and the first pick up gets the call. But unconditional would be quite easy.  http://www.anveo.com/business/features.asp?code=transfertophone talks of the Transfer call flow element. I think the element has been revised since that page was written, but the essential stuff is the same. The bottom path(s) could lead to a Voicemail element.

Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #7 on: October 13, 2013, 10:04:00 am »

Quote
I don't know how it works using SP2 as incoming and outgoing both. Maybe somebody will have some info on that.

This should be no problem as most voip providers allow two sessions (calls) on each trunk. This allows you to do three-way calls etc. The default setting for an OBi is to also allow two sessions for each spX. This can be increased if required.

Logged
spintronics
Newbie
*
Posts: 8


« Reply #8 on: October 13, 2013, 12:41:21 pm »

The three way calls works fine once the unconditional forward is removed; i just tested this.
Additionally, call waiting works fine, I can switch between the two callers.
So yes, more that one call works; and on SP2 (which is Anveo).
This eliminate the possibility of channel exhaustion

Now I am still clueless as to why call unconditional forwarding does not work.

 
Logged
spintronics
Newbie
*
Posts: 8


« Reply #9 on: October 19, 2013, 06:24:42 am »

Ok, the problem has been resolved via a SIP trace made by Anveo.

First Anveo mentioned that the SIP port to be used should be 5010 and not 5060. In my configuration 5060 was used all over and this is the default OBItalk configuration for Anveo, this configuration is wrong and should be corrected by obihai.

Second, when doing a call forward, the OBi device send a "SIP/2.0 302 Moved Temporarily" as a way to do better resource management in the device. This mode is not supported by Anveo. So the parameter X_Use302ToCallForward should be UNCHECKED to prevent this. Again, this is not the right config default for Anveo and should be corrected by obihai.

Now things work fine. I hope this information can help others to fix the problem.

Chers !
« Last Edit: October 19, 2013, 06:32:04 am by spintronics » Logged
kb9nvh
Jr. Member
**
Posts: 23


« Reply #10 on: November 16, 2013, 07:50:30 am »

I'm having trouble getting Anveo to ring at home..I can make outgoing calls and my e911 works fine and all defined on sp1.  I went in and change all ports to 5010 except the registration port that i left as 5060. 
Config for obi100 is to change UDP to TCP but that gave me an error with anveo so I changed it back to tcp.

I'm desperate to get my phone ringing again and its dissapointing that the OBI anevo setup is incorrectly setting ports.
Logged
INOVATEL
Newbie
*
Posts: 1


« Reply #11 on: June 06, 2017, 04:25:33 am »

Hello, old post, but I think this will be useful for several. I created two Call Flow you can use to forward calls with *72 star code.

https://www.dslreports.com/forum/r31450804-Anveo-72-Anveo-call-forwarding-How-to

Have a nice day.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC