On Tuesday September 6th the forum will be down for maintenance from 9:30 PM to 11:59 PM PDT

Main Menu

My voice is not registering [FIXED]

Started by Pacino, December 10, 2013, 07:19:28 PM

Previous topic - Next topic


Hello, I recently purchased an OBi100, which I configured with CallCentric. We have two Google Voice numbers that forward to the CallCentric number. But when I receive a call to my Google Voice number (through CallCentric to the OBI), or place a call, I can hear the other party, but they cannot hear me. I have a Belkin F7D5301 router. I'm not sure what to do -- do I need to forward ports or set up a static IP or something? I'm not really sure how to do any of that stuff. I'm afraid I'm no tech expert -- I thought setting up the OBi was going to be easy, and it was, but now I'm stumped.

Thanks for any help!


Some options.
Try adding a stun server to your Obi. 

Put your Obi in the DMZ

Disable SIP ALG

Port to forward.
Allow Outgoing:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060, 5061, 10000 to 11000, 16600 to 16998, 19305
Allow Incoming on UDP Port: 10000
Long live our new ObiLords!


Did you use the Obitalk web service to configure your OBi?  Or did you find out the IP address of your OBi and configure it directly?  If doing this on your own I would recommend the web service.

I just read the Belkin user manual for that router.

It's not the worst I've read.  It does have a few glaring errors that probably will not hurt anyone.

I also noticed that Belkin lists only V1 firmware for that router.  Apparently they still suffer from the problem they did several years ago when I last bought Belkin gear -- firmware does not get updated like it should.

I did not find any reference to a SIP "ALG" or "Application Gateway" function.  That's not too rare, but they also don't mention FTP and not having that seems odd.

If you can find any reference in your router's web user interface, typically in the firewall section, to a SIP gateway, change the setting -- off it is on, on if it is off.  If it makes no difference, leave it off.

If after trying this, and the stun server, your next step would be Callcentric support.  They will probably have you reset your OBi back to factory defaults and configure it directly.  I seem to recall a help page on the Callcentric site with instructions on how to do that.


It might be instructive to dial the OBi echo test number and check if, after the announcement, you can hear your own voice coming back to you slightly delayed.  If yes, then you know your phone's microphone, its connection to the OBi and the OBi's digital encoder are all OK.

Assuming you haven't changed the OBiTalk defaults, dial **9222222222.  (That's nine twos.)


You guys are awesome -- thanks so much for taking the time to help out a newbie! I think the stun server was the key, although I also set up those ports to forward. It did not work immediately after I set up the ports to forward, but that might also be because I did not restart my router immediately. Then I set up the stun server, restarted the OBi and the router, and voila -- everything is working great now. Thanks again!