On Tuesday September 6th the forum will be down for maintenance from 9:30 PM to 11:59 PM PDT

Main Menu

Anveo Lack of Support

Started by feelyat, April 17, 2014, 04:48:53 PM

Previous topic - Next topic


I have had an Anveo number now for about two weeks, and I have chosen to forward my GV number, rather than port it.  Unfortunately, like others here, I made the mistake of signing up for a year's service rather than trying it out a month at a time.  I have run into only one major issue, but the lack of support has been troubling.

Every time I call certain 800 numbers, I get no connection, and a message saying that "no response has been received from the service provider".  When I sent an email to Anveo support, they said that geographic restrictions on 800 numbers are set by the toll free operator and that Anveo can't control them.  To be fair, they came back with that response very quickly, but there has been no followup.

I'm not sure why they say there are geographic restrictions.  I am calling from a US number, to a US company.  Are they saying that the company I am calling is refusing calls from Anveo numbers?  If so, they should say that. Instead, I get nothing when I email asking for clarification.  Should I open a ticket? 


Toll Free Numbers (TFNs) work differently than regular inbound numbers.  The company who is using the TFN has to pay for every inbound call.  So, their TFN supplier can let them define which calling locations can call their TFN.  For example, if you are a business or government agency that only has customers in, say, Iowa, then you can restrict inbound calls only to callers in Iowa.  This is less common today than 20 years ago, what with internet e-commerce, but the restriction feature is still available.  If your Anveo number appears to the TFN provider as if it was from a restricted area, then the call won't complete.  Another example would be if Anveo is mangling your caller ID, and it looks like it's from another country, or if your caller ID or calling origin is blocked entirely.  Now, if your Anveo number is legitimately within the TFN's allowed calling area, it really should be connected.  If Anveo is playing games with call routing, they might be causing the problem.  We do know that Anveo restricts calls to certain regular phone numbers, when the called number's phone  company charges high termination rates, but that's a separate issue.  Frankly, if this is a show-stopper to you, there are better alternative SIP ITSPs to which you can take your business...


My feeling is that my number should be within the geographical area for this TFN.  It's my health insurance company, and they are a national company, with customers in lots of states.  My caller ID and origin number are both in the 708 area code, so both in the same area of Illinois. My supposition is that Anveo is doing something weird with the calls, which is causing the TF operator to refuse the connection.  Unfortunately, I can't be sure of that, and they're not being very responsive.

Not being able to call my insurance company is not what I'd call a showstopper, but it does fall into the category of pathetically inadequate service. In order to make certain calls, I need to use my cell phone?  Really?  And they won't even respond to my questions?

As I said, I paid for a year of advance.  I guess I learned my lesson.


Just some 2 cents stuff. I'd test it with spoofing disabled. And then test it by doing a Google Voice callback. Find out what the non TFN DID is for your insurance company and see if that works.

This may be an ANI issue rather than CID. I can never spoof calls to my GV. It always reports the underlying number.

Find someone that can test the number from other services. I can test from VestaLink for instance as well as two different Anveo accounts.

I don't even know if it's possible but if the ANI doesn't match the CID and it's a sophisticated system, that may be what's blowing the fuse. I'd also try dumb things like leaving out the +1 and not leaving out the +1

You can also get a test account with VestaLink. I prefer Anveo but it certainly is hard to get them nailed down.


Quote from: feelyat on April 17, 2014, 04:48:53 PM

Every time I call certain 800 numbers, I get no connection, and a message saying that "no response has been received from the service provider".  

I'm having the same problem on Vestalink, with the British Airways Executive club 800 number, and also the regular BA 800 number.
Vestalink at first said it was a problem at their end, with their provider, but then changed their mind, saying there was a problem with my phone/obi. The problem wasn't consistent on Vestalink, and sometimes the call would go through. I tried with and without GV spoofing, leaving off the 1, but nothing worked consistently.

I finally set up SP2 with Circlenet, and can now call British Airways again, without trouble.


You can setup a free tollfree provider on a Voice Gateway and share the same SP trunk with your VOIP provider. Assuming your VOIP provider is defined on SP1.

Voice Services -> Voice Gateways and Trunk Groups -> Voice Gateway1

Name: Tollfree
Access Number: sp1(
DigitMap: (18(00|88|77|66|55|44)xxxxxxx)
AuthUserID: 4801234567 (your outbound callerid)

Add the following rule to the beginning of the Phone Port OutboundCallRoute:



Quote from: feelyat on April 18, 2014, 11:55:11 AM
Really?  And they won't even respond to my questions?
I paid for a year of advance.  I guess I learned my lesson.


Contrary to what some may want you to believe, this is NOT rocket science.

You shouldn't need to be jumping through hoops to try and MAKE it work.

If it doesn't work for you and Anveo won't respond then contact Paypal.

Don't be intimidated by Anveo into thinking that you paid 1yr upfront so it's YOUR fault.

Paypal doesn't play that game. Paypal calls the shots.

Initiate a Paypal dispute and you'll get your money back pronto.

I'm speaking from experience.

Take care,


Like what others have suggested, try a different outbound caller ID.  I had a problem with Localphone calling a specific number with a specific outbound caller ID.  That combination took up to 40 seconds to start ringing.  Calling a different number or changing the outbound caller ID took only ~5 seconds to connect.


If you PM me the 1-800 number you are calling, I'll be glad to call it from Anveo and see what response I get.


Just a thought. With these DIY Voip services, you usually pick a server that is close to you but may not necessarily be in the state you are in. So based on SteveInWA comments about 800 numbers, I would assume you could have an 800 number blocked even though it shouldn't be for the state you are in.


I was away from the home (and the OBI) for the weekend, and when I got back, calls to the TFN in question worked.  I made no changes that I know of, although I did open up a ticket with Anveo, and they said it was working on their end, so who knows?

The only thing I can think of is that Anveo lets me choose which geographic point-of-presence I want when I configure my phone number.  Currently, I am configured for USA - Houston TX.  When I first signed up, I configured it for Montreal, simply because the Canadian SIP server gave me a lower ping time.  Later, I thought it might be a better idea to use the USA POP.  Not fully understanding how "redundant points of presence" actually work, and also not fully understanding the Anveo web site, I don't know for sure what effect that might have had.  When I was having the original problem, the Geo.POP was set to USA.

Thanks for all the help.


I too had issues with certain 800 numbers after I switched to Anveo, and was told during an online chat by a representative to go to the My Accounts tab, select Account Preferences, then SIP Device Registration.  On the right side of your screen you will see an option to Generate artificial ringtone.  Uncheck this box.  After I did this I was able to connect perfectly with the problem numbers.  It might be worth a try.