Anveo - *99 Always Busy?

Started by threehappypenguins, May 12, 2014, 04:48:49 AM

Previous topic - Next topic

threehappypenguins

I can't figure this out. I want to access the voicemail for Anveo, but no matter what I try, *99 gives me the fast busy signal (reorder tone). When I check the history on the Obi, it doesn't show anything; no attempted access to *99... nothing. I have Anveo set up on sp3.

Here is what I have done:

1. For the Call Flow, they already had a bunch of stuff set up for me. It goes START (Configure me to block unwanted callers) > DELAY (let it ring for 3 seconds) > GOODIES (Detect Fax, VM Access, DISA) > SIP > Voicemail

2. Under Speed Dial 8 in the Obitalk portal, I have sp3(*123) and under Speed Dial 7, I have sp3(*99). In the OBi Expert, for Code29, I have *123, Change VM Greeting, call($spd[8]) and under Code40, I have *99, Voice Mail, call($spd[7]).

In my Anveo account, when I go to PBX > Voicemail Boxes > edit > Phone Access (tab), it says, "You can access voicemail by dialing *99 from your SIP phone or by calling your phone number (must be configured with Goodies call control). Simply provide voicemail box number and password. Note that you need to use Goodies Call Flow item in your Call Flow." I left the default Voicemail Box Number as 100.

If I go into the Callflow and edit the Goodies, and when I click on the Voicemail tab in the Goodies, it just says, "No additional options." On the General tab in the Goodies, it says (about the voicemail): "Goody 2. Listen to your recent Voicemails; To access Voicemail through Goodies, simply configure a desired Voicemail Call Control
by selecting configurational options on 'Phone Access' tab.
" So... I've already gone to the 'Phone Access' tab, and the phone access tab tells me to go to the Goodies. And when I go to the Goodies, it tells me to go to the 'Phone Access' tab. This is confusing!

If I go into the Callflow and edit the Voicemail through that, it brings me to the same page as PBX > Voicemail Boxes > edit.

*123 works completely fine (it shows up in the Obi as well). I have a custom recorded message using that. But *99 just. Won't. Work.

threehappypenguins

By the way, does anyone know how to get rid of that annoying, "Please record your message after the beep. When finished, press the # key," that is after my voicemail greeting when a person calls? I just want it to be my voicemail greeting, then the beep.

Shale

To check voicemail, if Anveo is default line, press *97#
If Anevo is not your default **2*97# (if Anvio is SP2)

For voicemail message change, if you use Flow Control, edit your active Flow Control, click on pencil icon of your Voicemail element, Edit Profile. See General tab, Voicemail Greeting and make your changes. Save.

threehappypenguins

Well that was ridiculous. I don't understand why Anveo would say to use *99!!!

I tried **3*97 (didn't need #) and it worked fine. So I changed Speed dial 7 to sp3(*97). I tried changing Code40 in the star codes to *99, Voice Mail, call($spd[7]), but I still got the reorder tone. So then I changed Code28 to *98, Voice Mail, call($spd[7]) and it worked fine.

Weird.

AlanB

*99 allows you to any voicemail account and requires a password. *97 doesn't require a password. For many business accounts I would think *99 is more appropriate. For us home users *97 is easier although less secure.

Shale

#5
Quote from: threehappypenguins on May 12, 2014, 08:19:52 AM
Well that was ridiculous. I don't understand why Anveo would say to use *99!!!
I vaguely remember, or imagined, that *99 is special for OBi in some way, and it does not actually get forwarded to Anveo. So if that is actually the case, other ATAs (Attached Telephone Adapters) could use *99. If this is the case, perhaps Anveo could add a note to the voicemail use description to that effect.

Edit: from the administration guide:
Quote*99, Disable Echo Canceller For One Call, set($Noec1,1)
-  Disable the Echo Canceller for one call on the current phone port

AlanB

I've been using *99 with  my Obi but recently switched to *97.

sailing

I don't think anyone answered the original question. *99 will give you a busy signal because the Obi digimap doesn't know what to do with it. I asked the same question awhile back and got the answer. See http://www.obitalk.com/forum/index.php?topic=7345.0

Shale

On Anveo I just tried entering *99 and got to voicemail asking for the access number. *97 does not ask for the password. So the *99 in the dial plan would mean you would not have to enter the # to avoid the long timeout.

I don't know why this works now, when I think it did not work when I tried it maybe a year ago. I had then switched to *97 instead because it worked. Additionally *97 is more convenient in that you don't need to add the access number.

Wonder how the *99 echo suppressor cancel thing works.

giqcass

I like to stick with the typical convention for voice mail that cell phones use.  Almost all cellphone use speed dial 1 or a long press on 1 to access voicemail.  As a result I just programed speed dial 1 on my Obi for voice mail.
spx(*97) or spx(*99)
Long live our new ObiLords!