December 18, 2018, 07:42:08 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Obi202 Incoming calls won't connect after update  (Read 19834 times)
JohnH
Newbie
*
Posts: 13


« on: March 18, 2015, 02:56:25 pm »

I'm using two Obi202 devices with Vestalink. I recently updated my firmware through the ObiTalk site to v3.0.1 (Build: 4581) and now I'm noticing that incoming calls won't go through about 90% of the time. The phone rings, I pick up and hear nothing -- the incoming caller gets disconnected. This is happening with both devices, so I know it's not a defective unit.

Any ideas? Thanks in advance for your help.

UPDATE: I was curious why some calls when through and not others. I discovered that calls picked up on 3 or more rings went through, but calls picked up on 2 or fewer rings did not. The mystery deepens.
« Last Edit: March 18, 2015, 03:07:42 pm by JohnH » Logged
SgtRWE
Newbie
*
Posts: 6


« Reply #1 on: March 25, 2015, 10:44:24 am »

I'm having the same problem with my obi202 and using google voice/chat

I have deleted and readded the GV account, but when I get an incoming call when I pickup it disconnects.  If the person calls me back, I can then pickup and it works.

Also the OBI always rings before my cellphone, if I wait till the cellphone starts ringing I can usually answer with the OBI then.

Are you behind a firewall ?   I am, but some calls still go through, calls to my phonepower account always go through.

This is very annoying,  any debug options I can turn on the figure this out ?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3659


« Reply #2 on: March 25, 2015, 10:59:54 am »

If you think this started after installing the new FW, you can downgrade to the previous level.
I think the previous build was 4477.
Click the following to download to your computer:
http://fw.obihai.com/OBi202-3-0-1-4477.fw

Then log directly into the OBi using the local interface.
Key the IP address of the OBi into a Web Browser.
Hit Enter
The UserID and default Password are both "admin".

Go to:
System Management -> Device Update
Under Firmware Update click Browse and find the file you just downloaded then click Update.
Logged
JohnH
Newbie
*
Posts: 13


« Reply #3 on: March 25, 2015, 12:49:51 pm »

Thanks azrobert! I was wondering how to access the older firmware. Since I've figured out a workaround (waiting for the third ring), I might wait until the next firmware update. I've read horror stories on here about people trying to downgrade their firmware.

SgtRWE, I'm pretty sure your problem originates with GV. A lot of people on here complain about similar issues with GV and I had the same experience back when I started with GV and Callcentric.
Logged
SgtRWE
Newbie
*
Posts: 6


« Reply #4 on: March 25, 2015, 10:22:52 pm »

I've had this problem before the latest update, and I don't think I installed the 4477 update at all.

Here is one thing I noticed by calling  from a different cell phone.

When I answer the phone, it goes  click and then I get a dial tone, the strange thing is the cell phone still stays connected until I hang up the phone, then the cellphone disconnects.

I really don't want to downgrade, Is there a debug option that would let us know the progress so I could compare when a connection goes through to when it doesn't ?

Originally this occured when GV was in SP1, then I got phonepower last year and had to make that sp1, so now GV is sp2 and it still happens.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5231



« Reply #5 on: March 26, 2015, 09:28:17 am »

So, what firmware version is the device running now?
Logged

--Steve

Google Voice Forum Product Expert

https://productforums.google.com/forum/#!forum/voice
SgtRWE
Newbie
*
Posts: 6


« Reply #6 on: March 26, 2015, 07:31:28 pm »

It's up to date  3-0-1-4581

Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5231



« Reply #7 on: March 26, 2015, 09:15:40 pm »

I have deleted and readded the GV account, but when I get an incoming call when I pickup it disconnects.  If the person calls me back, I can then pickup and it works.

Also the OBI always rings before my cellphone, if I wait till the cellphone starts ringing I can usually answer with the OBI then.

I re-read your posts, and I can't be sure, but this sounds like a problem unrelated to JohnH's issue.

I can't explain why the second call works, after the first call fails.  However, there are a couple of things we can test.

You mentioned that your OBi rings before the cell phone.  That's normal and expected behavior -- GV forwards inbound calls simultaneously to Chat/OBi and to any forwarding telephone numbers, but it can take a few seconds or more for the mobile phone network to find your cell phone on whatever cell site it can, and then initiate the radio connection.  If you're in a weak signal area, it could take longer.

There's also a (undocumented on the GV help pages) feature of GV that attempts to detect when a call is immediately answered by a machine, instead of a human.  In this scenario, GV will play a message that asks the machine or human that answers to press "1" to prove they're a human.  This is to limit problems caused by calls being forwarded into answering machines, or other unwanted conditions.  I'd expect that you would hear this message, but since you don't, this may be a red herring.  In general, I recommend not rushing to pick up the phone, but letting the OBi-attached phone ring twice before answering, if you run into this problem.

There is also a possibility that you have an old, abandoned forwarding number on your list of GV forwarding phone numbers, or hiding in your "Groups and Circles" section of GV Settings.  Review those pages:

https://www.google.com/voice#phones

https://www.google.com/voice#groups

and remove the check mark next to any numbers you no longer control, and then delete those numbers entirely off of your account.  Did you find one or more of these numbers, and if so, did removing it/them change the ring/answer behavior?

Next, remove the check mark next to any legitimate forwarding numbers (like your cell phone), and only leave the Chat destination check-marked.  Try some inbound calls from some other number, not from your forwarding phone(s).  What happens?

Logged

--Steve

Google Voice Forum Product Expert

https://productforums.google.com/forum/#!forum/voice
SgtRWE
Newbie
*
Posts: 6


« Reply #8 on: March 31, 2015, 07:33:08 am »

Sorry for the delay, work kept me busy. Also one thing I never mentioned is that when it does answer on that second ring, it will answer on the third and forth and so on. It's only after some period of time that I haven't figured out, that it goes back to the not answering behavior, so I have to wait a few hours between tests.

There were no old numbers.

My GV setup is to forward to all my phones which are

Google Chat (OBI SP2) (Phone Line 1)
My Cellphone
and Phonepower (OBI SP1) (Phone Line 2)

I unchecked both Cellphone and Powerphone on GV and was able to answer on the first ring.

I enabled them both and it did not answer.

I unchecked Phonepower by itself and I am able to answer on the first ring.

I unchecked Cellphone and checked Phonepower and it did not answer again.

So it seems to be the phonepower setup somehow.

I have phonepower because everyone thought we were losing Google Chat option, so I could get rid of it. I originally had Google chat  as OBI SP1, but phonepower would only register in SP1, hence Chat is SP2.

I know I had the problem when I only had Google chat as sp1, but I think it worked sometimes then.

Now that we know the cause is there anything we can do to figure out why ?

And thanks for the help.



Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5231



« Reply #9 on: March 31, 2015, 03:59:44 pm »

You shouldn't be forwarding Google Voice calls to two different service providers that ring on your OBi at the same time.  That's the problem.  Either have it ring Chat or Phonepower, but not both.
Logged

--Steve

Google Voice Forum Product Expert

https://productforums.google.com/forum/#!forum/voice
SgtRWE
Newbie
*
Posts: 6


« Reply #10 on: April 01, 2015, 08:25:02 am »

Hmmm, Is that a GV problem or an Obi problem.

I got phone power  because we thought GV was going away, then GV kept on working, but we never knew  if it would stop one day.

My phonepower plan only has so many minutes, so thats why I split them to two lines.

I would get free minutes on GV and if it ever stopped working, the phonepower would still ring.

Since we now have word that GV is still going to be supported, I can let the phonepower expire.

right now I have unchecked it on GV.

Really do appreciate the help in getting it fixed.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5231



« Reply #11 on: April 01, 2015, 01:48:54 pm »

As I said:  forward your inbound calls to one of the two destinations:  Google Chat, or Phonepower, but not both at the same time.
Logged

--Steve

Google Voice Forum Product Expert

https://productforums.google.com/forum/#!forum/voice
SgtRWE
Newbie
*
Posts: 6


« Reply #12 on: April 01, 2015, 04:58:43 pm »

I did, I unchecked phonepower.

But I was wondering why the problem occurs when you have both.

I'll let the phonepower subscription run out.

Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5231



« Reply #13 on: April 01, 2015, 06:20:37 pm »

Because you have two different inbound calls from the same caller hitting your OBi at the same time; one being forwarded to the OBi via Chat, and the other via your SIP provider, Phonepower.  There is no valid reason to do that.
Logged

--Steve

Google Voice Forum Product Expert

https://productforums.google.com/forum/#!forum/voice
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC