Phone Line Issue w/Obi 110

Started by DanielG, September 04, 2014, 11:45:56 AM

Previous topic - Next topic

DanielG

Our Scenario:

Our corporate office implemented a ShoreTel VoIP solution and we decided we wanted to try to roll that out to our remote locations (we have 40+ sites much smaller than our main office in the retail sector) but didn't want to purchase the expensive ShoreTel switches to do so.  We felt that there were a number of devices in the industry for far cheaper than a full ShoreGear50 costs and, if there was a minor VoIP call quality loss for the savings, it would be acceptable.  What we never expected to experience was POTS quality being affected, but we'll get to that in a minute.

To further explain, our goal was simply to allow our remote locations to utilize the VoIP capabilities of the corporate ShoreTel solution by having an employee pick up their standard AT&T Dect 6.0 phone, enter a 4-digit extension of someone on the ShoreTel system, and whatever option we installed at the store would route that across SIP to place the call.  From there, if the store needed to dial a local or long distance phone call they would press a special digit (# for the 110) and that would pass the call to the local POTS line at the store and the employee would dial a 7/10 digit number to get out successfully.  Seems simple enough...

We researched a number of options and decided to proceed with the Linksys SPA-3102 before experiencing all sorts of quality-related issues.  We finally settled on the Obi 110 due to great reviews and a positive demo at a single site and purchased enough to roll out to our remote sites.  After a couple of days we started having issues at the sites we ended up rolling out to though (we stopped the rollout after about 6 locations due to them all having this issue) and that issue was that frequently (not every time), when a call came in on the local POTS line or when the remote location called out over the local POTS line the quality was terrible.  We're talking echo, hearing roughly 8 of every 10 words, dropped calls, not being able to dial out (pressing #, hearing the dial tone change, starting to dial numbers but the dial tone never changing and, upon 7/10 numbers being dialed, still hearing that same dial tone - hanging up and retrying the call would often fix this issue).

We couldn't understand how a device that was supposed to simply extend the voice capabilities at the store could get completely in the way of the one service that already worked fine.  Please note that if we remove the Obi from being in the loop, the POTS line works 100% of the time with absolutely zero issues.  We even ran new copper from the Dmarc to the office area and that didn't help a bit.  My team and I are all composed of engineers with ample Cat3/Cat5/networking experience so we've already tried a number of changes we think could play a role (changing from DHCP to a static IP, ensuring there are no router conflicts, ensuring there are no DSL filter issues where DSL is the ISP at a site, etc) and we've not been able to isolate the issue.  Just to throw this out there before it's suggested, we're not interested in Google Talk or anything else that will bypass the POTS line because we use it today for other purposes (Fax, ordering terminal, etc) so we'll need it anyway and, on top of that, we have this line listed in numerous directories as this site's main number and don't want to have to change that all.

To further explain, the technology schematic is simply our core Internet modem at the remote locations (could be AT&T Uverse, Verizon DSL, Time Warner Cable, etc - all public providers with anywhere from 3M/768k to 50M/10M circuits) plugging into our core router from our managed WAN provider.  From there the Obi 110 is plugging into one of the core router's LAN ports and receiving an IP address via DHCP (again, we've tried static IPs - doesn't change the outcome).  Finally, the local AT&T Dect 6.0 base phone is plugging into the Phone port and the local POTS line is plugging into the Line port.  Again, seems simple enough...

That said, no matter what we've tried (we've had a case open with Obi and have been working with Samuel and other techs to try AC Impedance settings, various line modifications, etc), we've been unsuccessful in having the quality of an incoming POTS call or the quality of an outgoing POTS call work anywhere near as well as it does when the Obi is out of the loop.  I'm hoping that a number of you have experienced similar issues and have figured out a work around of some sort.  If not, we're likely going to have to punt on this project, return 40+ devices to Obi and do without the ability to tie into our ShoreTel corporate solution from remote locations and just dial the local POTS line of the remote site anytime we need to reach them from the office.

Any help would be greatly appreciated and if you need additional information please just request the data you need and I'll reply back ASAP.  Thank you very much in advance!

-Daniel

azrobert

I disconnected my OBi110 from the router and I can still access my POTS line, so I think you can stop looking at any network settings or conflicts. I don't think it matters, but my OBi110 is configured with a static IP address.

If you get this problem resolved, you don't need to dial # to access the POTS line. Set the Phone Port Primary Line to PSTN Line. Now any number dialed will be routed to the POTS line. It would take a few simple config changes to route 4 digit numbers to the trunk connected to the corporate office.

DanielG

Quote from: azrobert on September 04, 2014, 12:39:59 PM
I disconnected my OBi110 from the router and I can still access my POTS line, so I think you can stop looking at any network settings or conflicts. I don't think it matters, but my OBi110 is configured with a static IP address.

If you get this problem resolved, you don't need to dial # to access the POTS line. Set the Phone Port Primary Line to PSTN Line. Now any number dialed will be routed to the POTS line. It would take a few simple config changes to route 4 digit numbers to the trunk connected to the corporate office.


I agree, that's how it SHOULD work regarding the Network not participating at all.  The OBI should get completely out of the way on POTS calls and treat it like a closed/open door and, upon pressing #, the call is routed to the POTS line and no interaction is done at all.  Unfortunately, the OBI tries instead to change the POTS line with settings and configuration modifications that break the technology completely.

As for swapping the setup of the OBI, do you know whether that actually helps or not?  Out of the box it definitely doesn't work that way and instead what you get is the box expecting you to enter a SIP string for extension dialing.  Only if you press # do you get the other dial tone for POTS.  If you're suggesting changing it around by affecting the dial string in the advanced settings of the unit so it defaults to POTS when you first pick up the phone and you press # to get VoIP extension capabilities, that's fine but I thought I would check if you've had success with that method in the past before going to such trouble figuring out that string.

Let me know please.

-Daniel

azrobert

The factory default for the OBi110 is to route calls out the line port to your POTS. When you take the phone off hook with the default settings you will hear dial tone from the OBi110. The only way to hear dial tone from the POTS is to dial "#".  However, when you dial a number it will be routed to POTS. If you want to route the call out SP1 to corporate you must dial a prefix "**1" followed by the 4 digit extension. Like I said in my previous post, it would be easy to eliminate the prefix and just dial the 4 digit extension.

Go to Physical Interfaces -> Phone Port
This is where the Primary Line is defined.

Now look at the OutboundCallRoute.
The last rule is {(Mpli):pli}
Mpli points to the primary line DigitMap (default Line Port)
pli point to the primary line (line port again)

If the dialed number matches a rule in the Line Port DigitMap it will be routed out the Line port.


DanielG

#4
Quote from: azrobert on September 04, 2014, 02:04:06 PM
The factory default for the OBi110 is to route calls out the line port to your POTS. When you take the phone off hook with the default settings you will hear dial tone from the OBi110. The only way to hear dial tone from the POTS is to dial "#".  However, when you dial a number it will be routed to POTS. If you want to route the call out SP1 to corporate you must dial a prefix "**1" followed by the 4 digit extension. Like I said in my previous post, it would be easy to eliminate the prefix and just dial the 4 digit extension.

Go to Physical Interfaces -> Phone Port
This is where the Primary Line is defined.

Now look at the OutboundCallRoute.
The last rule is {(Mpli):pli}
Mpli points to the primary line DigitMap (default Line Port)
pli point to the primary line (line port again)

If the dialed number matches a rule in the Line Port DigitMap it will be routed out the Line port.



I by no means intend to be argumentative here, and it's possible there's a process I'm completing in the early stages that transitions the 110 out of the default mode.  That said, once I follow the steps Obi gave me to follow (I actually put together a guide that I've attached to this ticket - I've just removed our custom information), the box right after doing that absolutely does not dial POTS immediately after picking up the phone and dialing a number and instead dials VoIP to the ShoreTel solution if you pick up and enter a 4-digit extension (you get an error if you try to dial a local/LD number because it's not found on the ShoreTel system).  Once the attached steps are followed, the box absolutely requires pressing # to then get the local POTS line and there's no other way around that short of dialing 911 (pressing 911 allows the system to get the local POTS and dial 911 - no need to dial #911).

EDIT - Not sure if there's a special way to attach the file or not, but it shows attached but won't let me open it.  Hopefully you have better luck.  Assuming not, below is what is in the attachment:

OBIHAI 110 SETUP INSTRUCTIONS

•   Power up phone/ObiHai 110 and hook 110 to Ethernet/phone
•   Browse to ObiTalk.com and create a new account for the store in question and click continue
          Enter site's E-Mail address and ####### as the password
          Set the display name to be #######
          Enter CAPTCHA, check the box and click REGISTER
•   Login to the site's E-Mail using Exchange OWA site to verify the account (click the link)
          Delete their ObiTalk E-Mail when done so they're not confused
•   Login to ObiTalk using the user/password above
•   Once you login, you are prompted to setup a device – click YES
•   Follow on-screen steps and click next (should've been done in first step)
•   Follow on-screen steps again and dial number to register device
•   A confirmation screen will appear saying connected, click confirm
•   Click NEXT in the bottom right-hand corner under OBITALK COMPATIBLE SERVICE PROVIDERS
          Click ACCEPT on 911 screen that appears
•   Choose GENERIC SERVICE PROVIDER at the bottom
•   Fill out the Service Provider Proxy Server and Outbound Proxy Server with #######
•   Enter the User Name and URI as #######
•   Enter the Service Provider Proxy Server Port and Outbound Proxy Server Port as 5060
•   Uncheck the Voicemail Notification Box
•   Clear what's in Configuration Name and enter ShoreTel
•   Once done entering these settings, click SUBMIT (top of page should show config successfully updated)
•   Click OBI DASHBOARD in the top-left menu
•   The newly added device for this respective store should now show REGISTERED with a GREEN status
          If it doesn't, something went wrong – check settings and review instructions
•   At this point the device is fully online and configured, but a change to the dialing plan is necessary
•   Click the purple gear to the far right of the Obi110 that now shows registered
•   Click OBI EXPERT CONFIGURATION at the very bottom of the screen
          Click OK to the box that pops up
•   Click ENTER OBI EXPERT at the top of the screen
•   Click the PLUS next to SERVICE PROVIDERS and select ITSP PROFILE A GENERAL
•   Uncheck the OBITALK SETTINGS and DEVICE DEFAULT checkboxes next to DIGITMAP
•   Place your curser JUST AFTER the opening parenthesis and add xxxx| between the parenthesis and 1
          Full map should then read (xxxx|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)
•   Click SUBMIT at the bottom of the page and that will update the equipment and reboot the device
•   You are completely finished at that point if, during testing, you can call a 4-digit extension with less than 5 seconds of wait between pressing the last number and the call ringing
          If issues getting that, check the digit map for errors
•   Label the box appropriately and deliver to the site with new AT&T DECT Phone
•   Plug primary POTS line into the OBIHAI 110, the phone into the 110 and Ethernet into the 110 and test again

azrobert

I configure my OBi110 directly using the Web interface. There is nothing wrong with using OBiTalk to configure your devices. I just prefer not to be tied to another service. Since I don't use OBiTalk I don't know what the wizards change. It looks like the Phone Port Primary Line was changed to SP1 Service because they are suggesting you change ITSP A DigitMap.

IMHO this is how your OBi110 should be configured.

Enter OBi Expert.
Click Service Providers, Click ITSP Profile A General
Change DigitMap to: (xxxx)

Click Physical Interfaces, Click Phone
I'm guessing the Primary line was changed to SP1
If it's not PSTN LINE, just check the box under OBiTalk Settings.
This will set Primary Line to the default of PSTN Line.

This is the default Phone DigitMap:
([1-9]x?*(Mpli)|[1-9]S9|[1-9][0-9]S9|911|**0|***|#|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp)|(Mpli))
Change it to:
((Msp1)|[1-9]x?*(Mpli)|[1-9]S9|[1-9][0-9]S9|911|**0|***|#|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp)|(Mpli))

This is the default Phone OutboundCallRoute:
{([1-9]x?*(Mpli)):pp},{(<#:>|911):li},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}
Change it to:
{(Msp1):sp1},{([1-9]x?*(Mpli)):pp},{(<#:>|911):li},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}

I added 1 rule to the beginning of the DigitMap and OutboundCallRoute

Under Physical Interfaces click LINE

Change the DigitMap to:
(xxxxxxxS4|[2-9]xxxxxxxxx|1xxxxxxxxxx)

That's it.

Now you can dial 4, 7, 10 or 11 digits.
4 digit numbers will be routed out SP1.
7, 10 or 11 digit numbers will be routed out the Line Port.
You can dial # to get the POTS dial tone.

You will get an error with any other number.

If you have additional requirements, list then and I will modify the above example.

DanielG

A few things.  When you say you can just dial a 7, 10 or 11 digit number and it goes out the line port but then say you can press # to get local POTS dial tone, what is the difference there?  I mean, the line port IS the local POTS dial tone and the only variation of dialing numbers is 7/10/11.

Also, what about a 3 digit number (911) in your scenario?  Is that going out the line port (local POTS dial tone) as well?

Finally, does this actually address my issue by doing this swap (echo, dropped words on a call, etc) or is it all just to make the call path easier and swap what the default methods are?  If the latter, that's really not my issue as the reason I posted was to get improved quality on POTS calls.

-Daniel

azrobert

Quote from: azrobert on September 04, 2014, 12:39:59 PM
If you get this problem resolved, you don't need to dial # to access the POTS line. Set the Phone Port Primary Line to PSTN Line. Now any number dialed will be routed to the POTS line. It would take a few simple config changes to route 4 digit numbers to the trunk connected to the corporate office.

The above is what I said in my first post. We then got off the purpose of this topic. The answer to your question is no. This will not resolve your problem.

I list # to show you can still use your current method to call out the POTS line.

sailing

This may  be a dumb question but, are you sure there isn't some connection between the incoming POTS line and the line out to the phones when using the Obi110?

I had a situation once with another ATA. The ATA had intermittent issues when connected through the phone lines in my house but no issues when just one phone was plugged directly into the ATA. There is a lot of phone wiring in my house that was all connected even though many of those runs do not terminate to anything. By disconnecting all unterminated runs (those that did not go to a phone jack), the problem was solved. My assumption was that the was added capacitance created a problem for the ATA.

I would expect calls over POTS not to have a problem with the Obi which is why I'm throwing out other ideas.

DanielG

No it's not an issue with the POTS line at all.  This happens at multiple locations and at the location that has the most issues we even ran new copper from the DMarc to the Obi 110.  It's not related to the line at all (again, if we bypass the Obi and plug the AT&T Dect 6.0 phone directly to the POTS line we don't experience any of these issues.

Daniel

azrobert

Do you use the same model phone at all the locations having the problem?

Nobody is providing any help, so a wild guess would be to try a different model phone.

DanielG

We considered this as well, tried different phones and even went so far as to use one of our tech's butt sets.  Didn't matter one bit.  The issue (from our perspective) is clearly in the Obi 110.  I mean, if the POTS line is brand new copper ran from the DMarc, you try multiple phones behind the Obi and, once the Obi is removed, the issues are 100% gone, what else can it be?

Daniel

Boykin

Have you tried doing a factory reset on one of your OBi's and setting it back up to see if that will fix the problem? 

I set up a 202 Tuesday and when I got finished the attached phone would not ring when I called it.  It would make outgoing calls fine.  I could not get it to ring no matter what I did.  I factory reset it and set it back up and now it works fine. 

I don't know that this will help your problem, but you might want to try it with one OBi.

DanielG

Yes, not only have we tried to do factory defaults, but because we purchased so many at once, we've tried 4 different devices in one particular site and they all have the same issues.

Daniel

sailing

Another idea. Measure the off hook voltage and current. Off hook voltage should  be 5-15Vdc and the current 23-35mA. If you are outside the range, the Obi may have a problem responding. Phones tend to work no matter how out of spec the POTS line is.

I know you said this is happening at multiple locations so the probability of this happening at all locations is small but no on has figured this out yet so its worth checking.

DanielG

We measured the settings you asked about and the off-hook voltage was 51Vdc and the current was 70mA.  Is it your opinion that this is the reason the Obi 110 is having issues with POTS-related phone calls despite the fact that a standard phone is having no issues working with those same numbers?

We've had a POTS tech onsite before and they said everything was perfectly fine (even led to a NTF charge we had to pay).  Is it possible that in Texas these figures are acceptable vs. your area or would you believe this to be problematic anywhere such that we need to have a tech dispatched again?

I know we're all grasping for straws but we've ruled out so much already prior to me ever submitting this thread but if these figures are absolutely unacceptable from the 110'S perspective and that device will simply never work like that, we'll need to address it either way (even if it turns out not to be the actual issue).

Thoughts?

-Daniel

DanielG

I found this link by the way, and the figures we have at this one store in particular are still out of the range shown as typical, but they don't quite match with the figures you listed:

http://www.rane.com/note150.html

Thoughts?

-Daniel

Shale

#17
Do I understand you to say that with the OBi110 plugged into the POTS line, the audio on a separate phone plugged into that POTS line degrades?

If not, what is your most basic symptom at the simplest level?

When you said "We measured the settings you asked about and the off-hook voltage was 51Vdc" did you mean on-hook for the voltage?

DanielG

Sorry for not being clear, it's on hook 51Vdc and off hook current 70ma.  As for the issue overview you requested, here it is:

When the standard phone is plugged into the POTS line directly it works 100% of the time with absolutely ZERO issues.  When the OBI is between the Phone and the POTS line there are all sorts of intermittent issues (echo, dropped words on the call, etc).  We've tried many, many things (had the TELCO onsite, ran new copper from the DMarc, replaced the DSL filter on the line, replaced the OBI with multiple devices, tried different phones, tried a different Cat3 patch cable running from the POTS line to the Obi, Factory defaulted multiple 110s, tried multiple settings provided straight from Obi regarding ACimpedance/TXGain/RXGain, etc) and we're still in the same exact place.  We have a phone that doesn't work when placing calls on the POTS line through the 110 and a phone that places calls perfectly fine if we remove the 110.

Ostracus

Interesting problem. Doesn't the Obi110 run the Phone port/Line port through an A/D and D/A conversion even for POTS calls only? Remember no relay. Also the whole Ethernet half/full duplex-speed setting has been addresses?