Send incoming calls straight to a busy signal? Disable voicemail on 110

Started by Donnyten, September 16, 2014, 08:11:10 PM

Previous topic - Next topic

Donnyten

Here is the deal. I plan on ditching my landline phone for use with work. I work from home doing technical support and I would like to be able to use my Google voice number as my primary landline. One of the requirements at my job is that there is no voicemail and call waiting on the line. Example, I am on a call and someone calls. They immediately get a busy signal. Is there anyway to set that up? Also I understand that there's no google voice setting to disable voicemail but is there a way to do it through the actual obihai interface?


azrobert

You can disable Call Waiting on your OBi.
Physical Interfaces -> Phone Port -> CallWaitingEnable: Unchecked

You can't disable GV voicemail, so the call will immediately go to VM.

You can make a custom greeting for GV VM like "The person you are trying to reach is unavailable, please call back later".
The greeting would have to be long enough, so the caller won't hear the beep at the end of the message. I think you can have silence at the end.

Or

You can get a free account at Tropo: https://www.tropo.com/

Write an App that plays a busy signal.
Forward the call to your App after 4 rings or when busy.

See: http://www.obitalk.com/forum/index.php?topic=8381.msg55956#msg55956

Here is a busy signal recording:
http://www.soundjay.com/phone-sounds-2.html
Busy is near the bottom of the page.

Donnyten

Thanks for the reply.

how exactly do I set it up to work with the obihai interface? I understand that I get a link when done.

Thank You.. I edited the script from the link you provided. Please let me know if this is the only script that is required.

<?php
say("http://www.soundjay.com/phone/phone-busy-1.mp3");
say("http://www.soundjay.com/phone/phone-busy-1.mp3");
rejected();
?>

I can't seem to finish the script, it says " please add extension".. I am adding  .PHP to the end and it is not accepting it

azrobert

I had trouble using Internet Explorer on Windows 7 with Tropo. The scripts weren't getting updated. I used Chrome.

When you create an App in Tropo they will give you a SIP URI that points to the App. It will look like:
9991234567@sip.tropo.com
You can test the App by defining a speed dial like:
sp2(9991234567@sip.tropo.com)

For production:
Voice Services -> SP1 Service

CallForwardOnBusyEnable: Checked
CallForwardOnBusyNumber: sp2(9991234567@sip.tropo.com)
CallForwardOnNoAnswerEnable: Checked
CallForwardOnNoAnswerNumber: sp2(9991234567@sip.tropo.com)
CallForwardOnNoAnswerRingCount: 4

SP2 must be defined as a SIP trunk.
If SP2 is not defined setup a dummy trunk like:
Service Providers -> ITSP Profile B -> SIP -> ProxyServer: 127.0.0.1
Voice Services -> SP2 Service -> AuthUserName: (any userid)
Voice Services -> SP2 Service -> X_RegisterEnable: (unchecked)
Voice Services -> SP2 Service -> X_ServProvProfile: B

I think you can use one Say command like this:
say("http://tindeck.com/download/dea586d67535ca6c90972f4679ccb99b/zgap/[tindeck.com]%20-%20phone-busy-1.mp3
"http://tindeck.com/download/dea586d67535ca6c90972f4679ccb99b/zgap/[tindeck.com]%20-%20phone-busy-1.mp3
");

It MIGHT have less delay between each file.

You can also upload the mp3 file to your Tropo account.
Download file to your computer
Sign in
Click My Files
Click www
Click Audio
Click Upload

Then reference it like:
http://hosting.tropo.com/12345/www/audio/filename.mp3

12345 is your account number which is displayed on top of the page to the left of LOGOUT.
It doesn't display when using IE.






Donnyten

Alright. I completed those steps.  for sp2 it still says " service not configured"   is this normal?

I just tried to call my number while already on a call from my girlfriends phone and it ring when it should have gotten a busy signal

azrobert

That doesn't seem right.
Do you update your OBi via OBiTalk or the Local/Web interface?

Donnyten

Yes I did.. Is there anyway you could perhaps take a look at my settings through teamviewer?

sorry, also i used the web interface

azrobert

I modified one of my apps with the code in my last post and there was a syntax error. I had an extra quote between the 2 files. In the Tropo editor a red X on the left indicates an error.

After fixing the error Tropo didn't like your files and I got static.

I tried this:
<?php
say("http://www.soundjay.com/phone/phone-busy-1.mp3");
say("http://www.soundjay.com/phone/phone-busy-1.mp3");
hangup();
?>

It worked, but there was a pause between files. I got the same pause with a single Say command. I tested it with a speed dial.

When you configure the OBi with the Web interface you must turn off OBiTalk Provisioning, otherwise OBiTalk will override your changes with the defaults.

System Management => Auto Provisioning

Under OBiTalk Provisioning
Method: Disabled.

There is another way to do this in Tropo. When you transfer a call in a Tropo App you can loop an audio file. It's normally used for a RingBack tone, but you can play any audio file. I think you can make a dummy call any play the Busy. I will have to play with it and see if I can get it to work. I don't have time now.

Donnyten

I do not see " Obitalk provisioning" within auto provisioning. Any ideas?

azrobert

I think you are using OBiTalk to configure your OBi, so you don't have to change provisioning.
In OBiTalk you don't see OBiTalk Provisioning.
Signing in using the Local/Web interface you key the IP address of the OBi into a Web Browser.

I don't think the "Not Configured" is correct. I don't configure my OBi with OBiTalk, so I can't help you.

I tried the looping of the audio file and it also has a pause.

I then uploaded the audio file to Tropo and the pause was about half as the other methods.


Donnyten

Alright. i will log in the other way

Donnyten

I'm not sure what i'm doing wrong. I logged into the obihai device without using obitalk, checked all of those settings and I still get beeps when I am on the phone with someone. My job uses avaya IP software to route calls to my landline and While I am helping a customer there can not be any call waiting or voicemail whatsoever active on my line. I go in tomorrow at 2:30 PM EST so hopefully I can get this sorted out by then. I just wish Google simply implemented a disable call waiting/ voice mail feature. Would make my life a bunch easier right now.

If you can help, I have teamviewer.

azrobert

From reply#2 above
QuoteYou can disable Call Waiting on your OBi.
Physical Interfaces -> Phone Port -> CallWaitingEnable: Unchecked

With above setting you should not get the Call Waiting Tone.

I'm not familiar with Teamviewer. Plus I don't want to install any software on my computer

Donnyten

teamviewer lets another remote access their computer. being you dont want to install anything this is the best I can do. I have attached images of my settings.

azrobert

You have CallForwardUnconditionalEnable checked and no forwarding number.
It probably isn't doing anything because your phone is still ringing.
It should be unchecked.

If you are still getting Call Waiting tone remove all the forwarding settings and just have the following:

Physical Interfaces -> Phone Port -> CallWaitingEnable: Unchecked

If you still get the Call Waiting tone I have no idea what to do.

Donnyten

I'm losing my mind.

I uncheck callwaitingenable, and the system management provisioning setting that I set to disable somehow sets itself back to " periodically". If i do it in reverse order the same thing Happens.I have no idea whats going on

azrobert

Are you sure you're changing OBiTalk Provisioning to Disabled and not ITSP Provisioning?

Donnyten

Yes.

I've the call waiting disabled but the problem is it still goes to my voicemail after 26 seconds.

azrobert

Call forward on busy doesn't work for GoogleVoice.
See: http://www.obitalk.com/forum/index.php?topic=5262.msg34181#msg34181

That was almost 2 years ago. A lot of my brain cells have died since then and I forgot about this. Sorry!

I think if you get a 2nd DID and define it on your OBi. Then have GV route calls to both DIDs. Call forward on busy should work on the 2nd DID. I think IPComms still has free DIDs.

I will setup this config on my OBi/GV and report back later.