Send incoming calls straight to a busy signal? Disable voicemail on 110

Started by Donnyten, September 16, 2014, 08:11:10 PM

Previous topic - Next topic

Donnyten

Hey, thanks for your help.

Please report back what you find.

Thanks

azrobert

I thought it might work with a non Google Chat DID, but it doesn't.
Call forward on busy doesn't work for GoogleVoice on any DID.
I apologize for wasting your time.
The only thing that will work is adding a custom greeting of a busy signal to your GV voicemail.

Donnyten

Ok. is it possible to change the number of rings at least to 0 on all incoming calls while on the phone?



azrobert

I went for a run and it cleared my mind and I thought of a way to do this, but I can't get it to work. In an inbound route you can fork the call to 2 destinations (phone port and Tropo). You can put a delay on the leg to Tropo, but when I try it ignores the delay.

Voice Services -> SP2 Service -> X_InboundCallRoute:
{ph,sp2(9990012345@sip.tropo.com;d=5)}

I changed the proxy server to: sip.tropo.com and tried this format:
{ph,sp2(9990012345;d=5)}

Both ignored the delay.

I have to go somewhere with the wife, so I can't play with it now.

From OBihai:

- All InboundCallRoute and OutboundCallRoute syntax will take a ";d=[delay-in-seconds]" parameter after the number to call from the specified trunk, and to insert a delay before the trunk makes the call. For example, SP1(18002211212;d=3) tells the OBi to call the number from SP1 after a 3-second delay.


azrobert

The wife is taking her time.

Got it to work on my OBi110 with this format:
Voice Services -> SP2 Service -> X_InboundCallRoute:
{ph,sp2(9990012345@sip.tropo.com;d=10)}

There was a 10 second delay before the call was forwarded to Tropo.

But now I'm not getting any audio.
I recently made a bunch of changes to my network and probably screwed up something.

Donnyten

No audio?  You mean you hear nothing when you pick up the phone/ speak with someone? or no audio in reference to busy signal?

If you got it to work could you please post updated settings?  thanks

azrobert

When using a delay routing the call to Tropo, I don't hear the busy.
This has to be a bug in the OBi.
I circumvented the problem by delaying answering the call in the Tropo script.
With the phone on-hook or off-hook  and a 10 second delay the caller hears 2 rings, a pause then busy.

Voice Services -> SP1 Service -> X_InboundCallRoute:
{ph,sp2(9990012345@sip.tropo.com)}

Tropo Script:
<?php
wait(10000);
answer();
say("http://hosting.tropo.com/12345/www/audio/phone-busy-1.mp3
http://hosting.tropo.com/12345/www/audio/phone-busy-1.mp3");
hangup();
?>

Edit:
All the call forwarding parms were removed.

Donnyten

Physical Interfaces -> Phone Port -> CallWaitingEnable: Unchecked
-------------------------------------------------------------
Voice Services -> SP1 Service

CallForwardOnBusyEnable: Checked
CallForwardOnBusyNumber: sp2(9991234567@sip.tropo.com)
CallForwardOnNoAnswerEnable: Checked
CallForwardOnNoAnswerNumber: sp2(9991234567@sip.tropo.com)
CallForwardOnNoAnswerRingCount: 4

SP2 must be defined as a SIP trunk.
If SP2 is not defined setup a dummy trunk like:
Service Providers -> ITSP Profile B -> SIP -> ProxyServer: 127.0.0.1
Voice Services -> SP2 Service -> AuthUserName: (any userid)
Voice Services -> SP2 Service -> X_RegisterEnable: (unchecked)
Voice Services -> SP2 Service -> X_ServProvProfile: B
------------------------------------------------

System Management => Auto Provisioning

Under OBiTalk Provisioning
Method: Disabled.

----------------------------------------------------

Voice Services -> SP1 Service -> X_InboundCallRoute:
{ph,sp2(9990012345@sip.tropo.com)}

Tropo Script:
<?php
wait(10000);
answer();
say("http://hosting.tropo.com/12345/www/audio/phone-busy-1.mp3
http://hosting.tropo.com/12345/www/audio/phone-busy-1.mp3");
hangup();
?>

------------------

What I have highlighted in bold, do I still need to make sure those settings are as you typed them? or do they no longer apply?

azrobert

They are needed to route the call to Tropo via SP2.

Just remove all the call forwarding settings.

Donnyten

Ok, so all the call forward settings for SP1 right?

Also i've noticed that for settings, there's also a check box under default, if I uncheck that, the check moves all the way to the left inside another check box.  as long as there's a check in any of the boxes in a given field, does that mean its enabled?

azrobert

Are you using OBiTalk to config your OBi?
I thought we disabled OBiTalk provisioning.

It doesn't matter which method you use, but you can only use one.

Maybe you should use OBitalk because the new firmware requires it to change GV settings.

Donnyten

Well I was just speaking in general.  I noticed there are two check boxes for most fields, unchecking the setting for 'default' shifts the check over to the far left...   was just wondering.  but i'll report back in a few hrs as to whether or not that scheme works for me

SteveInWA

Wow, this is two pages of trying to use a hammer to drive in a screw.  You might eventually succeed, but all parties involved will be sore at the end.

Let me suggest an alternative.  Don't use Google Voice at all for your work solution.

I think the original discussion went off the rails because it didn't address your actual job requirement.

As I understand it, you have one of those work-at-home jobs, wherein you are required to get a conventional inbound telephone line, with no call forwarding or voicemail or three-way calling at all.  The employing company then forwards inbound calls to your personal phone number, one at a time, and you do your thing with that customer, until you are done. On your company's side, they use ACD (automated call distribution) software to manage your call queue for you.  When your phone is no longer busy, it sends you your next chunk of work (your next caller).

Right?

If so, do this:  get a free New York inbound phone number (DID) from Callcentric.  Do not set up any calling features at all on that number.  It's just going to be a plain phone number that rings your OBi-attached phone.  When nobody answers, it keeps ringing, and when it's busy, it generates the correct busy signal.  Your company's ACD needs a carrier-supplied busy signal; fake, recorded hocus-pocus won't work, because your work's switch knows that your carrier answered the call.  They need to get the busy signal instead of an answered call, not something that sounds like a busy signal.

Factory reset your OBi box to remove that spaghetti-pile of settings you may have added.  Use the OBiTALK portal to delete and then re-add your OBi device.  Then, use the portal page's bottom-most link to configure service with other providers, and then select Callcentric.  Give the portal your Callcentric free DID account number (the  CC 1777nnnnnnn account number, NOT the DID telephone number) and the SIP password you set up on the CC web site. Call the CC telephone number from some other phone number, to test that it rings or goes busy as I descibed. Once you get it working, give the CC DID telephone number (the New York number, not the 1777 number) to your employer.  That's it.

Optionally:

IF you would also like to use Google Voice, you can configure one of your OBi's other service provider slots with GV, using the portal.  Just do NOT use that number for work calls.

azrobert

Quote from: SteveInWA on September 18, 2014, 07:55:14 PM
remove that spaghetti-pile of settings you may have added.

I disagree with your characterization of what I did. I must admit it took me 2 1/2 approaches to get this to work, but the final solution is 1 line of code in the OBi and a 4 line Tropo script. There is an additional 4 changes in the OBi to setup a dummy trunk only needed because the OP doesn't have a SIP trunk defined.

This is what you call "spaghetti-pile of settings":
Voice Services -> SP1 Service -> X_InboundCallRoute:
{ph,sp2(9990012345@sip.tropo.com)}

This solution worked for me. The true test is if the OP can get it to work.

Donnyten

I thank the both of you for the help I have received so far.

I tried the call centric method and I'm able to call myself, but when I tried to call that same line from another phone all the phone does is ring. Can I set it up so that incoming calls go straight to a busy signal?

I've lost about 4 hours of sleep trying to get a dang busy signal to the point when I now have a headache and have to go back to work in an hour or two

SteveInWA

Hi Donny:

I sent you a private message with the additional setting you probably need to change on the Callcentric portal page to send calls to the busy signal, and some related information.  It's been so long since I set up a clean/new CC DID, that I can't recall all their default settings.

Donnyten

Thanks for the correspondence.

It works now, the issue was that google doesnt support " early media" which would explain why I always heard rangs when I dialed the CC number. But i tried again with another it it works without a problem. :-)

Thanks so much guys :)

SteveInWA

Quote from: Donnyten on September 19, 2014, 05:27:51 PM
Thanks for the correspondence.

It works now, the issue was that google doesnt support " early media" which would explain why I always heard rangs when I dialed the CC number. But i tried again with another it it works without a problem. :-)

Thanks so much guys :)

Yay!  Glad you got it to work.  Enjoy the cost savings.