December 15, 2017, 01:39:48 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: "Cascading" Outbound Calls between two local OBis.  (Read 15720 times)
CLTGreg
Full Member
***
Posts: 109


« on: September 22, 2014, 02:10:11 pm »

This might be a voice gateway issue but I'm lost on the nuances and this is a bit different since both OBis are on the same subnet.

I have a new 200 thanks to the Newegg deal (boy that thing is smaller than the 202!) and a 202. My goal is to pick Line 1 on the 202 and have it go out an SP on the 200.

The reason for this is I want to use Obi Anveo line for incoming CNAME and possibly higher fidelity but use Google Voice for outbound calls because I don't like to be metered even though I never use my full bucket of outbound minutes.

The issue is having two SPs ring on the 202 for the same incoming call. Things can get squirly. Sometimes the caller ID shows one, sometimes the other and sometimes I pick up and I'm not connected. I wish I could turn off ringing altogether for an SP to address it that way.

So what I'm thinking is move the GV to the 200 and leave the Anveo on the 202 but have outbound calls for one line go out the 200 SP for GV.

Doable?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3203


« Reply #1 on: September 22, 2014, 05:50:57 pm »

Yes it can be done, but I think an easier way is to prevent GV from ringing the Phone port.

Change the X_InboundCallRoute  from ph to {}
Logged
CLTGreg
Full Member
***
Posts: 109


« Reply #2 on: September 22, 2014, 09:17:35 pm »

Thanks. There's a lot of moving parts with a lot of strange things but I think you've put me on the right track.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #3 on: September 22, 2014, 10:35:23 pm »

The typical usage scenario of people who want to route inbound calls through a SIP ITSP is this (it only requires one OBi box):
  • Using the OBiTALK web portal, not the local web page interface, configure Google Voice on SP1 and make it your default SP for outbound calling.
  • Configure your SIP ITSP (e.g. Anveo or Callcentric or voip.ms) on SP2, and don't enable it to be the default outbound SP.  Do enable it to be the default handler for 911 service.
  • Log into your Google Voice account and go to the Phones tab of Settings:  https://www.google.com/voice#phones
  • Add and verify your SIP DID number, and put a check mark in the box to the left of it to receive forwarded calls.
  • Remove the check mark next to Google Chat, so it won't receive forwarded calls.  It will still work for outbound calls.
  • That's it.

There is no need for changing the inbound call route parameter.
Logged

CLTGreg
Full Member
***
Posts: 109


« Reply #4 on: September 23, 2014, 09:32:53 pm »

Thanks Steve. That is what I had done but I was getting strange results. I think it was due to a bad call flow in Anveo and not the GV setup. I did get a 30 minute disconnect on an incoming forwarded GV call through Anveo. Again, lots of moving parts.

I'll revert back to your method but file the other as a valuable how-to.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3203


« Reply #5 on: September 23, 2014, 10:02:38 pm »

Maybe I didn't understand your requirements. I thought you wanted the same GV account on the OBi202 and OBi200. If you remove the check next to Google Chat both boxes will not receive inbound calls from GV. If you change the inbound route on the OBi202 then the OBi200 will still receive inbound calls.
« Last Edit: September 23, 2014, 10:33:38 pm by azrobert » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #6 on: September 23, 2014, 11:22:22 pm »

Greg, that makes sense; other users have run into conflicts with certain Anveo call flows causing GV problems.

Azrobert:  you can have multiple OBi 20x series boxes connect to the same GV account; it's the 1xx series that can't do that.
Logged

azrobert
Hero Member & Beta Tester
*****
Posts: 3203


« Reply #7 on: September 24, 2014, 08:17:25 am »

Azrobert:  you can have multiple OBi 20x series boxes connect to the same GV account; it's the 1xx series that can't do that.

Steve,

You don't get my point.

If the OP has the same GV defined on both boxes, both will ring. This is causing a conflict on the OBi202 with Anveo.

Unchecking Google Chat to fix the problem will also stop forwarding calls to the OBI200.

Changing the inbound route to block GV calls on the OBi202 will still allow GV calls to ring the OBi200.

Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #8 on: September 24, 2014, 03:25:33 pm »

Azrobert:  you can have multiple OBi 20x series boxes connect to the same GV account; it's the 1xx series that can't do that.

Steve,

You don't get my point.

If the OP has the same GV defined on both boxes, both will ring. This is causing a conflict on the OBi202 with Anveo.

Unchecking Google Chat to fix the problem will also stop forwarding calls to the OBI200.

Changing the inbound route to block GV calls on the OBi202 will still allow GV calls to ring the OBi200.



I pointed out that multiple OBi 20x boxes can connect to GV only as a separate factoid.  It's a moot point.  The big-picture goal was to make outbound calls through GV, and have inbound calls route through Anveo for CNAM  and other reasons.  The simple solution uses one OBi, rendering the other one unnecessary and irrelevant for this discussion.
Logged

CLTGreg
Full Member
***
Posts: 109


« Reply #9 on: September 25, 2014, 06:49:54 pm »

Sorry guys, I didn't mean both boxes hooked in at once though I did have that question earlier when considering the 1032. Obi sales never answered my e-mail though so I saved a bit of money going with the 200 on sale.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC