October 19, 2019, 06:46:30 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Always enable "modem mode" ..?  (Read 7931 times)
n808
Newbie
*
Posts: 8


« on: September 29, 2014, 09:30:56 am »

I have a medical device that I have been using on a Comcast VOIP line, which I think is using G711, so in theory it should work over via the OBi100, but it fails. Fax is working fine with a default Google Voice setup.

According to this message, it is suggested one can add a star code *01:

*01, Modem Call, set($Noji1,200),set($Noec1,1),set($Cdm1,3)

Quote
The 3 set() commands tell the obi to do the following for the next outbound call:
1. Disable Jitter Buffer Adjustment, and use a fixed jitter buffer length of 200 ms
2. Disable Echo Canceller
3. Use only G711u and G711a codec

Since I cannot change the phone number the medical device dials, is there a way to always enable these commands for all calls?

If this is possible, and if the settings result in unacceptable talk quality, can I then add a star code to set the device to normal mode for the next number dialed?

P.S. The medical info the device sends is weekly updates and not in any way critical / emergency related.

EDIT: I will try the suggestion in the last post of the thread above (by setting the "star code" to be the first part of the number dialed by the device, but since it requires a Pause to be inserted, it probably will not work ..

EDIT2: found in online manual that neither the jitter buffer nor echo cancellation settings are available for the OBi1x0's. I will have to try again after returning the OBi100 and when I have received an OBi200. I won't give up that easily. I am tired of paying $30 a month for a POTS line used once per week for this medical device (and annoying telemarketing/survey calls ignoring the do-no-call list).

Thanks!
-OBi100 noob.
« Last Edit: September 29, 2014, 05:05:34 pm by n808 » Logged
n808
Newbie
*
Posts: 8


« Reply #1 on: October 02, 2014, 10:36:53 am »

So I got my OBi200, and I tried the suggestion:

Quote
I have tried it using this:

Physical Interfaces > PHONE Port > DigitMap:
(<:1408123>4567|… other rules here …)

This works fine if the digits are dialled in one by one as you might from a normal phone, or from a dect / programmed phone it works if a pause is inserted – 1408123P4567. This gives the “Star Code” time to absorb the 1408123 and the 4567 is passed on to the Phone Port DigitMap.

If you card reader dials very slowly, then it should work using the second DigitMap above. If you cannot reprogram the card reader number, then inserting a pause will not be an option.

But I ran into the exact same problem. If I dial manually it works great, but not from the device, since it probably dials so quickly the OBi does not detect the star code, and sees the whole sequence of numbers as the phone number. Bummer! I really wish there was a way to set these options ON for all calls. The voice call quality with these options ON was still great.

-OBi200 Noob.
Logged
Mango
Hero Member
*****
Posts: 551


« Reply #2 on: October 02, 2014, 11:09:26 am »

If anyone knows how to do this I would like to know too.
Logged

n808
Newbie
*
Posts: 8


« Reply #3 on: October 02, 2014, 12:03:08 pm »

The reply from OBi Support was as follows:
Quote
The OBi devices will not work with data modem, it is not supported as you
describe below. Suggest that you continue to use Comcast VoIP for such modem transmission.

I wish I knew what Comcast VoIP does with their G711 codecs to make it work. Or perhaps the information I found was incorrect.

What does OBi then mean with "modem pass through" in their specification? This is also discussed here.

I guess it's pretty hopeless. I just wish I would have been able to test with the echo cancellation and jitter buffer adjustment turned off.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3926


« Reply #4 on: October 02, 2014, 12:27:57 pm »

Try this StarCode:
*01, Modem Call, set($Noji1,200),set($Noec1,1),set($Cdm1,3),call(16235941000)

16235941000 is the number you want the device to call.
Then program the device to just dial the StarCode "*01".

You can test this with an analog phone.
It dialed out for me by dialing "*01".

Edit:
If the device is dialing too fast for the OBi, you can have a single character StarCode like this:
*, Modem Call, set($Noji1,200),set($Noec1,1),set($Cdm1,3),call(16235941000)

Now just dial "*".

« Last Edit: October 02, 2014, 12:37:10 pm by azrobert » Logged
Mango
Hero Member
*****
Posts: 551


« Reply #5 on: October 02, 2014, 12:30:31 pm »

Please set up the following as a star code on your OBi200.  Note that even though it is called a star code, there is no * present:

16042999000,Modem Call,set($Noji1,200),set($Noec1,1),set($Cdm1,3),call(16042999000)

Replace both instances of 16042999000 with the actual number that your device dials, in the exact same format, which you will find in the OBi's Call History.  Let me know if it works.  I don't have an OBi2 device so am limited by how much I can test.

With this scenario, a pause should not be required.
Logged

n808
Newbie
*
Posts: 8


« Reply #6 on: October 02, 2014, 12:35:53 pm »

Awesome, that sounds like it might work, at least to get the options enabled. I will try when I get home.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3926


« Reply #7 on: October 02, 2014, 12:39:08 pm »

See the update in my last post.
Logged
n808
Newbie
*
Posts: 8


« Reply #8 on: October 02, 2014, 12:48:12 pm »

@azrobert : I will try Mango's suggestion, as I cannot program or change the device's phone numbers. It does not dial too fast for the OBi, it's just too fast for the 1st attempt at a semi-star code which requires a pause for the OBi to absorb the first part of the number, and provide a new dial tone, before the last four digits.

In Mango's suggestion, the entire number is absorbed as a *-code, hopefully - then as you both suggested, instructs the OBi to call the same number. I was not aware of this possibility.
Logged
n808
Newbie
*
Posts: 8


« Reply #9 on: October 02, 2014, 05:38:30 pm »

It works! First attempt - the call went a little longer than usual I assume it negotiated a lower speed, but it worked flawlessly. I verified during the call that jitter buffer was at 200ms, so the settings had been applied.

Good-bye POTS (or expensive Comcast VoIP in my case - I still call it POTS) Smiley

Thank you for the help!
« Last Edit: October 02, 2014, 05:54:44 pm by n808 » Logged
Mango
Hero Member
*****
Posts: 551


« Reply #10 on: October 02, 2014, 06:48:49 pm »

Sweet Cheesy

If you notice works only sporadically, you may wish to experiment with perhaps a 500ms jitter buffer.
Logged

ProfTech
Sr. Member
****
Posts: 451


« Reply #11 on: October 03, 2014, 11:22:21 am »

Mango - This is way interesting! I just bought a 200. I have to use an analog [dial-up] modem occasionally and have always used my POTS line. Tried it on Vonage way back when and also at least once on the Obi [110]. Wouldn't even connect. I can set the modem down to 9600 if I need to and the *01 "One-Call", manual technique should work fine for me. Will have to give it another try.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC