June 23, 2021, 10:01:54 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: Using laptop as landline telephone  (Read 12135 times)
PC10SR
Newbie
*
Posts: 10


« on: October 01, 2014, 03:40:37 am »

I am severely disabled (I have no use of my arms) and I would like to use my adapted Windows laptop to talk on my home PSTN landline here in the UK. Could I achieve this using an OBi110 or similar device coupled with VoIP software on my laptop?

I would anticipate locating the voice bridge next to my wireless router and landline socket and linking to my laptop via wi-fi.

Is this feasible? If so, how would I connect and configure the system (conceptually not physically, I have able bodied assistance), and would I need any an extra hardware or adapters?

Any help would be hugely appreciated.





« Last Edit: October 01, 2014, 04:32:18 am by PC10SR » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #1 on: October 01, 2014, 05:39:57 am »

PC10SR - welcome to the forum.

What you would like can be done if two conditions can be met:

1. Your router must be able to give static local ip addresses to your laptop and to the OBi110. Sometimes this is done by binding the local ip address to the devices mac number.

2. The voip client (softphone) on your laptop must be able to call without registration. I use PhonerLite mainly for testing these kind of setups, it is free and allows calling without registration. Once the setup is proven to work, then you might want to find a more sophisticated softphone.

If those conditions can be met, then the only cost to you would be the OBi110. The PSTN line plugs into the Line Port of the OBi110, which will interface with the softphone on your laptop via your router.

Another option is to use the OBiTALK network to connect between the laptop softphone and the OBi110. This has the advantage of not needing the above two conditions. The disadvantage is that you are using servers located in California to set up each call, although it is free to use once you have bought the OBi110.

The OBi110 needs a physical Ethernet patch cable to connect to the router - this comes in the box. The Line Port connection is the North American rj11 style and needs an adaptor to plug into the British Telecom socket. A suitable one is recommended on Amazon.co.uk next to the OBi110 ad.

I won't detail all of the setup configuration in this first reply, but I'm happy to do so if you go ahead with the idea. The OBi110 comes with settings suitable for North America, so it needs some alterations to get the best out of it in a UK situation. I'm in the UK, so I'm happy to advise on those alterations.


Logged
PC10SR
Newbie
*
Posts: 10


« Reply #2 on: October 02, 2014, 04:24:05 am »

ianobi - many thanks for your speedy and informative reply.

I am expecting my OBi110 and adapters from Amazon UK tomorrow.

My Sagemcom 2504n router can allocate reserved IP addresses and I will use whatever Windows 8.1 compatible softphone program is recommended. Alternatively, I have BlueStacks, so I could possibly run an Android app if that offered any advantage.

Fingers crossed that I don't end up with a tangle of wires and frayed nerves!

Is this topic appropriate in this thread or should I move to the newbies area?

Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #3 on: October 02, 2014, 05:27:23 am »

I should have said that a phone that can plug into the Phone Port of the OBi110 will be required to add the device to the OBiTALK network. This is part of the initial set up which is explained in the Quick Start Guide that comes with the OBi110. The phone can be an old corded type (may need another adapter) or a new hands free / DECT phone.

I recommend port forwarding in your router of port 10000 to the ip address of the OBi110. I don't think other ports will need to be forwarded as you are not using any voip services and the data links between your laptop and the OBi110 are all in your local router subnet.

There's more than one way to program your new OBi - I'll be going along with the standard Obihai company method.

Let's try PhonerLite as the laptop softphone to start with. It's free and a good test tool if things do not go right first time (often the case!)

Quote
Fingers crossed that I don't end up with a tangle of wires and frayed nerves!

Be prepared for frayed nerves! There's a lot of settings to change and it's easy for you to get one wrong (or for me to get it wrong in the write up). Testing is something we'll get to in good time!

Take it step by step - first add the OBi110 as described in the Quick Start Guide, then make sure it can receive incoming and make outgoing calls via the PSTN - there will be big delays in incoming calls ringing the phone attached to the OBi and outgoing calls getting the through to the called number, don't worry about this it will be fixed when we get to the configuration part. If all that works, then change all the settings which will be in my next post arriving here soon!

The best section for this thread is "Installation and Setup". It may well be useful to others looking for something similar.





Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #4 on: October 03, 2014, 01:32:20 am »

I’m assuming that by this post you have added your OBi110 to OBiTALK (**5 etc…), you can make a test call to the OBi echo number **9 222 222 222 and you can make an incoming and outgoing PSTN call from the phone attached to the OBi110.

This looks scary, but most of these settings you will only be changing this one time. A lot of the settings are to optimise your OBi110 for UK use, the rest are for the actual config needed to link PSTN to laptop softphone. I recommend regular tea breaks and soothing music throughout   Smiley  Almost certainly, this will not work first time, but this forum has never failed to solve this type of setup. (So far!)


Assuming that your local ip addresses are as follows:

Laptop:   192.168.1.10
OBi110:   192.168.1.11

They can be anything so long as they are fixed, substitute your settings as required.

The setup will be:

PSTN  > <  OBi LINE Port  > < OBi sp2 192.168.1.11:5490  > < laptop softphone 192.168.1.10:5498


PhonerLite (softphone on laptop) settings:

Set up new account:

New > Provider > Manual Configuration > Proxy/Registrar: 192.168.1.11:5490
Green arrow > Username: 12123434
Green tick

Then go into its configuration and ensure the settings are as follows:

(Remember to click on the “save” icon to save changes before moving on to the next page.)

Server > Proxy/Registrar: 192.168.1.11:5490
Server > Register: unchecked

User > Username: 12123434 (random numbers. This is the softphone CallerId and adds to the security of the setup. Same numbers will be used in the OBi110)
User > Displayed name: paulphone

Network > Local port: 5498 (can be almost anything even, but steer clear of 5060, again to add security to the setup)

Other settings at default.



OBi110:

This setup uses sp2. This leaves sp1 spare for future use should you decide you would like to add a voip service one day.

Most of the settings are check boxes or drop boxes. The digit maps etc can be cut and pasted from here rather than typed in, but be careful not to import any spaces.

Make changes via the OBi Expert Configuration pages. From your OBi Dashboard, click on your OBi number and follow the prompts to get there. To change a value uncheck both boxes to the right of the value and leave them unchecked. After changing the values on one page, press submit at the bottom of the page and wait a few minutes for the OBi to reboot. Then move on to the next page.


Physical Interfaces > PHONE Port > PrimaryLine: PSTN (default)

Physical Interfaces > PHONE Port > DigitMap:
([1-9]x?*(Mpli)|[1-9]S9|[1-9][0-9]S9|999|112|101|111|**0|***|#|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp)|(Mpli))

Physical Interfaces > PHONE Port > OutboundCallRoute:
{([1-9]x?*(Mpli)):pp},{(<#:>|999|112|101|111):li},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}


Physical Interfaces -> LINE Port -> LINE Port -> RingDelay: 0
Physical Interfaces -> LINE Port -> LINE Port -> RingProfile: B
Physical Interfaces -> LINE Port -> LINE Port -> DialDigitOnTime: 80
Physical Interfaces -> LINE Port -> LINE Port -> DialDigitOffTime: 80
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> CPCTimeThreshold: 100
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectPolarityReversal: uncheck
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectFarEndLongSilence: uncheck
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectDisconnectTone: check   
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DisconnectTonePattern: 400-30;3
Physical Interfaces -> LINE Port -> Port Settings -> ACImpedance: 370+(620||310nF)
Physical Interfaces -> LINE Port -> Port Settings -> CallerIDDetectMethod: FSK(V.23)

Physical Interfaces -> LINE Port -> DigitMap:
(999|112|101|111|0[4568]xx.S3|0[123]xxxxxxxxxS0|07[1-9]xxxxxxxxS0|116xxx|xx.S3)

Physical Interfaces -> LINE Port -> InboundCallRoute
{ph,sp2}

If it is not required to ring the phone attached to the OBi110, then:
Physical Interfaces -> LINE Port -> InboundCallRoute
{sp2}


Voice Services -> SP1 Service -> Enable : uncheck (another security measure)


Service Providers -> ITSP Profile B -> SIP -> ProxyServer : 192.168.1.10
Service Providers -> ITSP Profile B -> SIP -> ProxyServerPort : 5498
Service Providers -> ITSP Profile B -> SIP -> X_SpoofCallerID : checked

Voice Services -> SP2 Service -> Enable : checked
Voice Services -> SP2 Service -> AuthUserName : 56789 (anything, but not blank)
Voice Services -> SP2 Service -> X_RegisterEnable : unchecked
Voice Services -> SP2 Service -> X_ServProvProfile : B
Voice Services -> SP2 Service -> X_UserAgentPort : 5490
Voice Services -> SP2 Service -> CallerIDName : OBiHome
Voice Services -> SP2 Service -> MaxSessions : 4
Voice Services -> SP2 Service -> X_InboundCallRoute:
{12123434:li}


To see how calls have been routed check in “Call History”. This can only be accessed via the OBi110 local web page. Use your browser to go to the ip address you fixed for the OBi110. Default user name and password are both “admin”. Then go to Status > Call History and you should see how the calls have been routed. Very useful if they have been routed to the wrong place!
« Last Edit: October 09, 2014, 01:49:07 am by ianobi » Logged
PC10SR
Newbie
*
Posts: 10


« Reply #5 on: October 03, 2014, 10:45:43 am »

I've now setup the static IPs and port forwarding on the router and configured PhonerLite and the OBi110 as per the earlier instructions. I haven't received the phone cable and adapter yet, so I can't test anything.

Also, I haven't yet added the device to the OBiTALK network. Is this a central part of the setup? Should a UK phone and RJ11 cable be OK for this?
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #6 on: October 04, 2014, 02:40:34 am »

I'm surprised that you were able to set up the OBi110 using the method I described without adding the OBi110 to the OBiTALK network. Please check to see if the settings have stayed set by looking at the device directly via its ip address page.

If all the settings are set as described, then the setup should be working. Try dialling out from PhonerLite. Also, PhonerLite should ring when there's an incoming call.

A UK phone is ok for testing if you can plug the rj11 cable directly into it. Otherwise you will need an adapter that converts from the British Telecom style plug on the phone to the rj11 socket of the OBi110 Phone Port.

In the final setup it looks like you will not need a phone plugged into the OBi110, but it is useful for testing.
Logged
PC10SR
Newbie
*
Posts: 10


« Reply #7 on: October 04, 2014, 07:25:55 am »

OK, i have some incremental progress:


I'm hooked up from the OBi telco port to my PSTN line with the cable from Amazon.

I have a domestic phone connected to the OBi phone port.

When I take the domestic phone off-hook I hear normal landline dial tone.

I have registered with OBiTalk and I have an OBi number.

The OBi echo test works fine.

I have double checked all the suggested settings and they are still good.



However:

When I dial out a known number on the domestic phone nothing happens until I hear a US voice in the earpiece saying "no service configured air. Please login to OBiTalk.com and configure your device."

When I call in on PSTN I get no response on either the domestic phone or PhonerLite.

When I try to call out on PhonerLite I get nothing but a continuous tone from the laptop speakers, followed eventually by a few seconds of pulsed tone then silence.


So, still a little way to go...






« Last Edit: October 04, 2014, 07:45:43 am by PC10SR » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #8 on: October 04, 2014, 07:51:01 am »

Quote
When I take the domestic phone off-hook I hear normal landline dial tone.

This dial tone is supplied by the OBi Phone Port it does not indicate that you are connected correctly to the PSTN. If you take the domestic phone off hook and dial "#" that should give you PSTN dial tone and allow you to dial numbers. If that does not work then I suspect there's a problem with the connection between the OBi110 Line Port and the PSTN socket.

All of your other findings seem to suggest that the OBi110 is not connected to the PSTN correctly. If you look at Status > PHONE & LINE Status under Line Port Status it should show a TipRingVoltage of around 50v. This is the voltage of the PSTN line.

Not too far to go ...
Logged
PC10SR
Newbie
*
Posts: 10


« Reply #9 on: October 04, 2014, 08:34:16 am »

Any time I try to call out from the domestic phone (# or number) I get the "no service configured air message."

The line port status is on-hook, 0 mA, 0V when the phone is both on and off hook
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #10 on: October 04, 2014, 08:50:05 am »

Looks like the problem is the OBi110 is not connected to the PSTN correctly. Three possibilities:

1. PSTN socket not working - test by connecting the phone into it directly.
2. OBi110 Line Port faulty - possible but unlikely.
3. Cable / adapter faulty or wrong type - quite likely.

It's not unusual to have this kind of problem. It's frustrating and time consuming, but only needs solving once! Pins 2 and 5 from the BT socket need to connect with pins 3 and 4 of the rj11 plug (centre pair normally red and green).

If you have an old modem cable around they often have the correct pin configurations.


Logged
NoelB
Jr. Member
**
Posts: 41


« Reply #11 on: October 04, 2014, 11:32:56 pm »

My first post and wondering why the softphone on a laptop must be able to call without registration. I have zoiper on a samsung that registers via a wifi AP with an obi110 in proxy mode and it works ok.There are not that many softphones that you can diasable registration so it is a bit of a restriction.
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #12 on: October 05, 2014, 01:48:39 am »

NoelB - welcome to the forum.

I believe that the "X_Proxy" setting is only available on the OBi2xx series models. There is no way to register a client (softphone) directly to an OBi110. Do you mean that your zoiper softphone registers with a voip service provider that the OBi110 registers with?

The OBi110 remains the best option to bridge any voip service or softphone etc to the PSTN. Obviously nothing can register with a PSTN connection, so softphone to OBi110 requires both sides to call without registration before the call is bridged to PSTN.

I do agree that many softphones do not allow calling without registration, but there are some around. I suggested PhonerLite as a starting point as it's free, allows calling without registration, is very easy to set up and is good for debugging. It's a bit "clunky" and has no video, but is a great softphone for "proof of concept" projects.
Logged
NoelB
Jr. Member
**
Posts: 41


« Reply #13 on: October 05, 2014, 02:20:11 am »

Thanks ianobi. You are of course correct .I have had a obi202 for a while and recently got a couple of obi110s to use with obitalk but never bothered to compare their features in detail. I realised I had set  zoiper to register to the obi202 which has the X_Proxy which is not present in the obi110. Its all clear now -my mistake. Keep your posts coming as you have taught me heaps. I took your advice and downloaded PhonerLite and yes I particularly like the debug which took a bit of finding as when first downloaded it is not enabled.
Logged
PC10SR
Newbie
*
Posts: 10


« Reply #14 on: October 05, 2014, 05:01:07 am »

OK, slightly more progress.

The RJ11 lead I was using in the OBi telco port was wired to the outer pins. I have now substituted another lead (from a Panasonic phone) wired to the inner pins and I have an improvement:

I can now call in on PSTN and both the domestic (OBi phone port) and the laptop (softphone) ring.

If I answer on the phone port I have good 2 way voice comms.

If I answer on the softphone I get good clear speech on the laptop but the  calling end reports my voice is faint and they hear their own voice echoed back to them.

I still can't call out on either the phone port or the softphone.


We're heading in the right direction...
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #15 on: October 05, 2014, 05:46:31 am »

Looks like you have the physical connections all sorted now. I cannot see any obvious reason why outgoing calls are not working, but some testing should reveal all. Try:

1. Plug the domestic phone direct into the PSTN socket. Can you make outgoing calls? This will prove the PSTN line and the phone. (Obvious I know, but it's surprising how simple things get overlooked.)

2. With the OBi110 back in the setup, if you take the domestic phone off hook and dial "#" do you get PSTN dial tone? Can you then continue to dial out?

3. When attempting calls from the Phone Port and from the laptop, does Call History show anything? See earlier reply for accessing Call History.

4. Do you live in a rural area maybe a long way from the telephone exchange? (We can adjust for this.)


Quote
If I answer on the softphone I get good clear speech on the laptop but the  calling end reports my voice is faint and they hear their own voice echoed back to them.

This may be an effect of the physical design of most laptops. The speakers and mic are near each other, so the callers voice may feed back into the mic sounding like echo. It may be worth looking at using a headset or separate speakers / mic so they can be further apart. The mic gain and the speaker volume can be changed on PhonerLite, you have to click on each symbol to unlock it, then move the slider. It's something to look at once we have solved the outgoing calls issue.


Logged
PC10SR
Newbie
*
Posts: 10


« Reply #16 on: October 05, 2014, 12:40:39 pm »

The domestic phone works perfectly directly into the wall socket, into the ADSL filter or into the 2-way splitter plugged into the filter. Repeating with the OBi into all of these 3 locations yields the original results: inbound PSTN calls to OBi phone port or softphone fine, no outbound calls from either location.

When I dial # on the OBi phone port I get a couple of seconds of silence then a couple of clicks and then more dial tone, then while I dial a known PSTN number I get silence, but after a few seconds I get pulsed tone but no connection.

When I attempt calls from the phone port I get 2 call records a few seconds apart. The first is for the # press, which lists new call, call connected and end call all in the same second. The second is for the PSTN dialled number attempt, which shows new call and end call in the same second.

Call attempts from the softphone generate no record.

I live in a suburban area - Hove. I get 7Mb/s ADSL from Sky.

We'll get there...


Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #17 on: October 06, 2014, 01:54:59 am »

It looks like the OBi110 is having trouble seizing the PSTN line and maintaining the connection. This is odd as it works ok for incoming calls. Anyhow, we are not out of ideas just yet!

Change:

Physical Interfaces -> LINE Port -> LINE Port -> DialDelay: 2000
Physical Interfaces -> LINE Port -> LINE Port -> DialDigitOnTime: 200
Physical Interfaces -> LINE Port -> LINE Port -> DialDigitOffTime: 200

This will give the OBi110 two seconds to seize the PSTN line before it starts dialling and it will dial slightly slower. If it works try cutting DialDelay back to 1500, then 1000. Test from the Phone Port first and check Call History again for results.

Have another look at this:
Quote
If you look at Status > PHONE & LINE Status under Line Port Status it should show a TipRingVoltage of around 50v. This is the voltage of the PSTN line.

If the above changes don't solve the problem it may be something else on the PSTN line affecting line conditions. As a test try disconnecting all other devices connected to the PSTN line just leaving the OBi110 connected directly into the wall socket.

I'm away from my PC until around 1500 today, I'll check back here then.






Logged
PC10SR
Newbie
*
Posts: 10


« Reply #18 on: October 06, 2014, 07:26:27 am »

I tried the suggested changes without any success.

The TipRing voltage is -51v.

What is it that my normal phone does to dial out successfully that the OBi currently doesn't?

Hmmm...


« Last Edit: October 06, 2014, 07:32:19 am by PC10SR » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #19 on: October 06, 2014, 08:17:51 am »

That's a good question! As far as the PSTN line goes the OBi110 Line Port just looks like a phone that goes off hook, puts a loop across the line and send DTMF tones for dialling.

Let's do a Sherlock Holmes on this. We have eliminated most possibilities. About the only thing left is that some sort of line condition, maybe some capacitance, is looking like a PSTN disconnection signal. For now let's tell the OBi110 not to look for any line disconnection. Leave all the changes we have done in place, particularly DialDelay at 2000 and set:

Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectCPC: uncheck
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectPolarityReversal: uncheck
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectFarEndLongSilence: uncheck
*Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectDisconnectTone: uncheck

* Edit: This was enabled to solve another problem - see later posts. New settings are:
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DetectDisconnectTone: check   
Physical Interfaces -> LINE Port -> PSTN Disconnect Detection -> DisconnectTonePattern: 400-30;3

You could easily end up as one of the top ten OBi110 experts if this goes on much longer   Smiley
« Last Edit: October 11, 2014, 05:37:44 am by ianobi » Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement