Anybody having connection issues with RingTo?

Started by zorlac, November 29, 2014, 04:36:53 PM

Previous topic - Next topic

zorlac

I was having trouble with inbound calls on a obi200 not ringing the phone at times and after emailing RT I received this response.

We set the Obi devices to communicate with our servers on UDP port 9060. It is possible that you may have a router that is closing the connection between your Obi and RingTo. I've just updated your provisioning profile to use TCP port 9060. For the new config to take effect, you'll need to delete the Obi RingTo config from the SP slot in Obitalk. Wait a few minutes, then re-provision RingTo.


After a factory reset & reconfiguring SP1 & 2 only Anveo on SP2 works.

SP1 is stuck at....
Register Failed: Server Not Reachable (server=54.209.126.237:9060

I went into expert mode and changed all the 5060 port references to 9060 and also put the obi200 in the DMZ on the router but it's still offline.
I think it's them. >:(

Taoman

Quote from: zorlac on November 29, 2014, 04:36:53 PM


We set the Obi devices to communicate with our servers on UDP port 9060. It is possible that you may have a router that is closing the connection between your Obi and RingTo. I've just updated your provisioning profile to use TCP port 9060. For the new config to take effect, you'll need to delete the Obi RingTo config from the SP slot in Obitalk. Wait a few minutes, then re-provision RingTo.


After a factory reset & reconfiguring SP1 & 2 only Anveo on SP2 works.

SP1 is stuck at....
Register Failed: Server Not Reachable (server=54.209.126.237:9060

I went into expert mode and changed all the 5060 port references to 9060 and also put the obi200 in the DMZ on the router but it's still offline.


Did you also change the transport protocol (ProxyServerTransport) to TCP from UDP?  Are you sure the tech said to use TCP instead of UDP? That's somewhat unusual. As far as I can tell, port 9060 is not open on that server.
Can you at least ping the server?

zorlac

#2
Thanks for the reply, I didn't even notice the TCP change.
I tried setting the ProxyServerTransport) to TCP & port 9060 and I'm able to ping 54.209.126.237 from my house.
The obi200 at my parents house is still not registering according to the obi portal.
What I posted was a copy & paste from the RT tech.
What I really don't understand is that if RT auto configures SP1 why would the ports still be set at 5060?

This is from my house, not exactly sure what it means but it looks like only port 5060 supports SIP.


root@antixC700:/home/me#  nmap -p 9060 -sU 54.209.126.237

Starting Nmap 6.00 ( http://nmap.org ) at 2014-11-30 01:38 EST
Nmap scan report for ec2-54-209-126-237.compute-1.amazonaws.com (54.209.126.237)
Host is up (0.021s latency).
PORT     STATE         SERVICE
9060/udp open|filtered unknown

Nmap done: 1 IP address (1 host up) scanned in 0.61 seconds

root@antixC700:/home/me#  nmap -p 9060 -sT 54.209.126.237

Starting Nmap 6.00 ( http://nmap.org ) at 2014-11-30 01:38 EST
Nmap scan report for ec2-54-209-126-237.compute-1.amazonaws.com (54.209.126.237)
Host is up (0.021s latency).
PORT     STATE    SERVICE
9060/tcp filtered unknown

Nmap done: 1 IP address (1 host up) scanned in 0.29 seconds

Port 5060


root@antixC700:/home/me#  nmap -p 5060 -sT 54.209.126.237

Starting Nmap 6.00 ( http://nmap.org ) at 2014-11-30 01:44 EST
Nmap scan report for ec2-54-209-126-237.compute-1.amazonaws.com (54.209.126.237)
Host is up (0.022s latency).
PORT     STATE    SERVICE
5060/tcp filtered sip

Nmap done: 1 IP address (1 host up) scanned in 0.28 seconds
root@antixC700:/home/me#  nmap -p 5060 -sU 54.209.126.237

Starting Nmap 6.00 ( http://nmap.org ) at 2014-11-30 01:44 EST
Nmap scan report for ec2-54-209-126-237.compute-1.amazonaws.com (54.209.126.237)
Host is up (0.022s latency).
PORT     STATE         SERVICE
5060/udp open|filtered sip

Nmap done: 1 IP address (1 host up) scanned in 0.62 seconds