[SOLVED] No audio when bridging

Started by Felix, May 22, 2011, 11:08:21 PM

Previous topic - Next topic

Felix

I have GV on one line, and SIP provider on another. My goal is to allow caller to dial SIP (it has local number in a foreign country), and OBi would dial my office or cell number. Both incoming and out going calls work fine on both lines.

If I bridge to echo test pp(222222222), works fine as well.

However,when I bridge to GV - sp1(1xxxxxxxxx), there is no audio either way.

Any advise would be very welcome. My router is OpenWRT-based, and I didn't make any modifications that I can think of...

RonR

The easiest way to determine if your router is the culprit is to temporarily connect your OBi directly to your modem, bypassing the router (power-cycle both the OBi and the modem after making the connection).  If your audio problems go away, the router is the prime suspect.

obi-support2

Felix,

Please take a look at the call status page of your OBi and check what audio codec is used with your
SIP SP. It's possible that your SP always chooses G729, but GV can only do G711, hence the audio problem.

In that case, your can try to force your SP to use G711 (by disabling G729 and G726 codecs in the corresponding codec profile on the OBi).

However, if your SIP SP can only do G729, then there is no solution from the OBi side at this time.


Thank you.
OBIHAI Support Staff

Felix

Thank you very much!

SIP SP supports g711u, g729 and GSM codecs. I'll check the settings later today.

While theoretically, it's the easiest troubleshooting step to connect OBi directly to the modem, in practice it's not that simple since everything else in the house gets disconnected from the network.

RonR

Quote from: Felix on May 23, 2011, 10:11:19 AM
While theoretically, it's the easiest troubleshooting step to connect OBi directly to the modem, in practice it's not that simple since everything else in the house gets disconnected from the network.

Your network only needs to be disrupted long enough to make a test call or two.

obi-support2

Felix,

Put bridging aside for a moment.
If you can pick up the phone and make independent calls with your SIP SP or GV successfully
w/ 2-way audio, then your network setup should be fine. Otherwise, checking your network setup is a good first step.

If the problem only happens when trying to bridge the two services, please take a look
at the call status page to see what codecs that each call leg is using "during the call".
I understand your SP supports all the codecs, but that doesn't mean they would prefer to
use g711 over g729. You might still need to force your codec setting to g711.







OBIHAI Support Staff

Felix

Thank you - that was it. Once I forced SIP SP to use g711, bridging worked perfectly!