May 05, 2021, 10:06:06 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 2 [3] 4
  Print  
Author Topic: Call Forward (unconditional) & dialling out on Obitalk 200 ---Help needed.  (Read 78403 times)
realjohny
Jr. Member
**
Posts: 58


« Reply #40 on: January 23, 2015, 03:37:04 pm »

I tried this but there is no incoming call on local ObiBT and therefore it doesn't show any call either on call history of local or remote Obi device.

I have tried all possible Caller ID formats without country code, with country code , with 00 and with a "+".

This is strange as GV calls from remote Obi now goes to my mobile via local Obi/ObiBT connected mobile.

So currently I am not able to reach remote AA either using my mobile or cordless connected with local Obi.

**I am planning to use ObiLine with remote OBi instead as Bluetooth isn't a reliable solution. I will connect a fixed wireless terminal (which uses a SIM card and produces dial tone to use it like a normal PSTN line). SO in this case can I have your help to configure remote Obi AA to allow me to call using ObiLIne or to call phone connected with phone port of remote Obi ? I mean calling my family for free or calling out using ObiLine as and when required.

In this VoIP censored area (specially in office)  this will be a great scenario where  GV works at home (local Obi) and I can call cell phone connected with local Obi  and reach remote AA and dial to my family or use remote ObiLIne. Currently calls from remote Obi are reaching my mobile which is great but I can't dial out from my cell phone.

Happy weekend Smiley
« Last Edit: January 23, 2015, 03:54:56 pm by realjohny » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #41 on: January 24, 2015, 06:28:04 am »

Quote
I tried this but there is no incoming call on local ObiBT and therefore it doesn't show any call either on call history of local or remote Obi device.
This is strange as GV calls from remote Obi now goes to my mobile via local Obi/ObiBT connected mobile.

If I understand you correctly outbound BT calls work, but inbound don't.
This is strange.
For a test try this:
Local OBi:
Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{aa}

Now any inbound call will go to the AA.
Please report back what happens.
If it works, you will be able to see the callerid in the call history.

--------------------------------------------------------------------------------
Quote
So currently I am not able to reach remote AA either using my mobile or cordless connected with local Obi.
Outbound calls from the local phone port don't go to the AA.
Dial 0 from the local phone port.
Does it ring the remote phone port?

----------------------------------- ------------------------------------------
We have so many route combinations defined, I'm confused on how the OBiLine is going to be used.
Currently the remote OBiLine is used for remote outbound calls.
Do you want to change this to receive inbound calls from your local mobile?
Will the OBiLine be located at the remote site, but have a local number?
or
Is this a 2nd OBiLine and will be located at the local site?

----------------------------------------------------------------------------
Quote
Currently calls from remote Obi are reaching my mobile which is great but I can't dial out from my cell phone.

Are these the calls coming from the remote BT?
If yes, then inbound BT calls work at the remote site, but not at the local site.
There must be some coding error at the local site.
Hopefully my 1st suggestion above will work.

-------------------------------------------------------------------------------
Can you call the remote GV number from your mobile?
You can reach the remote AA this way.
If this is a toll call do the following:
Install the Hangouts app on your local mobile.
Android has a 2nd app (Hangouts Dialer).
Hangouts will allow you to use GV for outbound calls from your mobile.
Configure it with your local GV number.
Now call the remote GV number with Hangouts from your mobile to be routed to the AA.

Another Option is to install the Obion app on your mobile then you can communicate directly with the remote OBi200 over the OBiTalk network. Some people have problems using the Obion app.
« Last Edit: January 24, 2015, 08:38:54 am by azrobert » Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #42 on: January 24, 2015, 09:16:22 am »

Quote

If I understand you correctly outbound BT calls work, but inbound don't.
This is strange.
For a test try this:
Local OBi:
Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{aa}

Now any inbound call will go to the AA.
Please report back what happens.
If it works, you will be able to see the callerid in the call history.


I tried but no success. In fact I have noticed one thing is that when I call connected phone green phone light on Obi device turns off and after a few rings even power light turns off...looks like Obi device goes through power cycle?

Quote

Outbound calls from the local phone port don't go to the AA.
Dial 0 from the local phone port.
Does it ring the remote phone port?

Actually I hear GV message that your call couldn't be completed.


Quote
We have so many route combinations defined, I'm confused on how the OBiLine is going to be used.
Currently the remote OBiLine is used for remote outbound calls.
Do you want to change this to receive inbound calls from your local mobile?
Will the OBiLine be located at the remote site, but have a local number?
or
Is this a 2nd OBiLine and will be located at the local site?

I have attached a graphical image to explain this. I want to use remote PSTN line while sitting in another country and want to transfer all calls on remote PSTN to reach my mobile travelling via Obi+attached bluetooth phone.

Quote

Can you call the remote GV number from your mobile?
You can reach the remote AA this way.
If this is a toll call do the following:
Install the Hangouts app on your local mobile.
Android has a 2nd app (Hangouts Dialer).
Hangouts will allow you to use GV for outbound calls from your mobile.
Configure it with your local GV number.
Now call the remote GV number with Hangouts from your mobile to be routed to the AA.

I called from my mobile and it rings on attached remote phone.



* B007D930YO-amzn15.jpg (90.28 KB, 1374x730 - viewed 688 times.)
« Last Edit: January 24, 2015, 09:18:35 am by realjohny » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #43 on: January 24, 2015, 11:15:06 am »

Quote
Actually I hear GV message that your call couldn't be completed.
Please check the local phone port outbound call route and DigitMap. Only 10 digit number prefixed with "1" should be routed to GV. Everything else should be routed to the remote OBi200.
I added "***" to the DigitMap for the AA2. Nothing to do with this problem, just previously missed it.

Local OBi:
Physical Interfaces -> Phone Port
DigitMap:
(***|1xxxxxxxxxx|@@.S2)
OutboundCallRoute:
{***:aa2},{(1xxxxxxxxxx):sp1},{(<510222222*>@@.):pp}

Dial 0 from the local phone port and post the call history.

------------------------------------------------------------------------

 
Quote
I called from my mobile and it rings on attached remote phone.
Add your mobile number to the inbound rule.
Remote OBi:
Voice Services -> SP1 Service -> InboundCallRoute:
{(Local_GV#|your_mobile#):aa},{ph}

I added OBion app as another solution to my previous post after you quoted me.
---------------------------------------------------------------------------

I'm still not sure I understand. You want all inbound calls on the remote OBiline to be forwarded to your mobile via remote BT. Correct? This is a new requirement, not a fix to circumvent one of the other problems. Correct?

Remote OBi:
Physical Interfaces -> Line Port -> InboundCallRoute:
bt1(your_mobile#)
Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #44 on: January 25, 2015, 01:16:11 pm »

Quote
Please check the local phone port outbound call route and DigitMap. Only 10 digit number prefixed with "1" should be routed to GV. Everything else should be routed to the remote OBi200.
I added "***" to the DigitMap for the AA2. Nothing to do with this problem, just previously missed it.

Local OBi:
Physical Interfaces -> Phone Port
DigitMap:
(***|1xxxxxxxxxx|@@.S2)
OutboundCallRoute:
{***:aa2},{(1xxxxxxxxxx):sp1},{(<510222222*>@@.):pp}

Dial 0 from the local phone port and post the call history.



I tried and hear message "Number you dialled has been rejected by service provider, reason being 404"

Quote

Add your mobile number to the inbound rule.
Remote OBi:
Voice Services -> SP1 Service -> InboundCallRoute:
{(Local_GV#|your_mobile#):aa},{ph}

I added OBion app as another solution to my previous post after you quoted me.


In fact I don't want calls directly on remote GV to transfer to my mobile but in facct any call on remote ObiLINE + Local GV+ Local Obi to be transfered to my mobile.

I tried to explain it in the image, I can elaborate it more if you like Smiley  In fact purpose of all is to use remote PSTN line remotely and transfer all calls on that remote PSTN to my local mobile (which isn't connected directly with Obi) via local ObiBT (which is connected with a dedicated mobile phone).

In fact if I call local ObiBT phone and manage to reach remote AA (which gives me options to chose either calling remote GV and ring on phone or use remote PSNT line) will be awsome and is what I want. 
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #45 on: January 25, 2015, 08:46:44 pm »

My fault, I didn't take a close look at your diagram. You want inbound calls on the remote OBiLine sent to your personal mobile. This is the same function you have on the remote BT and the code is the same.

Remote OBi:
Physiscal Interfaces-> Line port -> InboundCallRoute:
pp(510111111*Your_Cell#)
_______________________________________________________

The local phone port is not functioning properly.
Please dial 0 again and post the call history from both the local and remote OBi200s.
_______________________________________________________

You can't reach the AA from your personal mobile by calling the local BT.
The call history doesn't show any activity, indicating the call is not reaching the local OBi.
You said:
Quote
I tried but no success. In fact I have noticed one thing is that when I call connected phone green phone light on Obi device turns off and after a few rings even power light turns off...looks like Obi device goes through power cycle?

This suggests a hardware problem.

I made a suggestion to circumvent the above problem by calling the remote GV# directly with your mobile or using the hangouts app. You tried it before I made any changes and said it rang the phone port. The following will send the call to the AA.

Remote OBi:
Voice Services -> SP1 Service -> InboundCallRoute:
{(Local_GV#|your_mobile#):aa},{ph}
« Last Edit: January 27, 2015, 02:23:37 pm by azrobert » Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #46 on: January 27, 2015, 02:08:04 pm »

I will give it a try today and will report. But I think we are missing something here, I think I haven't explained it well Sad
Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #47 on: February 09, 2015, 02:07:13 pm »

I am writing you after a few days sickness Smiley Trying to achieve it again, you definitely have been a great support indeed Smiley

In remote line setting I have entered inbound call route as pp(510946xxx*056789xxxx) as I understood it, where 510946xxx is local Obitalk number and is my personal mobile that I carry (not the one connected with local Obi with Bluetooth). Do you think call on remote ObiLine route to local Obi and then to mobile via connected Bluetooth mobile ? I think even in local Obitalk there must be setting to route this call via Bluetooth..what do you say?


I was earlier able to reach remote Obi AA dialing from local phone port, I am forgetting which setting that you recommended earlier. But there is no way I can reach remote AA calling local ObiBT and reaching remote AA and then using remote PSTN line?

I have ordered another Obi200 device which will arrive in a week just to see if existing local Obi is faulty. Also as I have ObiLine as well locally and remotely I am considering using GSM Wireless terminal to give dial tone to ObiLine and not to use bluetooth (considering there might be some issue with it?).
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #48 on: February 10, 2015, 06:17:38 am »

Local OBi Number: 510946xxx
Remote OBi Number: 510813xxx
Personal Mobile#: 056789xxxx

Local OBi:

Voice Services -> OBiTalk Service -> InboundCallRoute:
{510813xxx>(xx.):bt1},{ph}

Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{+cc056789xxxx:aa},{ph}

Voice Services -> Auto Attendant -> DigitMap:
(x|[1-9]x|@@.S2)
Voice Services -> Auto Attendant -> OutboundCallRoute:
{(1xxxxxxxxxx):sp1},{(<510813xxx*>@@.):pp}

Physical Interfaces -> Phone Port

DigitMap
(***|1xxxxxxxxxx|@@.S2)

OutboundCallRoute
{999:aa},{***:aa2},{(1xxxxxxxxxx):sp1},{(<510813xxx*>@@.):pp}

Speed dials:
pp(510813xxx*0)                             Ring phone
pp(510813xxx*#8005551212)       Line call
pp(510813xxx*8005551212)         BT call

Remote OBi:

Voice Services -> SP1 Service -> InboundCallRoute:
{(1Local_GV#):aa},{ph}

Voice Services -> OBiTalk Service -> InboundCallRoute:
{510946xxx >(<0:>):ph},{510946xxx>(<#:>xx.):li},{510946xxx>(xx.):bt1},{ph}

Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
pp(510946xxx*056789xxxx)

Voice Services -> Auto Attendant -> DigitMap:
(x|[1-9]x|@@.S2)
Voice Services -> Auto Attendant -> OutboundCallRoute:
{(<0:>):ph},{(<#:>xx.):li},{bt1}

Physiscal Interfaces-> Line port -> InboundCallRoute:
pp(510946xxx*056789xxxx)

From local phone port dial:
999                     Local AA
0                        Ring remote phone
#8005551212     Remote Line call
8005551212       Remote BT call
18005551212     Local SP1 call

From AA after calling BT with your mobile:
Reply 1 to ring remote phone
Otherwise reply 2 then dial:
#8005551212#        Remote Line call
8005551212#          Remote BT call
18005551212#        Local SP1 call
« Last Edit: February 11, 2015, 07:20:32 am by azrobert » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #49 on: February 10, 2015, 06:37:54 am »

I created the above configuration from a copy of reply#27 and updated it with the OBi numbers of the OBi202s and your mobile number. You were having problems, so I recommended in Reply#29 using GV to reach the AA. I don't know if you are using any of this code, so I didn't include it in the above configuration.
______________________________________

Quote
I think even in local Obitalk there must be setting to route this call via Bluetooth..what do you say?
Remote OBi:
Physiscal Interfaces-> Line port -> InboundCallRoute:
pp(510946xxx*056789xxxx)

The above code will route inbound line calls to the local OBi with your mobile number included.

Local OBi:
Voice Services -> OBiTalk Service -> InboundCallRoute:
{510813xxx>(xx.):bt1},{ph}

The above code will route ANY call from the remote OBi with an attached number out BT.

The remote BT inbound calls use the same code, so if BT calls work then there is probably something wrong with the OBiLine adapter.
______________________________________

Quote
I was earlier able to reach remote Obi AA dialing from local phone port, I am forgetting which setting that you recommended earlier.
Local OBi:
OutboundCallRoute
{999:aa},{***:aa2},{(1xxxxxxxxxx):sp1},{(<510813xxx*>@@.):pp}

I added dialing "999" to route to the local AA then the local AA will route the call to the remote OBi.
______________________________________

Quote
But there is no way I can reach remote AA calling local ObiBT and reaching remote AA and then using remote PSTN line?
Local OBi:
Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{+cc056789xxxx:aa},{ph}

The above rule will route local inbound BT calls from your mobile to the local AA. I believe you previously said the call history showed the callerid had a plus sign and the country code. The callerid in the above rule must exactly match the callerid in the call history.

If you still can't get the call to be routed to the local AA, you can unconditionally route all inbound BT call to the AA with the following rule:
Voice Services -> OBiBlueTooth1 -> InboundCallRoute: aa

« Last Edit: February 10, 2015, 07:07:50 am by azrobert » Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #50 on: February 10, 2015, 12:49:28 pm »

I have already settings which you mentioned in post#29.

Below setting in remote Obi actually rings phone attached to remote Obi and doesn't connect me with remote AA.

Voice Services -> SP1 Service -> InboundCallRoute:
{(Local_GV#):aa},{ph}

*My Local GV in above number is without + or 1 in the start.

------------------
In post 29 you have mentioned:

"You can have both methods setup at the same time.
Leave the BT Inbound route unchanged like this.
Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{(1?4808370001):aa)},{ph,ph2}"

Shoudl this be in local or remote Obi ? And number "1?4808370001" is local or remote GV? Should it be withour "1?"

--------------------------

You have mentioned:
Local OBi:
OutboundCallRoute
{999:aa},{***:aa2},{(1xxxxxxxxxx):sp1},{(<510813xxx*>@@.):pp}

I added dialing "999" to route to the local AA then the local AA will route the call to the remote OBi. "


Where should this go? In GV route or AA?.



-------------------
So far the issue is that on local Obi there is no inbound call when I call local ObiBT attached phone.

I will give it another try and will report back. Thank you Smiley
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #51 on: February 10, 2015, 04:15:23 pm »



Quote
Below setting in remote Obi actually rings phone attached to remote Obi and doesn't connect me with remote AA.

Voice Services -> SP1 Service -> InboundCallRoute:
{(Local_GV#):aa},{ph}
Remote OBi:
CallerID on an inbound GV trunk has the "1" prefix.
Try:
{(1Local_GV#):aa},{ph}
______________________________________

Quote
In post 29 you have mentioned:

"You can have both methods setup at the same time.
Leave the BT Inbound route unchanged like this.
Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{(1?4808370001):aa)},{ph,ph2}"

Shoudl this be in local or remote Obi ? And number "1?4808370001" is local or remote GV? Should it be withour "1?"

I believe this was for the remote OBi, and don't know why I suggested it. I probably didn't understand your requirements. Ignore this.
______________________________________

Quote
You have mentioned:
Local OBi:
OutboundCallRoute
{999:aa},{***:aa2},{(1xxxxxxxxxx):sp1},{(<510813xxx*>@@.):pp}

I added dialing "999" to route to the local AA then the local AA will route the call to the remote OBi. "

Where should this go? In GV route or AA?.

This is a replacement for the local Phone Port OutboundCallroute.
Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #52 on: February 14, 2015, 07:47:18 am »

I am really confuse here to be honest. Here are issue which I am still facing:

1- All dialed calls from local phone are reaching remote Obi Phone even if I am dialing any other GV number.

2- I am not able to reach remote AA to use either remote PSTN line o paired Bluetooth phone.

3- Calls on remote PSTN aren't reaching local Obi and then to my phone via paired mobile.

I think I am still not explained it well ? Can you please see the diagram.

Thank you Smiley

*P.S. If I call remote GV from Hangout dialer it hangs up after mentioning a brief message with +cc234567..


I wast reading your another post in forum and was wondering if rules can be defined for:

-All calls from local ph starting with 02, 03, 04, 05, 06, 07, 08,09 going through remote PSTN and/or ObiBT.


- All calls starting with any other number (except 510 going through OBi) going through GV.

This isn't a new requirement, in fact I came to this after reading your post.
« Last Edit: February 14, 2015, 01:16:55 pm by realjohny » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #53 on: February 15, 2015, 03:41:37 pm »

With this post I'm only going to address calls dialed from the local phone.

Quote
1- All dialed calls from local phone are reaching remote Obi Phone even if I am dialing any other GV number.

All dialed numbers in the format 1xxxxxxxxxx should be routed out the local SP1 (GV), all other numbers should be routed to the remote OBi.
Are you saying this is not working?

Quote
-All calls from local ph starting with 02, 03, 04, 05, 06, 07, 08,09 going through remote PSTN and/or ObiBT.
- All calls starting with any other number (except 510 going through OBi) going through GV.

The following is the outbound routing for calls sent to the remote OBi:
Currently, any number with a prefix of # (pound sign) will be routed out PSTN.
All other numbers will be routed out BT.

Are you saying this is not working? Are these calls ringing the phone attached to the remote OBi?

Is the following what you want?
Numbers dialed from local OBi phone starting with 02 thru 09 routed to the remote OBi.
Then what do you want? Should they be routed out the remote PSTN or BT?

All other numbers except 510 routed out the LOCAL SP1 (GV).

What is a 510 number and where should they be routed?
Is this a number or prefix?
Is this an OBi number?

Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #54 on: February 17, 2015, 01:51:18 pm »

Quote

With this post I'm only going to address calls dialed from the local phone.

1- All dialed calls from local phone are reaching remote Obi Phone even if I am dialing any other GV number.

All dialed numbers in the format 1xxxxxxxxxx should be routed out the local SP1 (GV), all other numbers should be routed to the remote OBi.
Are you saying this is not working?

Actually if I try to dial any GV number in standard format is ringing remote GV. I have set "4" as speed dial for remote GV though and 3 for remote Obi but any number I dial and it is ringing remote GV.

Quote

Quote
-All calls from local ph starting with 02, 03, 04, 05, 06, 07, 08,09 going through remote PSTN.
- All calls starting with any other number (except 510 going through OBi) going through GV.

The following is the outbound routing for calls sent to the remote OBi:
Currently, any number with a prefix of # (pound sign) will be routed out PSTN.
All other numbers will be routed out BT.

Are you saying this is not working? Are these calls ringing the phone attached to the remote OBi?

So I should dial any number will prefix # to use remote PSTN ? I will give it a try and will post as it is night at remote site and I fear it will ring remote phone to wake everyone up. But earlier I followed your post#27 and now when I dial 999 AA respond, I am not sure if it is remote or local AA. It gives me three options but calls still ring at remote Obi phone.

Quote
Is the following what you want?
Numbers dialed from local OBi phone starting with 02 thru 09 routed to the remote OBi.
Then what do you want? Should they be routed out the remote PSTN or BT?



Yes exactly, in fact this summarizes my dialling out requirement, these numbers range routed through remote PSTN or BT. I have both BT and PSTN options available as I have ObiBT and ObiLine. But Bluetooth will be quick to setup for now as I have ordered a fixed GSM terminal generating dial tone which I will plug into ObiLINE later to make it more reliable. Can we make dial out using Bluetooth now and change to PSTN later ?

Quote

All other numbers except 510 routed out the LOCAL SP1 (GV). 
What is a 510 number and where should they be routed?
Is this a number or prefix?
Is this an OBi number?

Yes all other calls to be routed via SP1 starting with 001 lets say.
510 is prefix for ObiTalk, I believe that is only prefix for Obitalk ?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #55 on: February 17, 2015, 03:51:44 pm »

Local OBi Number: 510946xxx
Remote OBi Number: 510813xxx
Personal Mobile#: 056789xxxx

Local OBi:

Voice Services -> OBiTalk Service -> InboundCallRoute:
{510813xxx>(xx.):bt1},{ph}

Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
{+cc056789xxxx:aa},{ph}

Voice Services -> Auto Attendant -> DigitMap:
(x|[1-9]x|@@.S2)
Voice Services -> Auto Attendant -> OutboundCallRoute:
{(<510813xxx*>(0[2-9]xx.|0)):pp},{sp1}

Physical Interfaces -> Phone Port

DigitMap
(***|1xxxxxxxxxx|@@.S2)

OutboundCallRoute
{999:aa},{***:aa2},{(<510813xxx*>(0[2-9]xx.|0)):pp},{sp1}

Speed dials:
pp(510813xxx*0)                             Ring Remote phone
pp(510813xxx*02123456789)       BT/Line call
sp1(anything)                                   SP1 call

Remote OBi:

Voice Services -> SP1 Service -> InboundCallRoute:
{(1Local_GV#):aa},{ph}

Voice Services -> OBiTalk Service -> InboundCallRoute:
Route 02 thru 09 numbers to BT
{>(<0:>):ph},{bt1}
Route 02 thru 09 numbers to Line
{>(<0:>):ph},{li}

Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
pp(510946xxx*056789xxxx)

Voice Services -> Auto Attendant -> DigitMap:
(x|[1-9]x|@@.S2)
Voice Services -> Auto Attendant -> OutboundCallRoute:
Route 02 thru 09 numbers to BT
{0:ph},{(0[2-9]xx.):bt},{sp1}
Route 02 thru 09 numbers to Line
{0:ph},{(0[2-9]xx.):li},{sp1}

Physiscal Interfaces-> Line port -> InboundCallRoute:
pp(510946xxx*056789xxxx)

From local phone port dial:
999                       Local AA
0                           Ring remote phone
02123456789  Remote BT/Line call
Anything (except 02 thru 09)   Local SP1 call

From AA after calling BT with your mobile:
Reply 1 to ring remote phone
Otherwise reply 2 then dial:
02123456789  Remote BT/Line call
Anything (except 02 thru 09)   Local SP1 call

From AA after calling remote GV from Local GV:
Reply 1 to ring remote phone
Otherwise reply 2 then dial:
02123456789  Remote BT/Line call
Anything (except 02 thru 09)   Remote SP1 call


« Last Edit: July 08, 2015, 08:21:38 pm by azrobert » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #56 on: February 17, 2015, 03:53:17 pm »

Reply#55 is the current configuration.
Ignore all others.
The items in BOLD are changes from the config in Reply#48.
In the Remote OBi I gave you 2 options to route to BT or Line.
See the end of the post for the dialing rules.

When you dial 999 you are sent to the Local AA.
After you reply, the Local AA will send the correct dialed numbers to the Remote OBi.
It was easier to do it this way instead of sending 999 to the Remote AA because this was already setup for calls from your mobile.

Why do you want this function from the Local Phone when you can just dial the number without the AA?
You need the AA when you call in from your mobile, but not from the phone port.
Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #57 on: February 21, 2015, 12:27:14 pm »

Reply#55 is the current configuration.
Ignore all others.
The items in BOLD are changes from the config in Reply#48.
In the Remote OBi I gave you 2 options to route to BT or Line.
See the end of the post for the dialing rules.

When you dial 999 you are sent to the Local AA.
After you reply, the Local AA will send the correct dialed numbers to the Remote OBi.
It was easier to do it this way instead of sending 999 to the Remote AA because this was already setup for calls from your mobile.

Why do you want this function from the Local Phone when you can just dial the number without the AA?
You need the AA when you call in from your mobile, but not from the phone port.


Amazing  Grin    Thank you very much. It worked indeed i.e. I could use remote Mobile connected with remote Obi ..dialing out this way.

Three issues
1st issue is that call on remote connected cell isn't reaching local mobile. Also if I call local mobile connected with local Obi from my personal mobile isn't reaching local AA and it keeps on ringing.

2nd issue is that sometime both sides (GV-GV) can't hear each other. Earlier there was no such issue.

3rd issue is that Obi-Obi isn't working anymore. Instead GV speaks up that number can't be dialed.

I am thinking I should use ObiLine instead as ObiBT probably works for dialing out only and doesn't respond to calls directly on mobile which is connected to Obi. Do you think it will help? Another solution with ObiLine I am thinking about is CobraPhoneLink http://www.cobraphonelynx.com/, any advice on it?

I will connect PSTN line with ObiLine and will give it a try, will give my feedback today.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 4121


« Reply #58 on: February 21, 2015, 04:14:14 pm »

Quote
3rd issue is that Obi-Obi isn't working anymore. Instead GV speaks up that number can't be dialed.
My fault. I forgot to include dialing zero in the new configuration to ring the remote phone port.

Local OBi:
Voice Services -> Auto Attendant -> OutboundCallRoute:
{(<510813xxx*>(0[2-9]xx.|0)):pp},{sp1}

Physical Interfaces -> Phone Port
OutboundCallRoute
{999:aa},{***:aa2},{(<510813xxx*>(0[2-9]xx.|0)):pp},{sp1}

Quote
2nd issue is that sometime both sides (GV-GV) can't hear each other. Earlier there was no such issue.
This was a reported GV problem. I was experiencing the same problem, but it was fixed awhile ago. I can't help if you are still having the problem.

Quote
if I call local mobile connected with local Obi from my personal mobile isn't reaching local AA and it keeps on ringing.
Temporarily make the following change:
Local OBi:
Voice Services -> OBiBlueTooth1 -> InboundCallRoute:
ph

This is to make sure there isn't a syntax error in the BT inbound route code.
Call the cell attached to BT.
Does the local phone port ring?
If it doesn't, the call isn't getting to the OBi and I can't help you.

Quote
1st issue is that call on remote connected cell isn't reaching local mobile.
Not sure I understand. Is this calling the remote cell connected to BT and having the call routed to your personal cell via local BT?
Wasn't this working? Check the local call history to see if the call is routed out local BT.
Logged
realjohny
Jr. Member
**
Posts: 58


« Reply #59 on: March 21, 2015, 12:47:09 am »

Hi Azrobert,
I hope you are doing well Smiley
I had an accident and returning to this forum after some time.

I tried above but it didn't work so I gave up BT idea and plugged in the ObiLine instead with remote Obi200. Basically ObiLine is getting PSTN line from a GSM Fixed Wireless Terminal that generates a dial tone from a SIM card inserted and you can plug in a PSTN phone into it to dial out.

So basically through this Vodafone device I am getting dial tone and have plugged it into ObiLine. I have done configuration you suggested to either use BT or Obiline changing it to ObiLine only.

Below is what I see when I dial 999 and chose 2 and then the desired number below is what I get:

11:16:57 From AA1 To PP1(510813xxx*032xxxxxxxx) 
11:17:02  Call Ended (503 Service Unavailable)


Also incoming calls on that PSTN line (calling it PSTN as it generates tone but from GSM) are also not reaching locally.
Logged
Pages: 1 2 [3] 4
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement