December 14, 2017, 10:17:25 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Obi200 local dns wrong behavior  (Read 12908 times)
Gladdoo
Newbie
*
Posts: 2


« on: February 03, 2015, 06:13:59 pm »


I have running a voip.ms setup with local dns configured on a list of voip.ms server as a kind of failover if the obi cannot reach a specific registration server.

The local dns record in wan settings section of the obi200 is something like this:

myvoipms={67.205.74.179:5060,0},{72.55.168.18:5060,1},{67.205.74.187:5060,2}

Then i am using this name anywhere else in the voip.ms configuration of the obi. While this is working correctly if the router as wan access, it gives a very weird behavior if the router does not have internet access. The obi200 is retrying the provider server list, but after trying them could get stucked retrying address "0:0:0:0" forever after (which is not in the local dns record). Even after wan internet access is coming back, it seems there is no way for the obi200 to get out of this stuck situation without rebooting the unit.

Anybody ever get this problem?

obi firmware: 3.0.1 (Build: 4477)
Hard rev 1.4

Logged
Jackson
Full Member
***
Posts: 142


« Reply #1 on: February 07, 2015, 10:06:43 am »

Your post is a bit confusing. Are you using the IP addresses you posted and not the domain name?

From their wiki:

Quote
Use the IP address from the server instead of the domain name, example: Use 67.215.241.250 instead of losangeles.voip.ms. This item is recommended as diagnostic only, if this works for you, then it is probably a DNS issue affecting in your network, test using it for a couple of weeks and then change again to the domain name, it is not recommended to have the registration with the Ip all the time, VoIP.ms will redirect the domain to another IP in the case of a server issue, but this will not work for you if you are not using the domain.
Logged
Gladdoo
Newbie
*
Posts: 2


« Reply #2 on: March 07, 2015, 07:35:54 am »


This is a local dns record in the obi200. It is using a custom internal dnsname "myvoipms" which is replaced with one of the defined ip addresses in priority order from left to right:

67.205.74.179
72.55.168.18
67.205.74.187


So i am using direct ip addresses instead of public domain name, according to the wiki...
Logged
202Owner
Full Member
***
Posts: 104


« Reply #3 on: March 07, 2015, 01:02:50 pm »

I have running a voip.ms setup with local dns configured on a list of voip.ms server as a kind of failover if the obi cannot reach a specific registration server.

This is only to ensure failover for outbound calling, yes?

My approach was to register SP3 to the main account on an alternate server, and place SP3 in a trunk group for outbound failover, PH1 Primary Line = TG1 = sp1,sp3,sp4,pp1.  Fully explained in my OBi Dial Plan http://ozarkedge.mypressonline.com/index.htm.
Logged
Webslinger
Full Member
***
Posts: 103


« Reply #4 on: February 27, 2017, 08:14:47 pm »

I can reproduce this issue. The ATA is attempting to resolve myvoipms, in this example, which doesn't exist. That is, the Local DNS record is not being used. And then the ATA gets stuck in a loop trying to register with myvoipms (instead of what's listed in the local defined record) while internet access is absent.

Continuing to use the example provided by Gladdoo,

Under Service Providers-->ITSP Profile (voipms)--> SIP--> ProxyServer is set to myvoipms

Then, X_ProxyServerRedundancy is enabled.

When internet access has been established, the ATA still fails, in this example, to register with 67.205.74.179 until it's been made to reboot.

While this method of server failover may not be useful for VoIP.ms in general, it does make me wonder if there's a potential fix for local DNS not working properly when the ATA boots before internet access has been established. Imagine there's a general outage in your area. ISP goes down. Power goes down. Power comes back up. Internet access is still out. ATA starts trying to register with Proxyserver instead of what's listed in the Local DNS record over and over and over again. Internet access returns. ATA is still not able to register. Registration still fails repeatedly by trying to register with myvoipms (0.0.0.0). User is forced to reboot ATA. Finally, the ATA registers with 67.205.74.179. In this example, ProxyServerRedundancy is useful when a server goes down, but, otherwise, there appears to be an issue when the ATA has booted up initially without internet access.
« Last Edit: February 27, 2017, 11:07:02 pm by Webslinger » Logged
Webslinger
Full Member
***
Posts: 103


« Reply #5 on: October 16, 2017, 12:24:40 am »

myvoipms={67.205.74.179:5060,0},{72.55.168.18:5060,1},{67.205.74.187:5060,2}

A workaround would be to use montreal4.voip.ms={67.205.74.179:5060,0},{72.55.168.18:5060,1},{67.205.74.187:5060,2} for Local DNS record

Then set ProxyServer to montreal4.voip.ms since that is 67.205.74.179 and your first preference.

While you would need to eventually reboot the ATA to achieve what you want, at least registration wouldn't completely fail, provided montreal4.voip.ms is up and running, after the router finally obtains internet access.

« Last Edit: October 16, 2017, 12:02:14 pm by Webslinger » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC