Dial Plan for forcing international calls via SP2

Started by soccerfan, March 23, 2011, 12:08:28 PM

Previous topic - Next topic

soccerfan

New, inexperienced user (my first post).
I have set up my obi110 SP1 for Google Voice and SP2 for voip.ms.
I would like all international calls with prefix 011
(or 044 which forces voip.ms to use their premium routing)
to be placed by SP2 by default.

Is there any simpler way than prefixing **2 every time?
Thanks,
Edit: The various destination numbers after 011 (or 044) are between 10 and 15 digits long.

RonR

Assuming SP1/ITSPA is Google Voice and SP2/ITSPB is VoIP:

To make international calling automatically use SP2 with the primary line being SP1, it should only be necessary to modify the ITSPA DigitMap rule for international dialing [<**2>011xx.].

Suggested configuration:


ITSPA DigitMap:
(1xxxxxxxxxxS0|<1>[2-9]xxxxxxxxxS0|<1aaa>xxxxxxxS4|<**2>011xx.|xx.)


aaa = your local area code

soccerfan

Thanks RonR. This is exactly what I was looking for  :). One quick question though:
Can your suggested configuration also be entered from the obitalk.com web portal, and if so, how?
I have the latest software upgrade from today. Thanks again.

RonR

I don't use the OBiTALK Web Portal, so I can't answer that one.  If you do any configuration outside the OBiTALK Web Portal, it's usually a good idea to diable Provisioning in your OBi so the Web Portal doesn't overwrite your custom settings everytime you reboot.

jimates

@ soccerfan

As of today, you can do that with the Expert Settings from the Obitalk Portal. Prior to the Expert Settings you could only do it from the web interface. This makes remote configuration possible and a very nice feature.

soccerfan

#5
Thank you RonR and jimates. I got it to work by accessing the device web portal ;D
I also disabled auto-provisioning as RonR suggested. Now for two quick questions:

1. What should I add to the dial plan to also make the 044 prefix place calls via SP2
   (both 011 and 044 are prefixes for international numbers for voip.ms).
2. With auto-provisioning disabled, can I still make changes via the 'Expert Settings'
  of the obitalk portal (and will they stick)?
Thanks again for all your help.

RonR

Quote from: jimates on March 23, 2011, 01:56:11 PMAs of today, you can do that with the Expert Settings from the Obitalk Portal. Prior to the Expert Settings you could only do it from the web interface. This makes remote configuration possible and a very nice feature.
Unless I'm mistaken, the OBi Expert Configuration facility is also an all or nothing proposition.  If you make any changes to the OBi locally (manually) without remembering to manually make the same changes in the OBi Expert Configuration facility, your local changes will be wiped out the next time you reboot.

I can see some value to the OBi Expert Configuration facility if you have an OBi in a remote location with no other way to access it since the OBi doesn't support remote login's.  But for local (manual) configuration, I still fail to see why one wouldn't simply maintain it locally and be done with it.

RonR

soccerfan,

If you want 044 + number to also go out SP2 like 011 + number does:


ITSPA DigitMap:
(1xxxxxxxxxxS0|<1>[2-9]xxxxxxxxxS0|<1aaa>xxxxxxxS4|<**2>011xx.|<**2>044xx.|xx.)

ITSPB DigitMap:
(1xxxxxxxxxxS0|<1>[2-9]xxxxxxxxxS0|<1aaa>xxxxxxxS4|011xx.|044xx.|xx.)


soccerfan

Thanks RonR, I'm a happy camper now. Applied your suggested configs locally.
I'll try to play with the Expert Settings some other time. Regards. 

oleg

Hi RonR,
My understanding of DigitMap must be slightly different... I thought each ISTP DigitMap should be responsible only for own patterns... I believe such approach may be a bit easier to understand and maintain. See below... criticism very welcome!

I was solving similar task: GV on sp1 for US calls and voipstunt on sp2 for international calls.
I have the following setup:

ITSP A DigitMap
(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx)
This allows dialing US phone number in form 1-234-345-4567 or 234-345-4567. 10 digits number will be automatically prefixed with 1.

ITSP B DigitMap
(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|<011:>xx.|xx.)
This allows dialing US phone number, 011 prefixed international number or international number starting from country code (with theoretical risk of calling similar US number instead if digits match one of first two patterns, practically it does not happen - all international numbers I dial are longer than 10 digits). This rule removes 011 since provider takes this way.

PHONE Port DigitMap includes following rules (I show only relevant part of the map)
...|(Msp1)|(Msp2)|...
This allows dialing a number matching any of two maps above

PHONE Port OutboundCallRoute includes (again, only relevant part)
...,{(Msp1):sp1},{(Msp2):sp2},...
This routes call matching any of two maps above to the corresponding service.

---oleg

xray

oleg is right.  you don't want to mix <**2>011xx.|<**2>044xx. into ITSP A DigitMap.

Another suggestion:
Assuming SP1(GV) use for USA calls only, and SP2(sip service) for international calls only.
you don't even need 1xxxxxxxxxx|<1>[2-9]xxxxxxxxx| in ITSP B DigitMap.

TSP B digimap can just look like
(011xx.|044xx.)

RonR

My general philosophy is to leave the PHONE Port DigitMap and OutboundCallRoute unmodified.  They work closely together and it's easy to break things from there.  You started out saying "I thought each ISTP DigitMap should be responsible only for own patterns.", but you quickly strayed from your own goal.

Your approach reuqired a number of changes to two PHONE Port structures, is confusing to follow (and potentially breaks things).

My approach required one simple change to ITSPA: '<**2>'

oleg

Quote from: xray on March 23, 2011, 09:38:07 PM

TSP B digimap can just look like
(011xx.|044xx.)


I totally agree. But in my case I can use ITSP B for all calls, including US. I have to dial prefix **2 (not shown in OutboundCallRoute above) to force US call via sp2

---oleg

soccerfan

A follow-up problem:
I have set up the ITSP DigitMap  as suggested by RonR:

Quote from: RonR on March 23, 2011, 03:17:55 PM
If you want 044 + number to also go out SP2 like 011 + number does:

ITSPA DigitMap:
(1xxxxxxxxxxS0|<1>[2-9]xxxxxxxxxS0|<1aaa>xxxxxxxS4|<**2>011xx.|<**2>044xx.|xx.)

ITSPB DigitMap:
(1xxxxxxxxxxS0|<1>[2-9]xxxxxxxxxS0|<1aaa>xxxxxxxS4|011xx.|044xx.|xx.)


I wanted to see if I could still manually use **2 to force a local (7-digit) call via SP2.
Dialing **2 1-AAA-XXX-XXXX (or **2 AAA-XXX-XXXX) works fine, but that is not the issue.

However, when I dial **2 XXX-XXXX the obi110 reboots (tried several local numbers).
Any thoughts about why the device reboots? Thanks.

obi-support2

soccerfan,

I used the same digit map for my ITSP A & B, I have not been able to reproduce the reboot problem yet. The area code I used is 408. I have tried this on 1.1.0.1892 and 1.2.0.2101 (latest 1.1 and 1.2 releases respectively).

1. What is the f/w version you have on your OBi device?
2. Would you mind sharing your PHONE Port OutboundCallRoute as well?
    If you send this information to support@obihai.com if you prefer

Other forum members, please let me know if you can also reproduce same/similar problem
and how you make it happen. Thanks a lot.

   
OBIHAI Support Staff

soccerfan

Hello obi-support2, Thank you for chiming in.

I'm using area code 906.

Try, calling (local) 487-2532 aftersetting area code to 906,
(I don't think I'm giving anything away, hopefully)

In response to your queries:

1. Firmware version: How do I check, please?
The web portal shows 'Expert Configuration' at the bottom of the page
when I click on my name so, I guess, 1.2.0.2101 .
Please let me know how to confirm.

2. PHONE Port OutboundCallRoute, pasted from the obitalk.com website
(from Expert Configuration|  Gate| Physical Interfaces|PHONE):

{([1-9]x?*(Mpli)):pp},{(<#:>|911):li},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}


Auto provisioning is disabled. Thanks.