Obi100 -> Obi200 Issues

Started by tazmo8448, January 12, 2018, 08:27:30 PM

Previous topic - Next topic

tazmo8448

When I changed over from the 100 to the 200 (and we all know why) and using GV I noticed now that all my incoming calls are now showing UNKNOWN CALLER no matter if they are listed in my directory or not they're all UNKNOWN. BTW the numbers are showing but not WHO it is....grrr ..Importing in ObiExtras does nothing either.

What I did is hook up the new modem go to the Obi/GV setup basically all it was was swapping modems.

What causes all incoming calls to now be UNKNOWN CALLER?

tazmo8448

So far what I've done is go into my IP address (dial***1) and 'submit' the caller configuration that lists Physical Interfaces (Phone Port 1) we'll see if that is what was causing all calls to be UNKNOWN.

tazmo8448

Just tried to call myself from the cell phone that I use to set up GV & Obi200 and it shows ME as an UNKNOWN CALLER....for cryin' out loud

tazmo8448

One more thing concerning this....Google Voice DOES show the correct caller name & number in it's history...it just showed me calling myself (plus other incoming calls today are correctly labeled).

tazmo8448

Going to the IP address associated with the phone an Obi checking all the boxes that deal with incoming ID an all that and SUBMITTING them for configuration did nothing...just sayin`

tazmo8448

Tried importing my GV contacts to Obi that didn't work either.....grrr.

GPz1100

Does it show the number, but name is unknown or just unknown and nothing else?

tazmo8448

It DOES show the number and all names no matter if they're in the phones directory or known to GV ALL show UNKNOWN CALLER

tazmo8448

The thing that gets me is none of this happened with the Obi100 it was flawless....but swapping out with the Obi200

I'm seeing issues, plus, seeing issues all over the net with this model....Obihan remains quiet on responses. Looks like the money grab is biting them in the rear. Then again they've sold the product an maybe could care less now. I'm thinking it's a firmware setting as my phone has stored numbers...GV shows all the calls as to who it is...but something in the firmware is interfering.

GPz1100

I don't understand what you typed above, but be advised, gv does not provide caller id names, just the number. It's up to your device to match the number to a stored name.  If you want true cnam caller id either use simonics gateway, or forward your calls to a free call centric DID.  We use call centric because it offers further inbound call enhancement such as spam blocking (better than gv), ivr, and call treatments.

https://simonics.com/gw/
http://www.callcentric.com

Edit:  Nothing wrong the obi200.  Been using one for over a year with no issues.  Obi's hardware is great.  The issue is software and documentation.  It's a rather complex device with lots of capability.  Making it easy to use for non tech people is challenging.

tazmo8448

All I know at this point is Obi200 does not show names like Obi100 did...we HAD to buy the thing to continue service with GV as you know.

My phone connected to Obi has a Directory with all the saved names an numbers an somehow they're not being triggered.
GV shows all the names (and numbers of course) that I have associated and they show when I miss calls an also show in history.....just sayin'

I'm glad to hear you're happy and don't doubt that but telling me all is well doesn't cut any ice at this point. I do appreciate that you've taken an interest and are posting but you'd think the default settings would at least work as well as the previous Obi100 version did...it was just plug-n-play as far as that goes.

This is really a head scratcher to me.... ???

GPz1100

I never owned an obi1xx so no clue how it handled CID.  Call log in the obi200 indicates a leading 1 then 10 digits for the caller id.  If your phone's directory only has the 10 digits without the leading 1 this would explain the mismatch.  I don't believe there is a way to strip off the leading 1.  Maybe your phone can be configured to ignore it.

You will need to put in some effort to get this sorted unless you go with a system such as ooma or magic jack where both the hardware and software is a matched set designed to work as a system.


tazmo8448

I think you're on to something there....the 1-xxx-xxx-xxxx thing

Guess the thing is set up for international calls these days which knocks the bottom out of local calls...my phone won't even store the 1 before the area code & number...that truly is something that needs to be addressed as the majority of people only use phones for local or in-state calls...with the occasional 1-800 numbers.

tazmo8448

the link:
Look at post #5, https://www.obitalk.com/forum/index.php?topic=6045.0 .

deals with Obi100 settings..but someone found a code that scrubs the 1 off (or eliminates it)

THAT I believe is the answer....scrubbing that darned 1 off so it only lists area code & number.

Looking at the code used in Obi200 
{pli:(xx.)},{sp1:(<**1>xx.)},{sp2:(<**2>xx.)},{sp3:(<**3>xx.)},{sp4:(<**4>xx.)},{bt:(<**8>xx.)},{bt2:(<**82>xx.)},{pp:(<**9>xx.)}

this looks to be associated with the star code dialing.

The Obi100 CID Format looks like this an is explained from the link above........

Voice Services > SP1 Service > X_InboundCallRoute:
{(<1:>@@.):ph},{ph}

An incoming call with CallerID of 12345678912 will have the leading "1" removed before the CallerID is sent to the phone by the rule {(<1:>@@.):ph}.

An incoming call with CallerID of 2345678912 or any other CallerID not starting with "1" will be sent to the phone unchanged by the rule {ph}.


I believe that this is the key to the problem finding a way to remove the 1

tazmo8448

#15
I've tried all the resets an reboots (wishing against hope) BUT

incoming calls on Obi200 are still showing UNKNOWN even though I've changed them to show a 1 in front of the Area Code....

Incoming calls on Obi200 are going to have to have the 1 removed I'm afraid...to work correctly

looking at the caller ID Method listed it shows the default as
FSK(Bell202) with a drop down list for FSK(V.23) and several other countries.
don't see a code there to be able to insert scrubbing the 1 off.

the CidNoNameFormat lists three types
  Show Code O
  Show BLANK
  Show Caller Number
none of which show a way to be 'tweaked'

The only other reference to CID is a check box (under Calling Features)to enable which is enabled by default (no codes to tweak)

I think this is something the Obi Firmware will have to address

tazmo8448

I'm really starting to think that it all boils down to Obi now wanting people to have the Obi Extras deal so they can charge monthly fees to do the things that use to be included. #1 was having CID now it seems it's listed as an EXTRA
way to go Obi....squeeze that dollar.

GPz1100

What was your outcome after you added to the respective SPx slot?

Voice Services > SP1 Service > X_InboundCallRoute:
{(<1:>@@.):ph},{ph}

tazmo8448

Well I spent several hours looking in Voice Services seeing nothing that even resembles a code that can be 'tweaked'
there really isn't anything relating to that except check boxes and those don't have drop downs to look at or change.

...then looking at the advertising for Obi200 see that CID is offered as a paid service under 'Obi Extras'

of course none of this was said when they announced the end of Obi100 and that the new Obi200 would be a replacement because of the new Google Chrome update (that changed the code used) when and if the ticket I sent on the subject is answered I will report those findings....have a friend that just got the Obi200 also and his calls all show UNKOWN CALLER so I'm sure it's a PAID service now. Will check with dslreports an see what they have to say.

GPz1100

You're looking for X_InboundCallRoute in the path specified above.  That's the parameter name.  You modify its parameter to "{(<1:>@@.):ph},{ph}" (without the quotes).

Are you saying your obi1xx does not have this parameter?

You still haven't confirmed what called id number your phone actually shows, and if you have your stored numbers with or without the 1.  Can't help you further until these are clarified.