Add Device With Google Voice Configuration FAIL

Started by Randroid, March 08, 2020, 09:47:55 PM

Previous topic - Next topic

Randroid

Brand new OBi200 reports the following error when attempting to Add Device to OBiTALK:

Firmware upgrade needed.
Cannot upgrade (OBi No.) since it is offline. Please try again when it is online.


System Status reports software version 3.2.2 (Build: 5921EX)
Router Reports IP Address of 192.168.0.7
Power & Data LED's are steady green
Phone LED is not lit
SP1 shows Not Configured - Offline
Google Voice Setup reports the same error as above

It appears that this IS the latest firmware

What do I do now?





drgeoff

Does a call to the echo test number, **9 222 222 222, succeed?

Randroid

drgeoff,

Thanks for your reply
The test call fails also
"There is no service available to complete your call"

drgeoff

#3
I suspect that your OBi is not reaching the internet.

See pages 29 and 30 of https://www.obitalk.com/info/documents/admin_guide/OBiDeviceAdminGuide.pdf for what to dial to have the OBi read out to you what it thinks its various network settings are.

Randroid

drgeoff,

Thanks for your help on this

The star code announcements for Network Related Configuration Options:

DHCP Configuration = Enabled
IP Address = 192.168.0.7
Default Gateway = 192.168.0.1
Subnet Mask = 255.255.255.0
DNS Server (Primary) = 75.75.75.75
NTP Server (Primary) = pool.ntp.org

SteveInWA

Get into OBi "Expert configuration" mode, and go to System Management-->WAN settings, and edit the two DNS parameters.  Change their values to 8.8.8.8 and 8.8.4.4 respectively.  See the screenshot below.

Randroid

SteveInWA,

Thanks for your help on this

I re-configured the DNSServer 1 & 2  parameters to 8.8.8.8 & 8.8.4.4, and re-booted my router & the OBi200

I initiated the Google Voice Setup:

"Firmware upgrade needed. Cannot upgrade (OBi No.) since it is offline. Please try again when it is online"

Any other settings we should check on?


SteveInWA

Perform the ***1 test referenced by Geoff.  Do you get an IP address on your LAN, as you did before?  If so, what sort of thing is the OBi's LAN cable plugged into?  Do other devices plugged into that thing connect normally to a working Internet service?

Where did you purchase this OBi?  Something is fishy.  Did you make any manual modifications to its configuration?

Randroid

Steve,

Thanks for your knowledge and expertise...

***1 reports IP address of 192.168.0.7 and DHCP is enabled
***2 reports Primary DNS server is 8.8.8.8
***6 reports Software Update is not available
***01# reports software version is 3.2.2.5921

The OBi LAN cable is plugged DIRECTLY into my router (Arris SBG6782-AC cable gateway on Comcast Xfinity)

My Smart TV, desktop computers, and laptop all work perfectly fine on this router

I just got this OBi200 from Amazon on Sunday, brand new in the box

No other modifications to configuration have been made from the default settings that loaded when the device was added to OBiTalk

I am also going to try putting the OBi device into the DMZ to see if that changes anything

Please let me know if any checking any other settings might help


SteveInWA

Don't bother with the DMZ; it never helps.  OBi's work fine with Xfinity, with no modifications.

I am out of ideas, unless somebody else has one (assuming **9 222 222 222 still fails).

I'd suggest opening a support ticket:  https://www.obitalk.com/info/support/request-support

Randroid

Steve,

Still no phone, but THANK YOU for your time & effort

I'll open a support ticket

Thanks for the link!

Thanks Again,

Randroid

SteveInWA

No problem.  Please let us know the outcome, for future reference.

Randroid

Steve,

Obi Consumer Support confirmed that after adding this device,and getting a valid IP address, the unit remains offline, possibly due to the DNSServer 75.75.75.75 (Comcast/Xfinity) being firewalled.
They suggested using OpenDNS to avoid firewall blocking and to contact my ISP for further help

I continued my internet search for help getting this device connected, and happened upon a review that included "Configuring the Obi200"

https://www.whichvoip.com/reviews/obi200.php

This review explained how to Open the router ports used by Obihai (Port Forwarding) and also how to properly configure the WAN settings on the OBi200 device.

Followed the reviewer's instructions, rebooted the router & the OBi200, clicked on Google Voice Setup and... NO MORE ERROR MESSAGE

SUCCESS!

Thanks again for your help

Randroid