December 17, 2017, 07:43:03 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Inbound call routing issue: $1 not working  (Read 23653 times)
joshhighley
Newbie
*
Posts: 10


« on: March 30, 2011, 01:44:09 pm »

SP2 is configured with voip.ms, which I have termination and a DID.

I have this for the inbound call routing:
{ph,SP2($1 > 5555555555)}
where 5555555555 is my cell phone number.  I've also enabled X_SpoofCallerID.  According to the admin guide (pgs 113-114), $1 is supposed to represent the caller number of the inbound call.  My intention is to simultaneously ring my cell phone and have it show the number of the caller.  The issue is that my cell phone is showing "Unavailable Number".  **However**, if I change $1 to a number, such as 1111111111, then it will show up correctly on my cell phone when the call is forwarded.  So, it appears that $1 is not working correctly, or at least not as I understand it.

Am I mis-understanding $1, or should I submit a support ticket?

Logged
obi-support2
Administrator
****
Posts: 169


« Reply #1 on: March 30, 2011, 09:51:05 pm »

Can you try removing $1 >, that is just {ph,SP2(55555555555)}.

What is your obi's software version?

Thank you.
Logged

OBIHAI Support Staff
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #2 on: March 30, 2011, 10:47:41 pm »

joshhighley,

I was not able to get the caller number to pass using voip.ms. Best I could do was to pass caller name.

see thread:
http://www.obitalk.com/forum/index.php?topic=425.msg3134#msg3134


obi-support2,

What is "X_SpoofCallerID" supposed to spoof? Is there a way to get both Caller name and number to pass?
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
obi-support2
Administrator
****
Posts: 169


« Reply #3 on: March 31, 2011, 03:01:36 pm »

OBi passes both, name and number, from the original call, if X_SpoofCallerID is yes.
ITSP however might not take it, and may reject the call all together. That's why
this is option depending on your ITSP.

However, using the SP2(xyz > abc) syntax in an InboundCallRoute, it can only spoof the number; we currently don't have a syntax for spoofing a name this way.

Also, even when we spoof it, the ITSP can selectively take the name or number part as they please and present the call to the final destination.

You have more control if the "ITSP" is a PBX (like Asterisk) for example. I do not expect this option to be very useful for a general commercial ITSP.


Logged

OBIHAI Support Staff
joshhighley
Newbie
*
Posts: 10


« Reply #4 on: April 01, 2011, 02:21:43 pm »

when I removed the $1, the caller number was passed as I wanted.

For voip.ms users, note that I think you must clear out the caller id in their web configuration panel in the account settings (General tab I think) for them to accept the number from the obi.

Final issue is that when calling out, the caller number sent is the AuthUserName (6 digit id for voip.ms).  Is there anyway to set this? CallerIDName doesn't seem to do it.
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #5 on: April 01, 2011, 02:37:19 pm »

joshhighley

Hi

This is how I setup my outgoing CID number using Voip.ms. Find the "General Tab" here:

Main Menu>Account Settings>General.

See Image



Edit: The CID number from the Voip.ms General Tab works to replace/override the voipms DID # on the CID.


* Voip.ms Caller Number.JPG (122.71 KB, 1152x864 - viewed 1011 times.)
« Last Edit: May 27, 2011, 12:59:21 pm by QBZappy » Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #6 on: April 01, 2011, 04:02:19 pm »

joshhighley,

Hi
I don't know if we have exactly the same setup. I tried to reproduce your CID number senario.

Your original setup: (Your first example {ph,SP2($1 > 5555555555)} then you dropped the $1 correct?)
{ph,SPx(>5555555555)}

obi-support2 setup:
{ph,SPx(55555555555)}

Which one did you use?
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
joshhighley
Newbie
*
Posts: 10


« Reply #7 on: April 01, 2011, 07:49:23 pm »

QBZappy:  {ph,SP2(55555555555)}

obi-support:  my understanding from the voip.ms website was that if I populated the number on the General tab, then voip.ms would ignore any id coming from the obi.  However, I don't think I had enabled the spoof option before I tried it, so I'll give it another go.

Also, why didn't my use of $1 work?  The obi admin guide documentation makes it seem like it should have worked.
Logged
joshhighley
Newbie
*
Posts: 10


« Reply #8 on: April 01, 2011, 08:03:46 pm »

obi-support:  I put my number back in the voip.ms web panel configuration (General tab), but that seems to keep the obi from overriding the caller number with the inbound call routing rule discussed above.  I think my last resort may be to modify the outbound call routing to pass my caller number using (1111111111>sp2). 
Logged
joshhighley
Newbie
*
Posts: 10


« Reply #9 on: April 01, 2011, 08:43:10 pm »

I think I have it working like I want:  in order to get my caller number to appear on outbound calls, I had to modify the outbound call route for the phone port -- not very clean, but it seems to work.  I modified the **2 rule:

{(<**2:>(Msp2)):sp2(1112223333>)}

where 1112223333 is my phone number.  I tried putting $2 after the > but it then passed the **2 with the number I dialed, so I got a 'not a valid number' error message.  Per the admin guide on page 116, I think the **2 should have been removed from $2 by the rule.  Also, it says not putting the target after the > implies $2, but it obviously works differently when the $2 target isn't explicitly there (it doesn't pass the **2).

For completeness sake, to recap:

my inbound call route for SP2 is {ph,SP2(5555555555)} where 5555555555 is my cell phone that I want to ring simultaneously.  I removed the caller id from the voip.ms web panel General tab so that voip.ms would honor the 'from' number that the obi passes them.  Finally, I had to enable the option X_SpoofCallerId for SP2.

Based on my interpretation of the admin guide, I really think $1 and $2 are *not* working properly.
Logged
krpan
Newbie
*
Posts: 14


« Reply #10 on: May 27, 2011, 12:22:38 pm »

joshhighley: I came to the same conclusion, $1 and $2 are not interpreted as advertised (official admin guide p.113-114), but rather as literal values. In particular that was my conclusion based on various tests I did when used in InboundCallRoute.

See http://www.obitalk.com/forum/index.php?topic=853.msg5872#msg5872 for a tad more info with my experience.

I did not test it in OutboundCallRoute. My testing was done using OBi100 with the latest firmware as of 5/26/11 [1.2.1 (Build: 2286)]
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC