December 14, 2017, 07:13:56 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Aastra 6757i or 6755i setup with Obi202 and Google Talk  (Read 8037 times)
peterc
Newbie
*
Posts: 9


« on: January 09, 2015, 11:17:57 am »

First post!

I recently acquired an Obi202, and set it up with an analog phone and my Google Voice account. I LOVE the savings, and think this is a great product.

I am looking for a bit of assistance, setting up the Obi202 with my existing VOIP phones. These are Aastra 6757i and 6755i that I have been using on 8x8, but would appreciate not having to buy new phones.

Can anyone help with the configuration?

Thank you so much in advance!

Peter C.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #1 on: January 09, 2015, 12:05:07 pm »


Assumption: GV defined on SP1

 OBi202:
Service Providers -> ITSP Profile D  SIP -> ProxyServer : 127.0.0.1
Voice Services -> SP4 Service -> AuthUserName : OBi202
Voice Services -> SP4 Service -> AuthPassword : OBi202PW
Voice Services -> SP4 Service -> X_RegisterEnable : (unchecked)
Voice Services -> SP4 Service -> X_ServProvProfile : D
Voice Services -> SP4 Service -> X_Proxy: Checked 
Voice Services -> SP4 Service -> X_InboundCallRoute: {OBi202>(Msp1):sp1}

Voice Services -> SP1 Service -> X_InboundCallRoute:
ph,ph2,sp4(anything@192.168.1.110:5060;ui=$1),sp4(anything@192.168.1.111:5060;ui=$1)

Change 192.168.1.110:5060 and 192.168.1.111:5060 to the IP addresses and port of your phones.
This will route inbound calls to both OBi phone ports and both IP phones.
You can route inbound calls to 4 devices, so you are at the max.
This does not use SP4's definition or connection to the IP phone to route the call.
It uses SP4 to route the call to an IP address.

IP Phones:
Proxy: 192.168.1.100  (IP address of the OBi202)
Proxy Port: 5063     (X_UserAgentPort of OBi202 SP4 trunk)
UserID: OBi202
Password: OBi202PW

Both phones are defined the same.
I have registered 2 devices.
I don't know the max.
If you want different definitions, you can setup SP3.


Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #2 on: January 09, 2015, 02:59:27 pm »

I received your PM.
SP4 is setup as a Proxy.
You register the phones to SP4.
The only change to SP1 is to route inbound calls to the phones.
The SP1 change is not required for outbound calls.

I gave you the basic credentials for the IP phones.
Use the OBi202's IP address instead of a proxy name.
Port 5063 is the default port for SP4.
If you don't have a separate field for the port, code the proxy name like 192.168.1.100:5063

I do have an OBi1032 IP phone.
The basic configuration is exactly like an OBi ATA.
This is the only IP phone I've ever owned, so I can't help anymore than the above.
Maybe someone else can help.

I have a suggestion.
If you have a Windows computer install the Phonerlite softphone.
It's very easy to setup.
Get it to work with the OBi202.
This way you will know the OBi202 is setup correctly.

Download and install:
http://www.phoner.de/PhonerLiteSetup.exe
When you start Phonerlite I think wizard will popup because no accounts are defined.
Proxy: 192.168.1.100:5063
Click right arrow.
User Name: OBi202
Password OBi202PW
Click right arrow.
Change Profile Name: OBi202
Click check mark
You should have a green circle indicating you are registered.
Dial a number and click the green phone symbol.
Click red phone symbol to hang up.
Logged
peterc
Newbie
*
Posts: 9


« Reply #3 on: January 09, 2015, 03:42:32 pm »

Thanks.

I appreciate the help.

It took me a while to understand that you were referring to the expert configurations. Now it is still not right, but I have most of the settings. I think it might be in how I am setting up the phone. I will advise when I get it!

It's good to know that I can use the Aastra for both incoming and outgoing. That was a question!

As to the 1032, it looks like a great phone. My phone is basically the same, just not preset for easy configuration to OBi. I am still debating selling the phones I have, and buying a few of the 1032's. It's looking like I should be able to get this configuration right, so I don't need to spend the money. I know the 202 is working correctly, so that part is fine.

Thanks again for your help. More to follow!!
Logged
peterc
Newbie
*
Posts: 9


« Reply #4 on: January 09, 2015, 06:47:58 pm »

OK Guys!

First question - This may sound stupid, but--
>IP Phones:
Proxy: 192.168.1.100  (IP address of the OBi202)
Proxy Port: 5063     (X_UserAgentPort of OBi202 SP4 trunk)
UserID: OBi202
Password: OBi202PW
<

Should the UserID and Password be MY userid and password or OBi202 and OBi202PW?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #5 on: January 09, 2015, 07:58:42 pm »

UserID and Password must match the OBi202's AuthUserName and AuthPassword, so in the above example it would be OBi202 and OBi202PW. It is case sensitive.
Logged
peterc
Newbie
*
Posts: 9


« Reply #6 on: January 10, 2015, 06:25:31 am »

OK.

I will try this one screen at a time, until it is working!

SP1 Service Screen -- Three lines have red exclamation points. They are --

X_InboundCallRoute   !      *   help
X_UserAgentPort   !         help
AuthUserName   !      *   help

The InboundCallRoute - I cut and past exactly from above. As I am working on only one phone to start, this is what I put in...
ph,ph2,sp4(anything@192.168.1.110:5060;ui=$1)

I did change the IP to my phone's IP address. The port was left the same.

The UserAgentPort shows 5080, and the OBiTALK settings box is checked. I did not change this at all.

The AuthUserName shows my email address, which is my username. Again, the OBiTALK settings box is checked. I did not change this at all, either.

Am I missing anything on this screen?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #7 on: January 10, 2015, 07:49:47 am »

First, do the following. It will save you a couple of clicks.
From the OBiTalk dashboard click Edit Profile on the left column.
At the bottom of the page check "Enable Obi Expert..."
Click Submit Query.
Now you can go directly to OBi Expert from the dashboard.

Click Obi Dashboard.
On the right of your OBixxx is an icon with a red E.
Click on it to enter OBi Expert.

The red ! indicates the field was changed from the default.
If you don't see the correct value, uncheck the box under OBi Settings.
I don't know why some settings are displayed without unchecking the box.
Actually, I don't know why you have to uncheck some and not others.

GV wizard changes UserAgent and AuthUserName.

You are not missing anything, you only change the inbound route.

I'm curious. Did you get outbound working with the softphone?

Edit:
Can you have multiple accounts on your phone?
Each account should be assigned a different port number.
The port number in the InboundCallRoute must match the phone's account port.

« Last Edit: January 10, 2015, 08:02:51 am by azrobert » Logged
peterc
Newbie
*
Posts: 9


« Reply #8 on: January 12, 2015, 09:30:47 am »

There is no Red icon to the right of my OBIxxx.

The Aastra phone is not working inbound or outbound, but the OBi202 is working in/out to another analog phone.

I am only looking to have one account on the phone.

I have tried contacting Aastra support, and they claim to know nothing of the OBi202, but they are trying to help. I also tried support here, and was told that maybe a Forum Member could help. That being said, any help here is greatly appreciated.

Here are all possible configurations on the phone -

Once in the administrator menu, reset to factory defaults.
Next are the following menu and sub-menus -  

1. Configuration Server

1.1. Download Protocol

1.2. TFTP Settings

1.2.1. Primary Server
1.2.2. Primary Path
1.2.3. Alternate Server
1.2.4. Alternate Path
1.2.5. Select PTFTP

1.3. FTP Settings

1.3.1. Server
1.3.2. Path
1.3.3. Username
1.3.4. Password

1.4. HTTP Settings

1.4.1. Server
1.4.2. Path
1.4.3. Port

1.5. HTTPS Settings

1.5.1. Server
1.5.2. Path
1.5.3. Port
1.5.4. Client Method
1.5.5. Cert Validation

2. Network Settings

2.1 DHCP Settings

2.1.1. DHCP
2.1.2. DHCP User Class
2.1.3. Download Options

2.2. IP Address
2.3. Subnet Mask
2.4. Gateway
2.5. DNS
2.6. Hostname
2.7. NAT Settings
2.8. Type of Service DSC
2.9. Ethernet & VLAN

3. Sip Settings

3.1. Proxy IP/Port
3.2. Registrar IP/Port
3.3. User Name
3.4. Display Name
3.5. Screen Name
3.6. Authentication Name
3.7. Password
3.8. RTP Port Base

The next two do not apply, as they are 4. Factory Default, and 5. Erase all Local Config.

Thanks again Robert.
« Last Edit: January 14, 2015, 12:03:05 pm by peterc » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #9 on: January 12, 2015, 10:39:34 am »

Quote
There is no Red icon to the right of my OBIxxx.

Did you do:
From the OBiTalk dashboard click Edit Profile on the left column.
At the bottom of the page check "Enable Obi Expert..."
Click Submit Query.

It's to the right of the gear ICON.
It's another gear ICON with a red E in the center.

Like I said previously, I'm not an IP phone expert.
If I miss something, anybody please chime in.

The phone with the defaults should connect to the router and an IP address should be assigned to it.
If you are getting an IP address assigned I think you only need to change the SIP settings.

3.1. Proxy IP/Port: xx.xx.xx.xx (IP address of OBi)
3.2. Registrar IP/Port: 5063  (X_UserAgentPort of SP4)
3.3. User Name: OBi202
3.4. Display Name: anything
3.5. Screen Name: anything
3.6. Authentication Name: Blank or OBi202
3.7. Password: OBi202PW
3.8. RTP Port Base: Should have a default value. 

Is the IP phone registering to SP4?

I assume you used the phone with another provider.
How was it configured?
Logged
peterc
Newbie
*
Posts: 9


« Reply #10 on: January 22, 2015, 08:34:57 am »

That's it. I quit. It is taking more time than the cost of a new phone.

I will buy a 1062 when they come out.

Thanks for trying.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3199


« Reply #11 on: January 22, 2015, 09:14:38 am »

I wonder if there is a parm that you have wrong that prevents the phone from registering with the OBi202.  I don't know if you want to spend a little more time, but this setup will work if your phones can dial out without registration. Turn off registration in the phone and uncheck X_Proxy in the OBi202. Everything else stays the same.

I forgot to ask, but are the OBi202 and the phones on the same LAN? If not you will need to use port forwarding in your router for both registered and unregistered methods.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC