RESOLVED ! Unable to dial out of PSTN line from a remote Obi throuh AA

Started by Obitalk, March 12, 2011, 09:10:22 AM

Previous topic - Next topic

Obitalk

Can someone provide be he;lp is troubleshooting the following issue:

I'm placing a call from a US based Obi device to a Remote Obi device in a different country.

I initiate the call via **9 and the obi device number
I receive the automated attendent and press 2 and then followed by **8 and the PSTN number
I hear the tone of Obi trying to initiate the call (ie. ringing tone)
But the call never completes.

In order to troubleshoot:
I requested someone at the remote location to pickup the phone of the remote obi device and dial **8 and the PSTN number
The person is able to successfully place the call

What would be the issue in dialing the remote obi from US and completing the PSTN call out of the remote Obi device in remote country.

Any help would be appreciated.

QBZappy

Hi,

It would help pinpoint problem if you show your OBiTALK InboundCallRoute
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

Obitalk

Thank you QBZappy

Here is my ObiTalkInBoundCallRoute

{(290700000|200111222|200222333)>(xx.):SP1},{(290700000|200111222|200222333):aa},{ph}

MichiganTelephone

Question:  Did you configure both devices using the OBiTALK portal or did you configure them manually?  If you configured the remote unit manually, then what you may need to do is go to the remote unit's Voice Services, Auto Attendant menu and check these things (these are probably NOT the problem, but just to be sure):

  • Is the default checkbox still checked for DigitMap?
  • Is the default checkbox still checked for OutboundCallRoute?
One thing I'm thinking might be an issue is if you are calling numbers that do not share NANP dial patterns.  By default the OBi assumes a NANP (USA/Canada) dial pattern.  So when you dial a number, it might not be sending the digits to the PSTN port that you think it is.  A way to check that would be to look at the Call History (under the status section) and look to see if you can find the failed calls.  See if the numbers it called were the actual numbers you dialed.  You might find that it chopped off some digits or something.

If it's the latter problem I'm not sure offhand which pattern would have to be modified to fix it, but I'll wait for your response before I say any more.  It might be helpful, though, to see an actual example of a number you're trying to call (**8 and then what? You can replace the last few digits with X's) and also what actually appeared in the call history.
Inactive, no longer posting or responding to messages.  Goodbye and good luck.  Some of my old Obihai-related blog posts have been moved to http://tech.iprock.com - note this in NOT my blog; I have simply given the owner permission to repost some of my old stuff.

QBZappy

Obitalk,

Your complete configuration is not clear from your post. I will try to guide you assuming a simple configuration setup. If you keep it simple and only have the Pots line and the OBi service at the far end. You should set Outbound Settings->Attendant PrimaryLine=PSTN line. Set as the primary line you will not need to press **8 to dial out from the AA. You hear the ringing tone. Gives the impression the call is going through. This setup will at least simplify the trouble shooting by giving you the ability to direct dial after you get past the AA. What country is the far end OBi located in?

Look in the Setup Wizard section of the OBi unit:
What is your "Outbound Settings->Attendant PrimaryLine" setting?

{290381063>(xx.):sp2},{(290381063|200883755):aa},{ph}  <-- Is the setting of the OBi at the far end?

What is the digitmap of the far end OBi "Physical Interfaces->LINE Port->DigitMap" ? Configure this into a format which makes sense in the region where the far end OBi is located.

Let us know you results.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

Obitalk

Thanks for the input MichiganTelephone,

I configured both devices using the OBiTALK portal.
DitiMap default is still checked
OutboundCallRoute default is still checked
The remote destination I'm trying to dial is Sri Lanka

These are the two different logs:

This is the call history when the person tried dialling the phone using **8 (The call was successful)

Terminal ID PHONE1 LINE1
Peer Name   
Peer Number **80776512345 0776512345
Direction Outbound Outbound
07:41:13 New Call 
07:41:18  Call Connected
07:41:39 End Call

This is the log when I dial through the auto attendant:

Terminal ID AA1 LINE1
Peer Name   
Peer Number 0771234567 0771234567
Direction Outbound Outbound
08:39:09 New Call 
08:39:14  Call Connected
08:39:14 New Peer: P2P1:Name=USLINE#1     Number=200123456 Transfer Target
08:40:00 End Call

The call log although says connected, on the second example, I'm still not able to connect.

===============================================================================

Thanks for the input QBZappy,

I took the advice and made the changes though OBiTALK portal.

Now the Autoattendant Primary Line is set to PSTN Line

I'm trying to dial Sri Lanka (The phone number is 7 digits long)

But in this particular instance for testing purpose I'm trying to dial a mobile number and it needs to be prefixed by a 0 then followed by 776512345

So I'm dialling 0776512345 after pressing 2 when the AA answers

Look in the Setup Wizard section of the OBi unit:
What is your "Outbound Settings->Attendant PrimaryLine" setting? This is set to PSTN Line

{(290712345|200512345|200212345)>(xx.):LI},{(290712345|200512345|200212345):aa},{ph}

What is the digitmap of the far end OBi "Physical Interfaces->LINE Port->DigitMap" ? The digitmap is as follows: (xxxxxxxS4|1xxxxxxxxxx|xx.)

===================================================================================

I still haven't had any luck connecting via the line port using AA

RonR

You show the peer number on the AA1 log entry as being different from the PHONE1 log entry.  Are they actually different or was that accidental in your effort to obscure the real number?

RonR

I just spotted something fishy in two Auto Attendant default settings.


Go to:

Voice Services -> Auto Attendant -> DigitMap

and uncheck default.  Then delete this part at the beginning of the line:

[1-9]x?*(Mpli)|

Go to:

Voice Services -> Auto Attendant -> OutboundCallRoute

and uncheck default.  Then delete this part at the beginning of the line:

{([1-9]x?*(Mpli)):pp},


Then try your call via the Auto Attendant.

MichiganTelephone

I understand that you've obscured the actual numbers here, but in order for the test to be valid you must try calling the same number that was successfully called from the phone port.  Otherwise you may run into a situation where the one number works fine and the other one won't go through, and that's the problem.

Other than that, it sure looks like it's actually calling the number you dialed. So my suspicion is that the problem may be with the called number, not with the way the device is routing the call.  Try calling two or three different numbers, preferably one or two different landlines and one or two different mobiles.  If the issue isn't with the called number, then I'm stumped.
Inactive, no longer posting or responding to messages.  Goodbye and good luck.  Some of my old Obihai-related blog posts have been moved to http://tech.iprock.com - note this in NOT my blog; I have simply given the owner permission to repost some of my old stuff.

QBZappy

Obitalk,

1) improve your "Physical Interfaces->LINE Port->DigitMap" (Digitmap for calls made on this trunk Mli)

Current setting=(xxxxxxxS4|1xxxxxxxxxx|xx.)
Consider setting=(77xxx xxxxS4|077xxx xxxxS4|xx.)  <--(Not sure if you want other area codes in the dial plan)

Explanation:
7 digit phone number with 2 digit (landline calls) or 3 digit (cellular calls) area code.
I placed what I am just assuming the more general user dialing senario first on the left (you reverse this if cell calling is more common). Next the 3 digit cellular dial plan. Then a general dial plan to catch everthing else.



2) For ease of use, consider placing frequently called numbers in the speed dial. After AA picks up you would just press "speed dial number+#"
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

RonR

QBZappy,

Those changes won't fix the current problem as the existing DigitMap ultimately lets anything through with the 'xx.' rule at the end.  While there may be optimizations that can be done later to accommodate the non-US dialing formats and to speed things up, it's a bad idea to be making unnecessary changes when something is not working and you're trying to get to the root cause.  If you accidentally introduce new problems before you find and fix the old ones, it just makes the job harder.

Assuming Obitalk has the same corruption in his Auto Attendant DigitMap and OutboundCallRoute that I'm seeing in mine, I think the problem is that calls from the Auto Attendant are being routed out the OBiTALK port instead of the LINE port (hence no call completion).  I didn't notice the corruption right away as I use custom DigitMap's and CallRoute's instead of the defaults.

QBZappy

RonR,

Hi, Don't you sleep? :D

I was scratching my head wondering where you were getting those values.  It did not match up with my default values for the settings you were describing. My values where not corrupted.

It might be a good time to introduce an idea where people with issues could provide some basic info about their OBi configurations according to some template design. This designed form should be a sticky where everyone can refer to it. (Please post your question in the following format) This would make the process of trouble shooting more efficient without resorting to the back and forth. What do you think would be the minimum info you would like to see to get a big picture.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

RonR

QBZappy,

My guess is Obihai introduced this problem in the non-Gmail account beta release that I and a number of others received.  Did you not request nor receive this particular update?  If Obitalk doesn't have the corrupted (or whatever they are) Auto Attendant entries then the mystery may still not be solved.

jimates

I wanted to compare the maps in the two firmware versions but I can't access my #2 obi's web interface. I get an xml error message

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.
--------------------------------------------------------------------------------
The stylesheet does not contain a document element. The stylesheet may be empty, or it may not be a well-formed XML documen...


This is what I have on my beta version, which is what Ron has.
DigitMap
([1-9]x?*(Mpli)|[1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**9(Mpp))
OutboundCallRoute
{([1-9]x?*(Mpli)):pp},{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**9:>(Mpp)):pp}


QBZappy, post yours from the standard FW

QBZappy

Default setting on my OBi: SoftwareVersion=   1.1.0 (Build: 1892)

Voice Services->Auto Attendant->DigitMap=

([1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp))

Voice Services->Auto Attendant->OutboundCallRoute =

{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp}

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

MichiganTelephone

From SoftwareVersion   1.1.0 (Build: 1892), these are the default settings on my devices:

Voice Services -> Auto Attendant -> DigitMap
OBi110:
([1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp))
OBi100:
([1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**9(Mpp))

Voice Services -> Auto Attendant -> OutboundCallRoute
OBi110:
{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp}
OBi100:
{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**9:>(Mpp)):pp}
Inactive, no longer posting or responding to messages.  Goodbye and good luck.  Some of my old Obihai-related blog posts have been moved to http://tech.iprock.com - note this in NOT my blog; I have simply given the owner permission to repost some of my old stuff.

jimates

He probably doesn't have the beta fw so it shouldn't need editing.

I don't know why they would need to be different anyways.

DigitMap
1.1.0
([1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp))
beta
([1-9]x?*(Mpli)|[1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**9(Mpp))

OutboundCallRoute
1.1.0
{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp}
beta
{([1-9]x?*(Mpli)):pp},{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**9:>(Mpp)):pp}

I notice there is no rule for **8 in the beta.

QBZappy

jimates,

Default settings: SoftwareVersion=1.1.0 (Build: 1892)

Physical Interfaces->PHONE Port->DigitMap->=

([1-9]|[1-9][0-9]|911|**0|***|#|(Mpli)|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp))


Physical Interfaces->PHONE Port->OutboundCallRoute->=

{(<#:>|911):li},{**0:aa},{***:aa2},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp}
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

RonR

Quote from: jimates on March 13, 2011, 03:29:18 PMI changed my settings on the Phone Port. I noticed no difference, there is still a 20 second delay in the outgoing call.
Let's move the discussion of dialing delays to:

http://www.obitalk.com/forum/index.php?topic=337.0

and keep this thread on topic to Obitalk's problem.

Obitalk

Thanks for input RonR, MichiganTelephone, QBZappy and Jimates

My auto attendant digit map is as follows:

([1-9]|[1-9][0-9]|<00:$1>|0|(Mpli)|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp))

And my outbound call route is as follows:

{0:ph},{(Mpli):pli},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp}

So I guess this mean I don't need to change anything correct ?

I have made a little bit of progress. (The changes that were incorporated were the one suggested by QBZappy so that I don't have to dial **8 and just dial directly)

When I try dialling out of the auto attendant at the remote obi, the phone number that I dialled rings and also had the correct caller id. But I cannot hear the voice at the other end nor I cannot hear them either. Also the call gets disconnected and I get back the dial tone.

Any suggestions would be appreciated.

Thanks