Caller ID Forwarding

Started by Hadi, March 20, 2014, 02:02:54 PM

Previous topic - Next topic

Hadi

Hello,

I have two obi110 devices. One is in my home (obi1) and the second one is in my office (obi2).
My landline (PSTN) connected to the obi1 and when someone called my landline number it transfers to my obi2. Is there any way to forward the original caller's Caller ID to my obi2? Right now the obi2 just shows the obi1 number.

Thanks






azrobert

On OBi1
Change Line Port -> InboundCallRoute to:
{ph,pp(ob200222222)}

ob200222222 is your OBi2's OBi number.


Hadi

#2

 Thanks Azrobert for answering but I don't have any problem to transfer. So far all my callings can transfer to OBI2. The problem is the caller ID on OBi2 does not show the original caller's caller ID. It just shows the 200111111.

200111111 is my OBi1's OBi number.

QBZappy

@Hadi,

Here is something azrobert wrote which may help you. You can find it in my Bookmark thread. CID spoofing is what you need. You may want to use an ip address instead of the OBi unit tel number for this to work. Have a look.

http://www.obitalk.com/forum/index.php?topic=7352.msg47664#msg47664

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

azrobert

#4
I have 2 OBi110s and my setup transfers the CID correctly using the OBiTalk network. I assumed you were using an SP trunk to transfer the call to the other OBi110. Are you transferring the call the same as I suggested?

Edit:

Can you tell me what services you have defined on the SP1 and SP2  on the work OBi110?

Hadi

#5
Quote from: QBZappy on March 22, 2014, 02:48:40 PM
@Hadi,

Here is something azrobert wrote which may help you. You can find it in my Bookmark thread. CID spoofing is what you need. You may want to use an ip address instead of the OBi unit tel number for this to work. Have a look.

http://www.obitalk.com/forum/index.php?topic=7352.msg47664#msg47664



Thanks QBZappy. I saw this post before posting my question but I don't use any SIP.

Hadi

#6

Quote from: azrobert on March 22, 2014, 03:05:16 PM
I have 2 OBi110s and my setup transfers the CID correctly using the OBiTalk network. I assumed you were using an SP trunk to transfer the call to the other OBi110. Are you transferring the call the same as I suggested?

Edit:

Can you tell me what services you have defined on the SP1 and SP2  on the work OBi110?

I don't use any SIP or Google voice. It is very simple:

POTS→Obi1→Obi2.  

So when anyone calls my local phone, it transfers to OBi2 but the caller ID on the OBi2 shows OBi1's number.  


QBZappy

Obi1->OBi2 can be bridged using any of the supported voice services. Sip, obitalk, pots, GV. Odd that oboi to obi fails the cid. First, try using the ui=$1 snippet at the end of the code azrobert mentioned. If that does not work the obi2 can receive using sip. There is no need to have a 3rd party sip service for this approach.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

azrobert

I don't understand why you don't get the correct CID. Like I said, mine works.

Anyway, you can try the following.
Get a free Sip2Sip account here:
https://mdns.sipthor.net/register_sip_account.phtml

On OBi2 register one of the SP trunks to your Sip2Sip account.

Service Provider -> ITSP Profile A or B -> SIP
ProxyServer: sip2sip.info
X_DnsSrvAutoPrefix: Enabled (checked)

Voice Services -> SP1/2 Service
AuthUserName: YourSip2SipID
AuthPassword: YourSip2SipPassword

On OBi1
Change Line Port -> InboundCallRoute to:
{ph,sp2(YourSip2SipID@sip2sip.info.com;ui=$1)}

azrobert

Quote from: QBZappy on March 23, 2014, 08:27:15 AM
the obi2 can receive using sip. There is no need to have a 3rd party sip service for this approach.

This is true, but there are audio problems that have to be fixed using this method.
You have to Port Forward the User Agent and RTP ports.   
When both OBi's are on the same LAN X_DiscoverPublicAddress must be disabled.
I don't remember what or if anything else has to be done when the OBi's are on different LANs.
That is why I didn't recommend this method.

If anyone knows, please chime in.


Hadi

Quote from: QBZappy on March 23, 2014, 08:27:15 AM
Obi1->OBi2 can be bridged using any of the supported voice services. Sip, obitalk, pots, GV. Odd that oboi to obi fails the cid. First, try using the ui=$1 snippet at the end of the code azrobert mentioned. If that does not work the obi2 can receive using sip. There is no need to have a 3rd party sip service for this approach.

As I told before I was succeed to bridge OBi1 and OBi2. but I didn't get the correct CID on OBi2. the CID on OBi2 just shows OBi1's number . I added ui=$1:

Changed Line Port -> InboundCallRoute to:
{ph,pp(ob200222222;ui=$1)}

After adding this, none of my callings from pots on OBi1 did not transfer to OBi2. So it didn't work for me.

Hadi

Quote from: azrobert on March 23, 2014, 08:29:13 AM
I don't understand why you don't get the correct CID. Like I said, mine works.

Anyway, you can try the following.
Get a free Sip2Sip account here:
https://mdns.sipthor.net/register_sip_account.phtml

On OBi2 register one of the SP trunks to your Sip2Sip account.

Service Provider -> ITSP Profile A or B -> SIP
ProxyServer: sip2sip.info
X_DnsSrvAutoPrefix: Enabled (checked)

Voice Services -> SP1/2 Service
AuthUserName: YourSip2SipID
AuthPassword: YourSip2SipPassword

On OBi1
Change Line Port -> InboundCallRoute to:
{ph,sp2(YourSip2SipID@sip2sip.info.com;ui=$1)}


I have two free accounts from callcentric so on OBi2:

Service Provider -> ITSP Profile A -> SIP
ProxyServer: callcentric.com
X_DnsSrvAutoPrefix: Enabled (checked)

Voice Services -> SP1 Service
AuthUserName: MycallcentricID
AuthPassword: MycallcentricPassword

On OBi1
Change Line Port -> InboundCallRoute to:
{ph,sp1(MycallcentricID@callcentric.com;ui=$1)}

Again any calling on OBi1 from POTS can transfer to OBi2 but the CID on OBi2 shows my idnumber and my name callcentric which I used on OBi1.

azrobert

Make this change:
On OBi1
Change Line Port -> InboundCallRoute to:
{ph,sp1(MycallcentricID@in.callcentric.com;ui=$1)}

The difference is in.callcentric.com.

Hadi

Quote from: azrobert on March 24, 2014, 11:16:16 AM
Make this change:
On OBi1
Change Line Port -> InboundCallRoute to:
{ph,sp1(MycallcentricID@in.callcentric.com;ui=$1)}

The difference is in.callcentric.com.


First time  I used this but it didn't work even it couldn't transfer on OBi2. I saw this:
http://www.callcentric.com/faq/11/244 and I figured out It does not need to use in.callcentric.com because both SPs on OBi1 and OBi2 are coming from callcentric. Am I right?

azrobert

You must have a Callcentric account defined on OBi#1 SP1. Correct?

When you use callcentric.com you are making a Callcentric#1 on OBi#1 to Callcentric#2 on OBi#2 call. When you do this OBi#2 will receive the account# of Callcentric#1 as the CallerID.

When you use in.callcentric.com you are making an OBi to Callcentric#2 call and should get the number in the ui=$1 as CallerID. $1 is an OBi variable that contains the inbound CallerID.

Did you try in.callcentric.com and it failed?

Hadi

#15
Yes I have two callcentric accounts. First one  defined on OBi#1 SP1 and second one is on OBi2 SP1.

Yes that's right hence OBI2 received the account# of Callcentric#1 as the CallerID with or without adding ui=$1.

I tried in.callcenteric.com but no call transferred to OBi2.


Edit:
I changed callcenteric.com to in.callcenteric.com again and OBi2 received all calling from OBi1 but CID didn't show any number (even account# of callcenteric#1)

azrobert

Sign into your Callcentric#2 account.
At the bottom right side of the screen there is a list of inbound calls.
Does it show the correct CallerID?

Hadi


azrobert

If you are not using SP2, define a dummy trunk on it like this:
Service Providers -> ITSP Profile B -> SIP -> ProxyServer : 127.0.0.1
Service Providers -> ITSP Profile B -> SIP -> X_SpoofCallerID: Enabled (Checked)
Voice Services -> SP2 Service -> AuthUserName : (any userid)
Voice Services -> SP2 Service -> X_RegisterEnable : (unchecked)
Voice Services -> SP2 Service -> X_ServProvProfile : B

And this:
Line Port -> InboundCallRoute:
{ph,sp2(MycallcentricID@in.callcentric.com)}

Enabling SpoofCallerID does the same as ui=$1
I might give up if this doesn't work.

Hadi

#19
On OBi1 I changed all things that you said but when I removed ui=$1, all calls could not transfer to OBi2 when I added ui=$1, they could transfer without CID. Anyway thanks for your time and your help.