800 calling through SipBroker (via CallCentric)

Started by tome, September 04, 2011, 08:28:21 AM

Previous topic - Next topic

tome

I had read that it was possible to dial 800 numbers (i.e., 800-555-1212) through SipBroker with CallCentric.  I have the digit map **275*x. which is supposed to get me to SipBroker.  If I pick up the phone and dial **275*18005551212 I get a fast busy.  Do I have to set something up on my Obi to access SipBroker (besides the digit map)?

If I dial it directly from CallCentric **218005551212 I am told it is a special services number and not reachable from CallCentric.  What am I doing wrong?

Tom

RonR

Quote from: tome on September 04, 2011, 08:28:21 AM
I had read that it was possible to dial 800 numbers (i.e., 800-555-1212) through SipBroker with CallCentric.  I have the digit map **275*x. which is supposed to get me to SipBroker.  If I pick up the phone and dial **275*18005551212 I get a fast busy.  Do I have to set something up on my Obi to access SipBroker (besides the digit map)?

I believe you have SP1 set as your PrimaryLine.

When you dial **275*18005551212, you're trying to send 75*18005551212 to Callcentric, which isn't allowed by any of your ITSP Profile B DigitMap rules and wouldn't be accepted by Callcentric anyway.

Since the Callcentric format to make a SIP Broker call is **275* + number, you need to dial **2**275*18005551212.

Quote from: tome on September 04, 2011, 08:28:21 AM
If I dial it directly from CallCentric **218005551212 I am told it is a special services number and not reachable from CallCentric.  What am I doing wrong?

That's a Callcentric issue and has nothing to do with the OBi.

tome

Quote from: RonR on September 04, 2011, 09:59:17 AM

I believe you have SP1 set as your PrimaryLine.

When you dial **275*18005551212, you're trying to send 75*18005551212 to Callcentric, which isn't allowed by any of your ITSP Profile B DigitMap rules and wouldn't be accepted by Callcentric anyway.

Since the Callcentric format to make a SIP Broker call is **275* + number, you need to dial **2**275*18005551212.

Yes, I have Sp1 as Primary (GV).  When I dial your way I get "The number you dialed **2**275... was rejected by the service provider.  Reason 503"

Also, what is the point of having **275*x. in the digit map if I am just force dialing the number to SP2 anyway?

Tom


RonR

When you dial **2**275*18005551212, what is shown as being sent to SP2 in your Call History?

The OBi uses the concept of having a PrimaryLine where all calls go by default.  If you want to use an alternate trunk, you must specify that trunk using **n.  It's possible to come up with an SP1 DigitMap that will detect sequences like **275*xx. and automatically redirect them to SP2.  For example, many users have US calls go out Google Voice (SP1) by default and international calls go out VoIP (SP2) by default, but you have to configure your PrimaryLine DigitMap in order for this to occur.

tome

Quote from: RonR on September 04, 2011, 10:14:25 AM
When you dial **2**275*18005551212, what is shown as being sent to SP2 in your Call History?

See attatchment.

Quote from: RonR on September 04, 2011, 10:14:25 AM
The OBi uses the concept of having a PrimaryLine where all calls go by default.  If you want to use an alternate trunk, you must specify that trunk using **n.  It's possible to come up with an SP1 DigitMap that will detect sequences like **275*xx. and automatically redirect them to SP2.  For example, many users have US calls go out Google Voice (SP1) by default and international calls go out VoIP (SP2) by default, but you have to configure your PrimaryLine DigitMap in order for this to occur.

Ok, I see.  This isn't really critical, but I have heard that GV will not complete some 800 numbers so I was toying with the idea of using CallCentric.  If I do get it to work on CallCentric I will play with the SP1 Digit Map.

Tom

RonR

Sip Broker isn't currently accessing 18005551212.  Try another 800 number such as **2**275*18003472683.

tome

Quote from: RonR on September 04, 2011, 10:40:03 AM
Sip Broker isn't currently accessing 18005551212.  Try another 800 number such as **2**275*18003472683.

Cool, I got Discover.  Why wouldn't SIP Broker be able to access that (or any) 800 number?
And thanks!
-Tom

RonR

Quote from: tome on September 04, 2011, 10:24:37 AM
This isn't really critical, but I have heard that GV will not complete some 800 numbers so I was toying with the idea of using CallCentric.

I have a Voice Gateway set up that handles all my toll-free calling using a SIP URI to IdeaSip (who welcomes toll-free calls from anyone).

Quote from: tome on September 04, 2011, 10:43:12 AM
Why wouldn't SIP Broker be able to access that (or any) 800 number?

The same reason Google Voice won't complete some 800 numbers.  ???

tome

Quote from: RonR on September 04, 2011, 10:50:36 AM
I have a Voice Gateway set up that handles all my toll-free calling using a SIP URI to IdeaSip (who welcomes toll-free calls from anyone).

Is this the only setup needed?  http://www.obitalk.com/forum/index.php?topic=526.0

Tom

RonR

It's on that theme.

I set up Voice Gateway8:

Name : Toll Free
AccessNumber : SP2(proxy.ideasip.com)
DigitMap : (18(00|88|77|66|55)xxxxxxx|<1>8(00|88|77|66|55)xxxxxxx|!18005551212|!8005551212)

Then I added Voice Gateway8 to the PHONE Port DigitMap:

(...|(Mvg8)|(Mpli))

(placement is critical)

and PHONE Port OutboundCallRoute:

...,{(Mvg8):vg8},{(Mpli):pli}

(placement is critical)

Toll Free calls that would otherwise go out the PrimaryLine are plucked off and sent to Voice Gateway8 instead.

RonR

BTW, there are several providers that offer free, open to the public, toll-free termination:

tf.callwithus.com
sip.tollfreegateway.com
tollfreetollfree.com
tollfree.sip-happens.com
free.tollfree4free.com
proxy.ideasip.com

Blacky

I just called 800-555-1212 with my obi through gv and had no problem with any other toll free numbers am I going to have issues with calling toll free numbers?

tome

Quote from: Blacky on September 04, 2011, 12:54:02 PM
I just called 800-555-1212 with my obi through gv and had no problem with any other toll free numbers am I going to have issues with calling toll free numbers?

You won't know until you know  :-\  That is essentially why I was investigating this to begin with.
Tom

mo832

I know this thread is old, but I am having a problem with the same issue.

I have SP1 set to Callcentric right now, and if I dial **1**275*xxxxxx, once I hit the first * after the 1, I get an immediate error. Why won't it take any more stars? What do I need to change in the digit rules to allow me to enter the **275* or any other 3digit code after ** when I want to use a different provider? I would like to just be able to dial this manually with any 800 number of my choosing, so setting a speed dial would not work. I want it to recognize the **275*, and then accept the next 11 digits at face value, and send all of that to callcentric.

azrobert

Add the following to the ITSP A DigitMap:

**275*18(00|88|77|66|55|44)xxxxxxx

mo832

The number was rejected by the service provider. Reason 404.

I have tried this with various other strings given by RonR on other threads. Something like **275*x. or [x*][x*]. Same error every time. The voice message reads back the full key entry exactly as I dialed it, which should work.

But, if I place the FULL number in a speed dial like SP1(**275*18001234567), it will dial the number and complete the call.

What gives?  ???

azrobert


mo832

Currently from ITSP Profile A

(**275*18(00|88|77|66|55|44)xxxxxxx|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

azrobert

I hate dialing **n, so I removed all that code from my configuration. Therefore, I can't easily test the exact way you are dialing. I did successfully route a call out a SP trunk by dialing **275*18005551212.

Is SP1 your Phone Port Primary Line?

Do you want to route 800 numbers this way all the time? If yes, you can automatically add prefix "**275*" after dialing a 1-800 number.

Anyway, if SP1 is your Primary Line dial **275*18005551212.

If SP1 is not your Primary Line, add the following to the beginning of the Phone Port DigitMap:
(Msp1)|

Add above after the beginning paren.
Dial **275*18005551212

Dialing **1............. should work, so maybe something else is wrong.
Please post your Phone Port DigitMap

azrobert

I forgot something if SP1 is not your Primary Line.
Add ,{(Msp1):sp1} to the Phone Port OutboundCallRoute.

It must be to the right of rule {(Mpli):pli}