Sending a fax through Obi202?

Started by UserAsdf, July 02, 2012, 01:08:44 AM

Previous topic - Next topic

UserAsdf

Hello. When attempting to call a fax machine, the incoming audio is very quickly "cut off" when the answering fax machine begins emitting tones. The line remains open, but no audio from the answering side is allowed through. This happens when using both Callcentric and voip.ms through my Obi202.

When calling the same numbers using softphones, everything appears to be fine.

I've been sending/receiving faxes on Vonage for over 8 years with an ancient ATA, so I know faxing over voip works. ;D

Does something need to be changed in my Obi202 to allow faxing through it?

???

pc44

Hi UserAsdf,

Here's a stab in the dark.

I wonder if the quick "cut off" is the OBI is misunderstanding the initial fax tones as some sort of DTMF.  If so, one thought is to try different options for the DTMFMethod under...

Service Providers -> ITSP Profile AorB -> General -> DTMFMethod ->

Also, do you know what codec is in use during these attempted fax calls?  During the call, if you check Status -> Call Status -> Audio Codec, it should tell you what codec is in play during the call.  I've heard of people having better success faxing with G711 on CC, and I've heard of people having better success faxing with T.38 on CC.  So, trying each might help figure this out. :)

pc44

UserAsdf

Hello. This is what I suspected also, but I'm not sure what to do about it.

I've tried changing the DTMFMethod to both Inband and RFC2833, disabling all codecs except T.38, and trying both phone ports.

At all times, the call status page shows G711 is in use. I would try forcing T.38 if I knew how. :)

pc44

UserAsdf,

Sadly, I'm not sure how to enforce T.38 either and have been unable to find much documentation regarding the use of T.38 in the admin guide.  Additionally, I am not yet setup for T.38 and so cannot test this out just yet.  I hope to be ready for T.38 service within a month, as I have been really looking forward to this capability on the OBI202.

In the interim, here is a link to a thread on another forum that talks about T.38 success with CC, albeit they are using a SPA2102.  Still, it might offer some tips or insight into getting our OBIs working.

If you discover anything, be sure to let me know! ;)
pc44

Ostracus

From the admin guide.

QuoteThere are two Codec Profiles available on OBi devices.  They are selectable Per Trunk (SP1/SP2/SP3/SP4/OBiTALK). To select a codec as the preferred codec in this profile, set the priority of that codec to be highest among all the enabled codecs in this profile. Each of the SP1, SP2, SP3, SP4, and OBiTALK services can be assigned a codec profile in its corresponding configuration. The codec list to use when setting up a call on the underlying service is formed from the list of enabled codecs in the chosen profile and ordered according to the assigned priorities in the profile.

There is also a star code for forcing a codec on a per call basis.


Code25
Default = Force G711u Codec Star Code  *4711, Use G711 Only, set($Cdm1,3)

Code26
Default = Force G729 Codec Star Code  *4729, Use G729 Only, set($Cdm1,4)


And I believe someone had mentioned that a provider that does T.38 (Callcentric does) may be needed for reliable faxing.

What would be nice to debug any problems is a faxing endpoint that one can fax to and see what's received on the other end. As well as fax back so one can see the same.

QBZappy

Quote from: Ostracus on July 03, 2012, 10:26:27 PM
What would be nice to debug any problems is a faxing endpoint that one can fax to and see what's received on the other end. As well as fax back so one can see the same.

You can try these fax services out to test the fax machine.

Testing Your HP Fax Machine with the HP Fax Test Service
http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&dlc=en&cc=us&docname=c00259105

http://faxtoy.net/ (Check out their web page to see your sent fax.

http://faxzero.com/  (send and receive. Look at the PDF emailed to you)
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

UserAsdf

I've "forced" G711a and G711u by adjusting priorities in the codec profiles and confirmed usage in the call status page. The problem persists.

The problem is the Obi202 is almost immediately cutting the answering side's audio when it begins emitting fax tones.

I hear the answering fax tone for about half a second, then the line goes "dead" on the answering side. This prevents a fax transmission from even beginning.

Is it possible I have a defective Obi202? Or could it be a known firmware issue?

HardwareVersion   1.3   help
SoftwareVersion   3.0.0 (Build: 3184M)

Ostracus

Thanks QBZappy, that'll help a lot.

pc44

Hi Ostracus,

Quote from: Ostracus on July 03, 2012, 10:26:27 PMThere is also a star code for forcing a codec on a per call basis.

Thanks for trying to help, but this does not apply to the T.38 in question.  Neither does the Star Code enforcement option.  Again, this is all according to the admin guide, which only mentions T.38 two times, one of which is on the title page. :D

Quote from: Ostracus on July 03, 2012, 10:26:27 PMAnd I believe someone had mentioned that a provider that does T.38 (Callcentric does) may be needed for reliable faxing.

You cannot use T.38 unless your provider supports it.


I'm looking for a way to select and force T.38 use.

Any thoughts anyone?
pc44

QBZappy

pc44,

One way I can think of doing it is to choose one of the Codec Profiles A/B to be exclusively for T38 (Fax codec).

For example Choose:
Codecs->Codec Profile A-> Disable all the codecs except the T38 codec. Assign that codec to the SP1/2/3/4 account you will be sending faxes with. Assign the other Codec profile to the remaining SP accounts you plan on using for voice calls.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

pc44

QBZappy,

Great idea.  As alluded to earlier, I do not currently have a VoIP provider with T.38 support but hope to have that capability during the next month approximately.

In the meantime, I set my Codec Profile B to disable all Codecs, with the exception of T.38.  I tested this profile with GV on my SP4 (SP4 Service -> X_CodecProfile: B), and the call completed, albeit by kicking SP4 back down to G711U, (Call Status: tx=G711U; rx=G711U).

Perhaps the Codec Profile configurations do not apply to GV, because apparently even with the G711U Codec Disabled, the call is still placed using G711U.  If this is the case, I shall have to wait until I have a T.38 VoIP provider at my disposal to further test.

Thank you for this input!
pc44

Ostracus

Please note that the codec is limited to G711u only for all calls. In reference to GV in the admin guide.

UserAsdf

Am I the only person having problems with the Obi202 silencing the answering end almostly immediately after the answering fax machine begins sending fax tones?

QBZappy

UserAsdf,

Forget about voipms. We've been there before. Voipms is useless for fax. Try forcing the T38 as I mentioned above and try again with CC.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

UserAsdf

I've already tried disabling all codecs except T.38 a few days ago. That resulted in an error message saying something about the service provider not supporting the call or something. I can't remember the exact error message. I can give it another try tomorrow for an exact error message. (Currently rushing out the door for festivities :))

I've been focusing on Callcentric since voip.ms doesn't advertise anything regarding fax capability. I did try voip.ms a few times out of curiosity. The same thing happens with both providers via my Obi202.

I've also submitted screenshots of my Obi configs to Callcentric, and they didn't find anything obvious to correct.

Both providers pass the answering fax tones perfectly (to my ears) when using softphones, so it's definitely an Obi issue.

I'm inclined to believe I have a defective unit, so I've already placed an order for a new one and I'll be sending this one back. If I find a solution before then, then I'll keep both. ;D

QBZappy

Have a look above. I have a post where you can test with several fax services. Give that a try.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

UserAsdf

Sorry, I guess I'm not being clear enough. I'll try again. :)

The fax never even begins transmission because the answering fax machine's tones are being cut off by the Obi202 almost immediately.

It's not a matter of fax quality or fax errors. The issue is the Obi not allowing the fax tones to come through on the line at all. I've tried multiple fax numbers.

QBZappy

#17
UserAsdf,

I have reread your entries more carefully. You may still have a defective unit, however I can suggest a few other things to try.

Checklist
1) You are certain that that the Service Provider supports T38 codec? From this reply it doesn't sound like it. Just to be clear, was it the OBiMAN voice or a CC voice message?

Quote from: UserAsdf on July 04, 2012, 04:20:21 PM
I've already tried disabling all codecs except T.38 a few days ago. That resulted in an error message saying something about the service provider not supporting the call or something.

2) You obviously have followed the CC fax FAQ (http://www.callcentric.com/faq/30#205 )

Fax Machine: Try using the slowest possible speed on your fax machine. Normally 9.6k or 14.4k would be the best options, as speeds faster than 14.4k may not work properly with faxing. Disable error correction

T.38: Enable T.38.Disable echo cancellation and echo suppression. If available enable re-INVITE for faxes

Pass through:Try using the G711 codecs as these would offer more bandwidth.Disable echo cancellation and echo suppression Disable NSE, usually on Cisco/Linksys devices

Quote from: UserAsdf on July 02, 2012, 02:02:01 PM
At all times, the call status page shows G711 is in use. I would try forcing T.38 if I knew how. :)

I show a way how to force T38 codec up above. I assume you did the exact thing. You are certain that the fax is going over the CC trunk. I would try **1 or **2 before the fax number just to make sure you force it over the correct trunk. Since it shows using G711 it might be going over your GV account (if you have one, you didn't mention it).


Quote from: UserAsdf on July 04, 2012, 05:00:31 PM
The fax never even begins transmission because the answering fax machine's tones are being cut off by the Obi202 almost immediately.

I think that could be a symptom of many things including a codec issue, it may not have anything to do with a faulty OBi.

Failing the lack of proper Obihai documentation, I am forced to scavenge from other sources. We can find T38 Fax relay explained here: (May not be completely relevant to the OBi)

http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/cisco_ios_fax_services_over_ip_application_guide/t38.html#wp1158066

SIP T.38 Fax Relay

•The transport protocols specified in the ITU-T recommendation for T.38 are Transmission Control Protocol (TCP) and User Datagram Protocol (UDP). However, for T.38 fax relay on Cisco gateways, only UDP is supported for the transport layer.

•If SIP T.38 fax relay is not supported by both gateways, the T.38 negotiation fails and the call reverts to an audio codec. <-- NB This might be what is happening to you.

•T.38 fax relay requires a 64-kbps transmission rate, the same amount of bandwidth as a voice call with the G.711 codec.

•Fax Calling Tones (CNG) are optional and are not used to initiate a switch to T.38 mode. Instead, Called Station Identifier (CED) tones or preamble flags are used.

•SIP fax relay does not rely on NSEs to signal a switch to T.38 mode. Standard RFC 2543 and RFC 2327 SIP and SDP signaling are used instead.

•If the fax rate disable command is configured on a dial peer, neither the originating nor the terminating gateway can enter into Cisco fax relay mode, T.38 fax relay mode, or fax pass-through mode. The fax rate disable command disables fax transfer support.

Hope this helps. I'm surprised that someone else with a CC fax setup has not replied to you directly.
Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.

UserAsdf

Hello, and thanks for re-reading my posts! :)

Quote from: QBZappy on July 05, 2012, 08:56:39 AM
1) You are certain that that the Service Provider supports T38 codec? From this reply it doesn't sound like it. Just to be clear, was it the OBiMAN voice or a CC voice message?

I've been using Callcentric for all of my fax testing, with the few voip.ms tests just to satisfy curiosity.

The error message came from the Obi device and not CC.

I disabled the following codecs when attempting to "force" T.38: G711u, G711a, G729, G726R32, iLBC

Quote from: QBZappy on July 05, 2012, 08:56:39 AM
2) You obviously have followed the CC fax FAQ (http://www.callcentric.com/faq/30#205 )

Fax Machine: Try using the slowest possible speed on your fax machine. Normally 9.6k or 14.4k would be the best options, as speeds faster than 14.4k may not work properly with faxing. Disable error correction

Windows 7 Fax & Scan won't allow me to change the fax or port speed of my usb faxmodem, but I'm not sure if that's relevant when fax negotiation never even occurs due to the answering fax tones being silenced by the Obi202.

Quote from: QBZappy on July 05, 2012, 08:56:39 AM
T.38: Enable T.38.Disable echo cancellation and echo suppression. If available enable re-INVITE for faxes

Pass through:Try using the G711 codecs as these would offer more bandwidth.Disable echo cancellation and echo suppression Disable NSE, usually on Cisco/Linksys devices

I attempted to call fax machines and confirmed both G711a and G711u were in use via the Obi202 call status page. Neither codec seemed to help.

I also sent screenshots of my config pages to Callcentric, and they couldn't find anything set incorrectly.

Quote from: QBZappy on July 05, 2012, 08:56:39 AM
I show a way how to force T38 codec up above. I assume you did the exact thing. You are certain that the fax is going over the CC trunk. I would try **1 or **2 before the fax number just to make sure you force it over the correct trunk. Since it shows using G711 it might be going over your GV account (if you have one, you didn't mention it).

I did confirm the calls were going over Callcentric both via the Obi202 call status page and by calling my own fax number hosted by Callcentric. (Doing the latter results in voicemail prompts)

I also sent a support ticket to Obi via this url a few days ago:
http://obihai.com/supportTicketForm.php

but I haven't received a response yet. I linked this thread url in the support request.

pc44

Quote from: UserAsdf on July 05, 2012, 01:44:41 PMWindows 7 Fax & Scan won't allow me to change the fax or port speed of my usb faxmodem, but I'm not sure if that's relevant when fax negotiation never even occurs due to the answering fax tones being silenced by the Obi202.

Hi UserAsdf,

It may not be relevant, but if you want to adjust the maximum port speed for your fax modem, on your Windows 7 PC, I would go to Control Panel -> System and Security -> System -> Device Manager -> Modems -> Your Modem.  Double-click on your modem entry.  This should open another window.  In this window, choose the tab marked "Modem."  Here you should see a Maximum Port Speed setting.  The thread that I referenced earlier regarding fax usage with CC suggested a speed of 14400; however, QBZappy's 9600 suggestion is probably a safer choice.

Again, it may not help, but I thought I'd just mention that.  Also, from the thread I reference earlier, if it turns out that your OBI is not defective, I do think your best route is to see if anyone at CC is willing to directly troubleshoot your situation.  As you are an active, paying customer of their service, they might.

Hope you get this eventually solved, :)
pc44